Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Количество строк в колонку от заданного числа - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество строк в колонку от заданного числа (Формулы/Formulas)
Количество строк в колонку от заданного числа
Oh_Nick Дата: Пятница, 27.10.2023, 13:35 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 445
Репутация: 8 ±
Замечаний: 20% ±

Excel 2019
Всем привет!

Файл пример приложил. Подскажите, пожалуйста, измененную формулу для 2007 экселя. Там сейчас прописана[offtop] , но 2007 ее не читает...
К сообщению приложен файл: 6939121.xlsx (12.5 Kb)
 
Ответить
СообщениеВсем привет!

Файл пример приложил. Подскажите, пожалуйста, измененную формулу для 2007 экселя. Там сейчас прописана[offtop] , но 2007 ее не читает...

Автор - Oh_Nick
Дата добавления - 27.10.2023 в 13:35
bigor Дата: Пятница, 27.10.2023, 16:10 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1100
Репутация: 210 ±
Замечаний: 0% ±

нет
Привет.
Получилось коряво и 2 мя формулами, но в 2010 работает нормально
в H1
Код
=A1

в H2 и ниже
Код
=ЕСЛИ(СУММ(B$1:ИНДЕКС($B$1:$B$3;ПОИСКПОЗ(H1;$A$1:$A$3;0)))>=СТРОКА();H1;ИНДЕКС($A$1:$A$3;СЧЁТ(B$1:ИНДЕКС($B$1:$B$3;ПОИСКПОЗ(H1;$A$1:$A$3;0)))+1))
К сообщению приложен файл: oh_nick_231027_1.xlsx (7.7 Kb)
 
Ответить
СообщениеПривет.
Получилось коряво и 2 мя формулами, но в 2010 работает нормально
в H1
Код
=A1

в H2 и ниже
Код
=ЕСЛИ(СУММ(B$1:ИНДЕКС($B$1:$B$3;ПОИСКПОЗ(H1;$A$1:$A$3;0)))>=СТРОКА();H1;ИНДЕКС($A$1:$A$3;СЧЁТ(B$1:ИНДЕКС($B$1:$B$3;ПОИСКПОЗ(H1;$A$1:$A$3;0)))+1))

Автор - bigor
Дата добавления - 27.10.2023 в 16:10
Oh_Nick Дата: Пятница, 27.10.2023, 16:38 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 445
Репутация: 8 ±
Замечаний: 20% ±

Excel 2019
bigor, оч круто, спасибо!
 
Ответить
Сообщениеbigor, оч круто, спасибо!

Автор - Oh_Nick
Дата добавления - 27.10.2023 в 16:38
Egyptian Дата: Пятница, 27.10.2023, 22:49 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 514
Репутация: 185 ±
Замечаний: 0% ±

Excel 2013/2016
Вариант. Вводить через CTRL+SHIFT+ENTER
Код
=IF(ROWS(I$1:I1)>SUM($B$1:$B$3);"";INDEX($A$1:$A$3;MATCH(TRUE;MMULT(--(ROW($A$1:$A$3)>=TRANSPOSE(ROW($A$1:$A$3)));--$B$1:$B$3)>=ROWS(I$1:I1);0)))
 
Ответить
СообщениеВариант. Вводить через CTRL+SHIFT+ENTER
Код
=IF(ROWS(I$1:I1)>SUM($B$1:$B$3);"";INDEX($A$1:$A$3;MATCH(TRUE;MMULT(--(ROW($A$1:$A$3)>=TRANSPOSE(ROW($A$1:$A$3)));--$B$1:$B$3)>=ROWS(I$1:I1);0)))

Автор - Egyptian
Дата добавления - 27.10.2023 в 22:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество строк в колонку от заданного числа (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!