Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проверка введённых данных по условию. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка введённых данных по условию. (Формулы/Formulas)
Проверка введённых данных по условию.
gidroliz Дата: Четверг, 02.11.2023, 17:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Доброго времени суток.
Буду благодарен если поможете с реализацией проверки по условиям.
Имею таблицу и множества строк в которой всего 6 столбцов с ячейками.
В первом - A1 - будет вестись автоматическая нумерация заполненных строк.
Мне нужно сделать проверку ячеек - B1:F1 на предмет правильности заполнения, условием чего является запрет ввода букв кириллицы.
Было бы хорошо, если все 5 ячеек в строке не имеют введённых данных/значений, то в ячейке - G1 ничего не отображалось.
Если пользователь ввёл символ кириллицы, то появилось предупреждение - вводимый текст должен быть латиницей
Если все 5 ячеек в строке заполнены латиницей, символами и цифрами то появился символ - галочка

Я пробовал осуществлять проверку формулой -
Код
=СЧЁТ(ПОИСК({"а":"А":"б":"Б":"в":"В":"г":"Г":"д":"Д":"е":"Е":"ё":"Ё":"ж":"Ж":"з":"З":"и":"И":"й":"Й":"к":"К":"л":"Л":"м":"М":"н":"Н":"о":"О":"п":"П":"р":"Р":"с":"С":"т":"Т":"у":"У":"ф":"Ф":"х":"Х":"ц":"Ц":"ч":"Ч":"ш":"Ш":"щ":"Щ":"ъ":"Ъ":"ы":"Ы":"ь":"Ь":"э":"Э":"ю":"Ю":"я":"Я"};B5:F5))>1

и
Код
=ЕСЛИ(L5=ЛОЖЬ();"✓";"вводимый текст должен быть латиницей")

Но не смог реализовать условие при котором все 5 ячеек в строке не имеют введённых данных/значений, то в ячейке - G1 ничего не отображалось.
 
Ответить
СообщениеДоброго времени суток.
Буду благодарен если поможете с реализацией проверки по условиям.
Имею таблицу и множества строк в которой всего 6 столбцов с ячейками.
В первом - A1 - будет вестись автоматическая нумерация заполненных строк.
Мне нужно сделать проверку ячеек - B1:F1 на предмет правильности заполнения, условием чего является запрет ввода букв кириллицы.
Было бы хорошо, если все 5 ячеек в строке не имеют введённых данных/значений, то в ячейке - G1 ничего не отображалось.
Если пользователь ввёл символ кириллицы, то появилось предупреждение - вводимый текст должен быть латиницей
Если все 5 ячеек в строке заполнены латиницей, символами и цифрами то появился символ - галочка

Я пробовал осуществлять проверку формулой -
Код
=СЧЁТ(ПОИСК({"а":"А":"б":"Б":"в":"В":"г":"Г":"д":"Д":"е":"Е":"ё":"Ё":"ж":"Ж":"з":"З":"и":"И":"й":"Й":"к":"К":"л":"Л":"м":"М":"н":"Н":"о":"О":"п":"П":"р":"Р":"с":"С":"т":"Т":"у":"У":"ф":"Ф":"х":"Х":"ц":"Ц":"ч":"Ч":"ш":"Ш":"щ":"Щ":"ъ":"Ъ":"ы":"Ы":"ь":"Ь":"э":"Э":"ю":"Ю":"я":"Я"};B5:F5))>1

и
Код
=ЕСЛИ(L5=ЛОЖЬ();"✓";"вводимый текст должен быть латиницей")

Но не смог реализовать условие при котором все 5 ячеек в строке не имеют введённых данных/значений, то в ячейке - G1 ничего не отображалось.

Автор - gidroliz
Дата добавления - 02.11.2023 в 17:12
Pelena Дата: Четверг, 02.11.2023, 17:18 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 19197
Репутация: 4423 ±
Замечаний: ±

Excel 365 & Mac Excel
Здравствуйте.
Файл с примером помог бы в понимании проблемы


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Файл с примером помог бы в понимании проблемы

Автор - Pelena
Дата добавления - 02.11.2023 в 17:18
gidroliz Дата: Пятница, 03.11.2023, 09:57 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Прошу прощения, в вложении прикрепил файл, то что сделал сам, но хотелось бы с учётом выше приведённых условий
Цитата
если все 5 ячеек в строке не имеют введённых данных/значений, то в ячейке - G1 ничего не отображалось.
, и если возможно без использования I4 - в которой формула.
К сообщению приложен файл: konkurs_01.xlsx (39.8 Kb)
 
Ответить
СообщениеПрошу прощения, в вложении прикрепил файл, то что сделал сам, но хотелось бы с учётом выше приведённых условий
Цитата
если все 5 ячеек в строке не имеют введённых данных/значений, то в ячейке - G1 ничего не отображалось.
, и если возможно без использования I4 - в которой формула.

Автор - gidroliz
Дата добавления - 03.11.2023 в 09:57
Nic70y Дата: Пятница, 03.11.2023, 10:32 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 8791
Репутация: 2293 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(СЧЁТЗ(Table_2[@[Column2]:[Column6]]);ЕСЛИ(СЧЁТ(ПОИСК({"а":"б":"в":"г":"д":"е":"ё":"ж":"з":"и":"й":"к":"л":"м":"н":"о":"п":"р":"с":"т":"у":"ф":"х":"ц":"ч":"ш":"щ":"ъ":"ы":"ь":"э":"ю":"я"};Table_2[@[Column2]:[Column6]]));"<- вводимый текст должен быть латиницей";"✓");"")
К сообщению приложен файл: konkurs_02.xlsx (38.1 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(СЧЁТЗ(Table_2[@[Column2]:[Column6]]);ЕСЛИ(СЧЁТ(ПОИСК({"а":"б":"в":"г":"д":"е":"ё":"ж":"з":"и":"й":"к":"л":"м":"н":"о":"п":"р":"с":"т":"у":"ф":"х":"ц":"ч":"ш":"щ":"ъ":"ы":"ь":"э":"ю":"я"};Table_2[@[Column2]:[Column6]]));"<- вводимый текст должен быть латиницей";"✓");"")

Автор - Nic70y
Дата добавления - 03.11.2023 в 10:32
alexa1965 Дата: Пятница, 03.11.2023, 10:37 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 343
Репутация: 55 ±
Замечаний: 0% ±

2003> 2019 >2016
Добрый день! Без формулы в ячейке I4 пожалуйста
Код
=ЕСЛИ((СЧЁТ(ПОИСК({"а":"А":"б":"Б":"в":"В":"г":"Г":"д":"Д":"е":"Е":"ё":"Ё":"ж":"Ж":"з":"З":"и":"И":"й":"Й":"к":"К":"л":"Л":"м":"М":"н":"Н":"о":"О":"п":"П":"р":"Р":"с":"С":"т":"Т":"у":"У":"ф":"Ф":"х":"Х":"ц":"Ц":"ч":"Ч":"ш":"Ш":"щ":"Щ":"ъ":"Ъ":"ы":"Ы":"ь":"Ь":"э":"Э":"ю":"Ю":"я":"Я"};C4:G4))>1)=ЛОЖЬ();"✓";"<- вводимый текст должен быть латиницей")
формула массивная, а вот что должно быть в ячейке G1, которая фактически из-за объединения ячеей является В1 непонятно


Главное не быть балабастиком
 
Ответить
СообщениеДобрый день! Без формулы в ячейке I4 пожалуйста
Код
=ЕСЛИ((СЧЁТ(ПОИСК({"а":"А":"б":"Б":"в":"В":"г":"Г":"д":"Д":"е":"Е":"ё":"Ё":"ж":"Ж":"з":"З":"и":"И":"й":"Й":"к":"К":"л":"Л":"м":"М":"н":"Н":"о":"О":"п":"П":"р":"Р":"с":"С":"т":"Т":"у":"У":"ф":"Ф":"х":"Х":"ц":"Ц":"ч":"Ч":"ш":"Ш":"щ":"Щ":"ъ":"Ъ":"ы":"Ы":"ь":"Ь":"э":"Э":"ю":"Ю":"я":"Я"};C4:G4))>1)=ЛОЖЬ();"✓";"<- вводимый текст должен быть латиницей")
формула массивная, а вот что должно быть в ячейке G1, которая фактически из-за объединения ячеей является В1 непонятно

Автор - alexa1965
Дата добавления - 03.11.2023 в 10:37
gidroliz Дата: Понедельник, 06.11.2023, 17:24 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Премного всем благодарен.
hands
 
Ответить
СообщениеПремного всем благодарен.
hands

Автор - gidroliz
Дата добавления - 06.11.2023 в 17:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка введённых данных по условию. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!