Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как учесть объедененные ячейки при подсчете ? Пример во влое - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как учесть объедененные ячейки при подсчете ? Пример во влое (Формулы/Formulas)
Как учесть объедененные ячейки при подсчете ? Пример во влое
Дмитрий1249 Дата: Суббота, 04.11.2023, 11:07 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 20% ±

1
Здравствуйте! Прошу Вашей помощи написал формулу но к сожалению при подсчете не считаются ячейки объединенные избавиться от них не представляется возможным , помогите пример во вложении
К сообщению приложен файл: 6999265.xlsx (10.7 Kb)
 
Ответить
СообщениеЗдравствуйте! Прошу Вашей помощи написал формулу но к сожалению при подсчете не считаются ячейки объединенные избавиться от них не представляется возможным , помогите пример во вложении

Автор - Дмитрий1249
Дата добавления - 04.11.2023 в 11:07
cmivadwot Дата: Суббота, 04.11.2023, 14:24 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 452
Репутация: 86 ±
Замечаний: 0% ±

365
Дмитрий1249, День добрый. Немного корявенько (из-за повторов, когда значения в А столбце закончатся), и доп столбец, должно работать....
К сообщению приложен файл: ljg_cnjk_wjv.xlsx (17.7 Kb)


Сообщение отредактировал cmivadwot - Суббота, 04.11.2023, 14:25
 
Ответить
СообщениеДмитрий1249, День добрый. Немного корявенько (из-за повторов, когда значения в А столбце закончатся), и доп столбец, должно работать....

Автор - cmivadwot
Дата добавления - 04.11.2023 в 14:24
Дмитрий1249 Дата: Суббота, 04.11.2023, 15:26 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 20% ±

1
Спасибо! понятно в каком направлении нужно двигаться ) нужно создать доп столбец в листе данных, формула которая вбивается в дополнительный столбец можно её как то расшифровать если не затруднит что бы правильно ввести в свой архив.
 
Ответить
СообщениеСпасибо! понятно в каком направлении нужно двигаться ) нужно создать доп столбец в листе данных, формула которая вбивается в дополнительный столбец можно её как то расшифровать если не затруднит что бы правильно ввести в свой архив.

Автор - Дмитрий1249
Дата добавления - 04.11.2023 в 15:26
cmivadwot Дата: Суббота, 04.11.2023, 15:47 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 452
Репутация: 86 ±
Замечаний: 0% ±

365
Дмитрий1249, а про какую? Если то, то это. Есито и то и то то))) там вроде и так понятно..
=ЕСЛИ(значение ячейки A2>0; то A2;ЕСЛИ(И(ячейка A2=0;и ячейка C1>0);то C1))
скопировать, вставить, протянуть вниз....


Сообщение отредактировал cmivadwot - Суббота, 04.11.2023, 16:02
 
Ответить
СообщениеДмитрий1249, а про какую? Если то, то это. Есито и то и то то))) там вроде и так понятно..
=ЕСЛИ(значение ячейки A2>0; то A2;ЕСЛИ(И(ячейка A2=0;и ячейка C1>0);то C1))
скопировать, вставить, протянуть вниз....

Автор - cmivadwot
Дата добавления - 04.11.2023 в 15:47
Дмитрий1249 Дата: Суббота, 04.11.2023, 16:26 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 20% ±

1
Да попробовал перенести вообщем получилось . но саму формулу не пойму ) посмотрел видео про если, вроде понятно, смотрю свой пример не фига )

=ЕСЛИ(значение ячейки A2>0; то A2;ЕСЛИ(И(ячейка A2=0;и ячейка C1>0);то C1))

если ячейка А2 больше 0 то она будет равно внесенному в неё значению а если она равно 0 и при этом ячейка С1 больше 0 .... причем тут С1 ? там вроде пустота шапка

В любом случае Вам спасибо будем пробовать на архиве
 
Ответить
СообщениеДа попробовал перенести вообщем получилось . но саму формулу не пойму ) посмотрел видео про если, вроде понятно, смотрю свой пример не фига )

=ЕСЛИ(значение ячейки A2>0; то A2;ЕСЛИ(И(ячейка A2=0;и ячейка C1>0);то C1))

если ячейка А2 больше 0 то она будет равно внесенному в неё значению а если она равно 0 и при этом ячейка С1 больше 0 .... причем тут С1 ? там вроде пустота шапка

В любом случае Вам спасибо будем пробовать на архиве

Автор - Дмитрий1249
Дата добавления - 04.11.2023 в 16:26
cmivadwot Дата: Суббота, 04.11.2023, 16:44 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 452
Репутация: 86 ±
Замечаний: 0% ±

365
Цитата Дмитрий1249, 04.11.2023 в 16:26, в сообщении № 5 ()
причем тут С1 ?
при том, что при условии... что в А2=0.. т.е. пошли объединенные ячейки и значение берется с ячейки С1, а когда и А3 будет равно 0 то с С2. я набрал составил формулу 1 раз не пошло, поменял условия - протянул.. заработало. там по идее еще не хватает в конце значения ложь, но оно и не нужно. Попробуйте переусловить))) как то аналогично делал не было косяков с повтором ври окончании значений в А.
проверил... да лишнее... это от старого варианта осталось
Код
=ЕСЛИ(A2>0;A2;ЕСЛИ(A2=0;C1))
и так работает


Сообщение отредактировал cmivadwot - Суббота, 04.11.2023, 16:53
 
Ответить
Сообщение
Цитата Дмитрий1249, 04.11.2023 в 16:26, в сообщении № 5 ()
причем тут С1 ?
при том, что при условии... что в А2=0.. т.е. пошли объединенные ячейки и значение берется с ячейки С1, а когда и А3 будет равно 0 то с С2. я набрал составил формулу 1 раз не пошло, поменял условия - протянул.. заработало. там по идее еще не хватает в конце значения ложь, но оно и не нужно. Попробуйте переусловить))) как то аналогично делал не было косяков с повтором ври окончании значений в А.
проверил... да лишнее... это от старого варианта осталось
Код
=ЕСЛИ(A2>0;A2;ЕСЛИ(A2=0;C1))
и так работает

Автор - cmivadwot
Дата добавления - 04.11.2023 в 16:44
DrMini Дата: Суббота, 04.11.2023, 17:36 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1635
Репутация: 204 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Добрый вечер Дмитрий1249,
Посмотрите вот такой вариант:
Код
=СУММПРОИЗВ((ПРОСМОТР(СТРОКА('Страница с данными '!$A$2:$A$500);СТРОКА('Страница с данными '!$A$2:$A$500)/('Страница с данными '!$A$2:$A$500<>"");'Страница с данными '!$A$2:$A$500)=A2)*'Страница с данными '!$B$2:$B$500)

сделал на 500 строк измените на своё число строк.
К сообщению приложен файл: 1403328.xlsx (12.3 Kb)
 
Ответить
СообщениеДобрый вечер Дмитрий1249,
Посмотрите вот такой вариант:
Код
=СУММПРОИЗВ((ПРОСМОТР(СТРОКА('Страница с данными '!$A$2:$A$500);СТРОКА('Страница с данными '!$A$2:$A$500)/('Страница с данными '!$A$2:$A$500<>"");'Страница с данными '!$A$2:$A$500)=A2)*'Страница с данными '!$B$2:$B$500)

сделал на 500 строк измените на своё число строк.

Автор - DrMini
Дата добавления - 04.11.2023 в 17:36
Дмитрий1249 Дата: Суббота, 04.11.2023, 19:16 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 20% ±

1
Всех благодарю за оказанную помощь! Спасибо!
 
Ответить
СообщениеВсех благодарю за оказанную помощь! Спасибо!

Автор - Дмитрий1249
Дата добавления - 04.11.2023 в 19:16
Hugo Дата: Понедельник, 06.11.2023, 22:43 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3251
Репутация: 707 ±
Замечаний: 0% ±

2019
Цитата Дмитрий1249, 04.11.2023 в 15:26, в сообщении № 3 ()
понятно в каком направлении нужно двигаться
- если это ваша таблица, и эти объединения ставите сами, или это шаблон - то можно доработать объединения чтобы в них каждая ячейка содержала значение, и тогда не придётся добавлять столбец или усложнять все формулы по анализу этих данных.


excel@nxt.ru
webmoney: E265281470651 Z422237915069
 
Ответить
Сообщение
Цитата Дмитрий1249, 04.11.2023 в 15:26, в сообщении № 3 ()
понятно в каком направлении нужно двигаться
- если это ваша таблица, и эти объединения ставите сами, или это шаблон - то можно доработать объединения чтобы в них каждая ячейка содержала значение, и тогда не придётся добавлять столбец или усложнять все формулы по анализу этих данных.

Автор - Hugo
Дата добавления - 06.11.2023 в 22:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как учесть объедененные ячейки при подсчете ? Пример во влое (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!