Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для указания общего для всех колонок слова - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для указания общего для всех колонок слова (Формулы/Formulas)
Формула для указания общего для всех колонок слова
350 Дата: Суббота, 04.11.2023, 17:33 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 60% ±

Добрый вечер!
Скорее всего это очень простая задача, но все же обращусь с профессионалам Excel за помощью.
Если в одной из трех колонок упоминается слово Яблоко, то в колонке Результат появляетя слово Яблоко
Если нет слова Яблоко ни в одной из колонок, то указать 0.

Заранее благодарю!
К сообщению приложен файл: forum_04_11_23.xlsx (8.9 Kb)
 
Ответить
СообщениеДобрый вечер!
Скорее всего это очень простая задача, но все же обращусь с профессионалам Excel за помощью.
Если в одной из трех колонок упоминается слово Яблоко, то в колонке Результат появляетя слово Яблоко
Если нет слова Яблоко ни в одной из колонок, то указать 0.

Заранее благодарю!

Автор - 350
Дата добавления - 04.11.2023 в 17:33
DrMini Дата: Суббота, 04.11.2023, 17:44 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Добрый вечер 350,
Можно так:
Код
=ЕСЛИ(СЧЁТЕСЛИ(A2:C2;"Яблоко")=1;"Яблоко";0)

или так:
Код
=ЕСЛИОШИБКА(ГПР("Яблоко";A2:C2;1;);0)

По Вашему примеру понял, что результат ищем в строках, а не в столбцах.


Сообщение отредактировал DrMini - Суббота, 04.11.2023, 18:02
 
Ответить
СообщениеДобрый вечер 350,
Можно так:
Код
=ЕСЛИ(СЧЁТЕСЛИ(A2:C2;"Яблоко")=1;"Яблоко";0)

или так:
Код
=ЕСЛИОШИБКА(ГПР("Яблоко";A2:C2;1;);0)

По Вашему примеру понял, что результат ищем в строках, а не в столбцах.

Автор - DrMini
Дата добавления - 04.11.2023 в 17:44
350 Дата: Суббота, 04.11.2023, 21:42 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 60% ±

Спасибо Вам большое!!!
Да, точнее, конечно, ищем по строкам
 
Ответить
СообщениеСпасибо Вам большое!!!
Да, точнее, конечно, ищем по строкам

Автор - 350
Дата добавления - 04.11.2023 в 21:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для указания общего для всех колонок слова (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!