Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод текста в зависимости от текста - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод текста в зависимости от текста (Формулы/Formulas)
Вывод текста в зависимости от текста
kvlar Дата: Суббота, 11.11.2023, 19:52 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте
Помогите, если возможно.
Нужно следующее решение
При вводе определенного текста в ячейку А1, в ячейке В1 должен появляться другой текст.
Например: В А1 ввожу "jghy5", а в В1 появляется "k8jr6"

При вводе в А1 иного текста, в В1, либо ничего, либо, например, слово "неверно" или что другое.

Решения из темы "Вывод текста в зависимости от данных" дают ошибку. (там в А1 обязательно должны быть только цифры"
Спасибо за любую помощь.
 
Ответить
СообщениеЗдравствуйте
Помогите, если возможно.
Нужно следующее решение
При вводе определенного текста в ячейку А1, в ячейке В1 должен появляться другой текст.
Например: В А1 ввожу "jghy5", а в В1 появляется "k8jr6"

При вводе в А1 иного текста, в В1, либо ничего, либо, например, слово "неверно" или что другое.

Решения из темы "Вывод текста в зависимости от данных" дают ошибку. (там в А1 обязательно должны быть только цифры"
Спасибо за любую помощь.

Автор - kvlar
Дата добавления - 11.11.2023 в 19:52
gling Дата: Суббота, 11.11.2023, 20:18 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2521
Репутация: 675 ±
Замечаний: 0% ±

2010
Здравствуйте.
В ячейку В1 впишите формулу
Код
=ЕСЛИ(A1="jghy5";"k8jr6";"Неверное значение в А1")


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
В ячейку В1 впишите формулу
Код
=ЕСЛИ(A1="jghy5";"k8jr6";"Неверное значение в А1")

Автор - gling
Дата добавления - 11.11.2023 в 20:18
kvlar Дата: Воскресенье, 12.11.2023, 08:16 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Спасибо огромное!
А можно усложнить?
Конечная цель такова:
Есть список пользователей (Например в ячейках А1-А5) 5 человек
В ячейки В1-В5 соответственно каждый вводит свой старый пароль, а в ячейках С1-С5 появляется их новый пароль.
При этом их старые пароли написаны в ячейках D1-D5, а новые в ячейках Е1-Е5. (т.е не писать данные в формуле, а сделать ссылку, т.к. пользователей много)
При этом содержимое D1-D5 и Е1-Е5, а так же формулы при щелчке в С1-С5 не должны быть видны.
Спасибо.
 
Ответить
СообщениеСпасибо огромное!
А можно усложнить?
Конечная цель такова:
Есть список пользователей (Например в ячейках А1-А5) 5 человек
В ячейки В1-В5 соответственно каждый вводит свой старый пароль, а в ячейках С1-С5 появляется их новый пароль.
При этом их старые пароли написаны в ячейках D1-D5, а новые в ячейках Е1-Е5. (т.е не писать данные в формуле, а сделать ссылку, т.к. пользователей много)
При этом содержимое D1-D5 и Е1-Е5, а так же формулы при щелчке в С1-С5 не должны быть видны.
Спасибо.

Автор - kvlar
Дата добавления - 12.11.2023 в 08:16
DrMini Дата: Воскресенье, 12.11.2023, 08:32 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1645
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
А можно усложнить?

Усложнить всегда можно.
Как вариант:
Код
=ЕСЛИ(B1="";"";ЕСЛИ(B1=D1;E1;"ошибка"))

Ячейки с паролями либо скрыть, либо перенести на другой лист и запаролить.

У Вас ведь будут пароли. А там важны буквы строчные или прописные, латиница или кириллица.
Вот вариант будет получше:
Код
=ЕСЛИ(B1="";"";ЕСЛИ(СОВПАД(B1;D1);E1;"ошибка"))

[p.s.]во втором варианте защита листа и книги без пароля.[/p.s.]
К сообщению приложен файл: Passwords.xlsx (10.2 Kb) · passwords2.xlsx (11.3 Kb)


Сообщение отредактировал DrMini - Воскресенье, 12.11.2023, 09:36
 
Ответить
Сообщение
А можно усложнить?

Усложнить всегда можно.
Как вариант:
Код
=ЕСЛИ(B1="";"";ЕСЛИ(B1=D1;E1;"ошибка"))

Ячейки с паролями либо скрыть, либо перенести на другой лист и запаролить.

У Вас ведь будут пароли. А там важны буквы строчные или прописные, латиница или кириллица.
Вот вариант будет получше:
Код
=ЕСЛИ(B1="";"";ЕСЛИ(СОВПАД(B1;D1);E1;"ошибка"))

[p.s.]во втором варианте защита листа и книги без пароля.[/p.s.]

Автор - DrMini
Дата добавления - 12.11.2023 в 08:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод текста в зависимости от текста (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!