Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск по разным столбцам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск по разным столбцам (Формулы/Formulas)
Поиск по разным столбцам
astashov_michail@tutby Дата: Воскресенье, 12.11.2023, 19:24 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 0 ±
Замечаний: 100% ±

2016
Добрый вечер. Возможно ли сократить формулу поиска, если значение поиска может находится в разных столбцах

=ЕСЛИОШИБКА(ИНДЕКС('1'!$G$5:$G$70;ПОИСКПОЗ(AE46;'1'!$F$5:$F$70;0));"0")+
ЕСЛИОШИБКА(ИНДЕКС('1'!$L$5:$L$70;ПОИСКПОЗ(AE46;'1'!$K$5:$K$70;0));"0")+
ЕСЛИОШИБКА(ИНДЕКС('1'!$B$5:$B$70;ПОИСКПОЗ(AE46;'1'!$A$5:$A$70;0));"0")


astashovM..
 
Ответить
СообщениеДобрый вечер. Возможно ли сократить формулу поиска, если значение поиска может находится в разных столбцах

=ЕСЛИОШИБКА(ИНДЕКС('1'!$G$5:$G$70;ПОИСКПОЗ(AE46;'1'!$F$5:$F$70;0));"0")+
ЕСЛИОШИБКА(ИНДЕКС('1'!$L$5:$L$70;ПОИСКПОЗ(AE46;'1'!$K$5:$K$70;0));"0")+
ЕСЛИОШИБКА(ИНДЕКС('1'!$B$5:$B$70;ПОИСКПОЗ(AE46;'1'!$A$5:$A$70;0));"0")

Автор - astashov_michail@tutby
Дата добавления - 12.11.2023 в 19:24
bmv98rus Дата: Воскресенье, 12.11.2023, 22:31 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4111
Репутация: 768 ±
Замечаний: 0% ±

Excel 2013/2016
astashov_michail@tutby, Приведите пример в файле. На вскидку SUMIF может сократить .


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениеastashov_michail@tutby, Приведите пример в файле. На вскидку SUMIF может сократить .

Автор - bmv98rus
Дата добавления - 12.11.2023 в 22:31
Gustav Дата: Воскресенье, 12.11.2023, 22:56 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2757
Репутация: 1139 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Цитата astashov_michail@tutby, 12.11.2023 в 19:24, в сообщении № 1 ()
Возможно ли сократить формулу поиска

Если имеете доступ к новым версиям Excel 365/2021++, то в них можно, объединяя по три отдельных столбца в виртуальные массивы (по отдельности для вектора просмотра и вектора результатов):
[vba]
Код
=ПРОСМОТРX(AE46;
ВСТОЛБИК('1'!$F$5:$F$70;'1'!$K$5:$K$70;'1'!$A$5:$A$70);
ВСТОЛБИК('1'!$G$5:$G$70;'1'!$L$5:$L$70;'1'!$B$5:$B$70);
"0")
[/vba]Можно также в Таблицах Гугл подобное провернуть. И даже в табличном редакторе отечественного Р-7 Офиса! Да-да, проверил лично, там уже есть эти функции - и ПРОСМОТРX, и ВСТОЛБИК.


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Воскресенье, 12.11.2023, 23:16
 
Ответить
Сообщение
Цитата astashov_michail@tutby, 12.11.2023 в 19:24, в сообщении № 1 ()
Возможно ли сократить формулу поиска

Если имеете доступ к новым версиям Excel 365/2021++, то в них можно, объединяя по три отдельных столбца в виртуальные массивы (по отдельности для вектора просмотра и вектора результатов):
[vba]
Код
=ПРОСМОТРX(AE46;
ВСТОЛБИК('1'!$F$5:$F$70;'1'!$K$5:$K$70;'1'!$A$5:$A$70);
ВСТОЛБИК('1'!$G$5:$G$70;'1'!$L$5:$L$70;'1'!$B$5:$B$70);
"0")
[/vba]Можно также в Таблицах Гугл подобное провернуть. И даже в табличном редакторе отечественного Р-7 Офиса! Да-да, проверил лично, там уже есть эти функции - и ПРОСМОТРX, и ВСТОЛБИК.

Автор - Gustav
Дата добавления - 12.11.2023 в 22:56
bmv98rus Дата: Воскресенье, 12.11.2023, 23:04 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4111
Репутация: 768 ±
Замечаний: 0% ±

Excel 2013/2016
а я за
Код
=SUMIF('1'!$A$5:$K$70;AE46;'1'!$B$5:$L$70)

:D


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениеа я за
Код
=SUMIF('1'!$A$5:$K$70;AE46;'1'!$B$5:$L$70)

:D

Автор - bmv98rus
Дата добавления - 12.11.2023 в 23:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск по разным столбцам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!