Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Index/MAtch по 2 критеряим, данные по оси Y, результат X - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Index/MAtch по 2 критеряим, данные по оси Y, результат X (Формулы/Formulas)
Index/MAtch по 2 критеряим, данные по оси Y, результат X
SVR3054 Дата: Понедельник, 13.11.2023, 20:33 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Уважаемые формучане, помогите, пожалуйста, с проблемой по функции Index Match. У меня 2 таблицы, в одной данные, в дргой резлутат, в таблице резльтат нужно поставить значения из таблицы с данными, но скорее всего в связи с тем что данные хранятся по горизонтали а резльтат нужен по вертикали функция Index Match не может подобрать значения. Точнее получается зацепить только часть значений из таблицы с данными, те данные что находятся в начале таблицы, может быть нужно какое другое решение использовать при таком формате данны? Прилагаю пример. Заранее благодарю за помощь.
К сообщению приложен файл: 5058860.xlsx (58.5 Kb)
 
Ответить
СообщениеУважаемые формучане, помогите, пожалуйста, с проблемой по функции Index Match. У меня 2 таблицы, в одной данные, в дргой резлутат, в таблице резльтат нужно поставить значения из таблицы с данными, но скорее всего в связи с тем что данные хранятся по горизонтали а резльтат нужен по вертикали функция Index Match не может подобрать значения. Точнее получается зацепить только часть значений из таблицы с данными, те данные что находятся в начале таблицы, может быть нужно какое другое решение использовать при таком формате данны? Прилагаю пример. Заранее благодарю за помощь.

Автор - SVR3054
Дата добавления - 13.11.2023 в 20:33
bmv98rus Дата: Понедельник, 13.11.2023, 21:03 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4106
Репутация: 768 ±
Замечаний: 0% ±

Excel 2013/2016
Если всеж преобразовать текст в третье строке данных в число то достаточно
Код
=SUMIFS('1'!$4:$4;'1'!$2:$2;$B12;'1'!$3:$3;$A12)
К сообщению приложен файл: example2896.xlsx (58.9 Kb)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Понедельник, 13.11.2023, 21:05
 
Ответить
СообщениеЕсли всеж преобразовать текст в третье строке данных в число то достаточно
Код
=SUMIFS('1'!$4:$4;'1'!$2:$2;$B12;'1'!$3:$3;$A12)

Автор - bmv98rus
Дата добавления - 13.11.2023 в 21:03
i691198 Дата: Понедельник, 13.11.2023, 21:47 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 218
Репутация: 85 ±
Замечаний: 0% ±

Добрый вечер. Попробуйте такую формулу.
Код
=ИНДЕКС('1'!$C$4:$AJ$4;ПОИСКПОЗ(1;('1'!$C$3:$AJ$3=A14)*('1'!$C$2:$AJ$2=B14);0))

Формула массивная.
 
Ответить
СообщениеДобрый вечер. Попробуйте такую формулу.
Код
=ИНДЕКС('1'!$C$4:$AJ$4;ПОИСКПОЗ(1;('1'!$C$3:$AJ$3=A14)*('1'!$C$2:$AJ$2=B14);0))

Формула массивная.

Автор - i691198
Дата добавления - 13.11.2023 в 21:47
cmivadwot Дата: Понедельник, 13.11.2023, 21:48 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 452
Репутация: 86 ±
Замечаний: 0% ±

365
SVR3054, если так? сводная таблица... только по тем данным что даны... аа и артикул с местом переставлены... там еще и объединенные ячейки есть Melfi Y, Z столбец
К сообщению приложен файл: 5203265.xlsx (67.1 Kb)


Сообщение отредактировал cmivadwot - Понедельник, 13.11.2023, 21:51
 
Ответить
СообщениеSVR3054, если так? сводная таблица... только по тем данным что даны... аа и артикул с местом переставлены... там еще и объединенные ячейки есть Melfi Y, Z столбец

Автор - cmivadwot
Дата добавления - 13.11.2023 в 21:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Index/MAtch по 2 критеряим, данные по оси Y, результат X (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!