Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/При помощи формул заменить дубликаты в столбце - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » При помощи формул заменить дубликаты в столбце (Формулы/Formulas)
При помощи формул заменить дубликаты в столбце
Chelovekov Дата: Вторник, 14.11.2023, 09:58 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 310
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Здравствуйте, Уважаемые Форумчане. Прошу, Вас, помочь решить проблему с дубликатами в столбце. Нужно последующие дубликаты заменять на пустую ячейку.
Пример прилагаю.
Заранее благодарен.
К сообщению приложен файл: 4865570.xlsx (8.9 Kb)


Сообщение отредактировал Chelovekov - Вторник, 14.11.2023, 09:59
 
Ответить
СообщениеЗдравствуйте, Уважаемые Форумчане. Прошу, Вас, помочь решить проблему с дубликатами в столбце. Нужно последующие дубликаты заменять на пустую ячейку.
Пример прилагаю.
Заранее благодарен.

Автор - Chelovekov
Дата добавления - 14.11.2023 в 09:58
DrMini Дата: Вторник, 14.11.2023, 10:18 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Нужно последующие дубликаты заменять на пустую ячейку

В этом же столбце формулами не получится.
 
Ответить
Сообщение
Нужно последующие дубликаты заменять на пустую ячейку

В этом же столбце формулами не получится.

Автор - DrMini
Дата добавления - 14.11.2023 в 10:18
Chelovekov Дата: Вторник, 14.11.2023, 10:20 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 310
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Код
=ЕСЛИ(СЧЁТЕСЛИ($B$2:B2;B2)>1;"";B2)

Нашел такую формулу, вроде работает
К сообщению приложен файл: 9221911.xlsx (10.1 Kb)
 
Ответить
Сообщение
Код
=ЕСЛИ(СЧЁТЕСЛИ($B$2:B2;B2)>1;"";B2)

Нашел такую формулу, вроде работает

Автор - Chelovekov
Дата добавления - 14.11.2023 в 10:20
elovkov Дата: Вторник, 14.11.2023, 10:36 | Сообщение № 4
Группа: Друзья
Ранг: Обитатель
Сообщений: 380
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
такую формулу

Если одинаковое имя в разных классах, то посчитает только первого


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
такую формулу

Если одинаковое имя в разных классах, то посчитает только первого

Автор - elovkov
Дата добавления - 14.11.2023 в 10:36
DrMini Дата: Вторник, 14.11.2023, 11:18 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Раз нужно было в соседний столбец то можно и так:
Код
=ЕСЛИ(СУММПРОИЗВ(--(СЖПРОБЕЛЫ(B2)=СЖПРОБЕЛЫ($B$2:B2)))>1;"";B2)
 
Ответить
СообщениеРаз нужно было в соседний столбец то можно и так:
Код
=ЕСЛИ(СУММПРОИЗВ(--(СЖПРОБЕЛЫ(B2)=СЖПРОБЕЛЫ($B$2:B2)))>1;"";B2)

Автор - DrMini
Дата добавления - 14.11.2023 в 11:18
bigor Дата: Вторник, 14.11.2023, 11:19 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1110
Репутация: 212 ±
Замечаний: 0% ±

нет
Если одинаковое имя в разных классах

Код
=IF(COUNTIFS($B$2:B2;B2;$A$2:A2;A2)>1;"";B2)
 
Ответить
Сообщение
Если одинаковое имя в разных классах

Код
=IF(COUNTIFS($B$2:B2;B2;$A$2:A2;A2)>1;"";B2)

Автор - bigor
Дата добавления - 14.11.2023 в 11:19
Chelovekov Дата: Вторник, 14.11.2023, 11:50 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 310
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Всем спасибо hands
 
Ответить
СообщениеВсем спасибо hands

Автор - Chelovekov
Дата добавления - 14.11.2023 в 11:50
elovkov Дата: Вторник, 14.11.2023, 13:22 | Сообщение № 8
Группа: Друзья
Ранг: Обитатель
Сообщений: 380
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
СЧЁТЕСЛИМН

Вот я дурик, пытался и "И" прикрутить и "&" и еще что-то, и все криво как-то, а можно же было так... :D


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
СЧЁТЕСЛИМН

Вот я дурик, пытался и "И" прикрутить и "&" и еще что-то, и все криво как-то, а можно же было так... :D

Автор - elovkov
Дата добавления - 14.11.2023 в 13:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » При помощи формул заменить дубликаты в столбце (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!