Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбрать строки из таблицы согласно условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать строки из таблицы согласно условию (Формулы/Formulas)
Выбрать строки из таблицы согласно условию
Chelovekov Дата: Вторник, 14.11.2023, 13:30 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 310
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Здравствуйте, Уважаемые Форумчане. Прошу, Вас, помочь решить проблему. Нужно из одной таблицы, выбрать строки, порядковый номер, который делится на 3 без остатка.
Пример прилагаю.
Заранее благодарен.
К сообщению приложен файл: 4579757.xlsx (9.5 Kb)
 
Ответить
СообщениеЗдравствуйте, Уважаемые Форумчане. Прошу, Вас, помочь решить проблему. Нужно из одной таблицы, выбрать строки, порядковый номер, который делится на 3 без остатка.
Пример прилагаю.
Заранее благодарен.

Автор - Chelovekov
Дата добавления - 14.11.2023 в 13:30
Nic70y Дата: Вторник, 14.11.2023, 13:53 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8791
Репутация: 2293 ±
Замечаний: 0% ±

Excel 2010
Chelovekov, в приметы верите?
Код
=СТРОКА(E1)*3
Код
=ВПР(D2;A:B;2;)
К сообщению приложен файл: 27.xlsx (9.6 Kb)


ЮMoney 41001841029809
 
Ответить
СообщениеChelovekov, в приметы верите?
Код
=СТРОКА(E1)*3
Код
=ВПР(D2;A:B;2;)

Автор - Nic70y
Дата добавления - 14.11.2023 в 13:53
Chelovekov Дата: Вторник, 14.11.2023, 13:58 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 310
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Спасибо за решения. В приметы скорее нет, чем да. Как говориться «Пути Господни неисповедимы».
 
Ответить
СообщениеСпасибо за решения. В приметы скорее нет, чем да. Как говориться «Пути Господни неисповедимы».

Автор - Chelovekov
Дата добавления - 14.11.2023 в 13:58
Nic70y Дата: Вторник, 14.11.2023, 14:00 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 8791
Репутация: 2293 ±
Замечаний: 0% ±

Excel 2010
В приметы скорее нет, чем да

[offtop]13 номер отсутствует[/offtop]


ЮMoney 41001841029809
 
Ответить
Сообщение
В приметы скорее нет, чем да

[offtop]13 номер отсутствует[/offtop]

Автор - Nic70y
Дата добавления - 14.11.2023 в 14:00
jakim Дата: Вторник, 14.11.2023, 14:05 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 313 ±
Замечаний: 0% ±

Excel 2010
Формулы

строка

Код
=IFERROR(AGGREGATE(15;6;ROW(A$1:A$21)/(MOD(A$2:A$21;3)=0);ROWS($2:2));"")

имя

Код
=IFERROR(INDEX(B$2:B$21;G2);"")
К сообщению приложен файл: 7643598.xlsx (10.2 Kb)
 
Ответить
Сообщение
Формулы

строка

Код
=IFERROR(AGGREGATE(15;6;ROW(A$1:A$21)/(MOD(A$2:A$21;3)=0);ROWS($2:2));"")

имя

Код
=IFERROR(INDEX(B$2:B$21;G2);"")

Автор - jakim
Дата добавления - 14.11.2023 в 14:05
Chelovekov Дата: Вторник, 14.11.2023, 14:08 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 310
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Спасибо
 
Ответить
СообщениеСпасибо

Автор - Chelovekov
Дата добавления - 14.11.2023 в 14:08
jakim Дата: Вторник, 14.11.2023, 16:25 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 313 ±
Замечаний: 0% ±

Excel 2010
Извините. Ошибочка вышла.

Одна формула. Протяните её вправо и вниз.
Код
=IFERROR(INDEX(A$2:A$21;AGGREGATE(15;6;ROW(A$1:A$21)/(MOD($A$2:$A$21;3)=0);ROWS($2:2)));"")
К сообщению приложен файл: 6022543.xlsx (10.3 Kb)


Сообщение отредактировал jakim - Вторник, 14.11.2023, 16:35
 
Ответить
Сообщение
Извините. Ошибочка вышла.

Одна формула. Протяните её вправо и вниз.
Код
=IFERROR(INDEX(A$2:A$21;AGGREGATE(15;6;ROW(A$1:A$21)/(MOD($A$2:$A$21;3)=0);ROWS($2:2)));"")

Автор - jakim
Дата добавления - 14.11.2023 в 16:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать строки из таблицы согласно условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!