Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск слова в тексте по столбцу и извлечение значения - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Поиск слова в тексте по столбцу и извлечение значения
denis_afanase8 Дата: Вторник, 14.11.2023, 21:37 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 40% ±

Добрый день!
Помогите, пожалуйста, решить задачку.

1)Имеется столбец, в котором необходимо найти все сообщения, содержащие номер заказа (в данном случаи 111) и извлечь из столбца "порядковый номер" номер, который соответствует последнему повторению (в данном случаи 6).

2) Имеется столбец, в котором необходимо найти все сообщения, содержащие номер заказа (в данном случаи 111) и извлечь последнее сообщение, в котором встречается искомый номер заказа (в данном случаи бла ааа 111 бла бла ааа).

Если такого заказа нет, выдать сообщение "Заказ отсутствует".
Порядковые номера не повторяются, они индивидуальные для каждого сообщения.
К сообщению приложен файл: primerxlsx.xls (31.5 Kb)
 
Ответить
СообщениеДобрый день!
Помогите, пожалуйста, решить задачку.

1)Имеется столбец, в котором необходимо найти все сообщения, содержащие номер заказа (в данном случаи 111) и извлечь из столбца "порядковый номер" номер, который соответствует последнему повторению (в данном случаи 6).

2) Имеется столбец, в котором необходимо найти все сообщения, содержащие номер заказа (в данном случаи 111) и извлечь последнее сообщение, в котором встречается искомый номер заказа (в данном случаи бла ааа 111 бла бла ааа).

Если такого заказа нет, выдать сообщение "Заказ отсутствует".
Порядковые номера не повторяются, они индивидуальные для каждого сообщения.

Автор - denis_afanase8
Дата добавления - 14.11.2023 в 21:37
AlexM Дата: Вторник, 14.11.2023, 22:27 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4513
Репутация: 1128 ±
Замечаний: 0% ±

Excel 2003
Для номера
Код
=МАКС(ЕЧИСЛО(ПОИСК(A2;B2:B7))*C2:C7)

Для сообщения
Код
=ЕСЛИ(E2;ИНДЕКС(B2:B7;E2);"Заказ отсутствует")



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 15.11.2023, 08:05
 
Ответить
СообщениеДля номера
Код
=МАКС(ЕЧИСЛО(ПОИСК(A2;B2:B7))*C2:C7)

Для сообщения
Код
=ЕСЛИ(E2;ИНДЕКС(B2:B7;E2);"Заказ отсутствует")

Автор - AlexM
Дата добавления - 14.11.2023 в 22:27
bmv98rus Дата: Вторник, 14.11.2023, 23:38 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4111
Репутация: 769 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=LOOKUP(2;1/FIND(A2;B2:B7);C2:C7)
пошустрее будет


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=LOOKUP(2;1/FIND(A2;B2:B7);C2:C7)
пошустрее будет

Автор - bmv98rus
Дата добавления - 14.11.2023 в 23:38
denis_afanase8 Дата: Среда, 15.11.2023, 21:32 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 40% ±

Добрый день!

Спасибо за помощь AlexM и bmv98rus.

У меня возник вопрос, как только значение ячейки C7 меняю с 6 на 7, то формула
Код
=ЕСЛИ(E2;ИНДЕКС(B2:B7;E2);"Заказ отсутствует")
даёт сбой.

В чём может быть проблема?
К сообщению приложен файл: primerxlsx.xlsx (11.8 Kb)


Сообщение отредактировал Serge_007 - Среда, 15.11.2023, 21:59
 
Ответить
СообщениеДобрый день!

Спасибо за помощь AlexM и bmv98rus.

У меня возник вопрос, как только значение ячейки C7 меняю с 6 на 7, то формула
Код
=ЕСЛИ(E2;ИНДЕКС(B2:B7;E2);"Заказ отсутствует")
даёт сбой.

В чём может быть проблема?

Автор - denis_afanase8
Дата добавления - 15.11.2023 в 21:32
Serge_007 Дата: Среда, 15.11.2023, 21:58 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
Цитата denis_afanase8, 15.11.2023 в 21:32, в сообщении № 4 ()
меняю с 6 на 7
В диапазоне B2:B7 только 6 ячеек

[p.s.]Внимательно читайте правила форума[/p.s.]


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Цитата denis_afanase8, 15.11.2023 в 21:32, в сообщении № 4 ()
меняю с 6 на 7
В диапазоне B2:B7 только 6 ячеек

[p.s.]Внимательно читайте правила форума[/p.s.]

Автор - Serge_007
Дата добавления - 15.11.2023 в 21:58
denis_afanase8 Дата: Среда, 15.11.2023, 22:31 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 40% ±

Благодарю за разъяснение Serge_007.

Возникла, теперь, другая необходимость.

Имеется столбец, в котором необходимо найти все сообщения, содержащие номер заказа (в данном случаи 111) и проверить статус заказа в этом сообщении. Вывести статус заказа, который встречается в последнем сообщении, содержащий номер заказа (в данном случаи 111).

Если такого заказа нет, выдать сообщение "Заказ отсутствует".
Порядковые номера не повторяются, они индивидуальные для каждого сообщения.

И вопрос на опережение, возможно применить такую формулу, ссылаясь на другой документ?
К сообщению приложен файл: primerxlsx_2.xlsx (11.5 Kb)
 
Ответить
СообщениеБлагодарю за разъяснение Serge_007.

Возникла, теперь, другая необходимость.

Имеется столбец, в котором необходимо найти все сообщения, содержащие номер заказа (в данном случаи 111) и проверить статус заказа в этом сообщении. Вывести статус заказа, который встречается в последнем сообщении, содержащий номер заказа (в данном случаи 111).

Если такого заказа нет, выдать сообщение "Заказ отсутствует".
Порядковые номера не повторяются, они индивидуальные для каждого сообщения.

И вопрос на опережение, возможно применить такую формулу, ссылаясь на другой документ?

Автор - denis_afanase8
Дата добавления - 15.11.2023 в 22:31
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!