Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт букв в диапазоне по выбранным датам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт букв в диапазоне по выбранным датам (Формулы/Formulas)
Подсчёт букв в диапазоне по выбранным датам
DrMini Дата: Четверг, 16.11.2023, 09:57 | Сообщение № 1
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте форумчане и гости!
Нужно подсчитать количество букв (кроме буквы В) в табеле, которые попадают на определённые Даты заданные в диапазоне AJ3:AJ5. Если на заданную дату выпадает цифра то её считать не нужно.
В столбце Итог: сделал, как должно получиться.
К сообщению приложен файл: vybor_po_dvum_kriterijam.xlsx (13.9 Kb)


Сообщение отредактировал DrMini - Четверг, 16.11.2023, 09:59
 
Ответить
СообщениеЗдравствуйте форумчане и гости!
Нужно подсчитать количество букв (кроме буквы В) в табеле, которые попадают на определённые Даты заданные в диапазоне AJ3:AJ5. Если на заданную дату выпадает цифра то её считать не нужно.
В столбце Итог: сделал, как должно получиться.

Автор - DrMini
Дата добавления - 16.11.2023 в 09:57
Nic70y Дата: Четверг, 16.11.2023, 10:10 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8791
Репутация: 2293 ±
Замечаний: 0% ±

Excel 2010
массивная
Код
=СУММ(--ЕОШ(--ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(B$2:AE$2;AJ$3:AJ$5;));ЕСЛИ(B3:AE3<>"В";B3:AE3))))
К сообщению приложен файл: 78.xlsx (13.8 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениемассивная
Код
=СУММ(--ЕОШ(--ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(B$2:AE$2;AJ$3:AJ$5;));ЕСЛИ(B3:AE3<>"В";B3:AE3))))

Автор - Nic70y
Дата добавления - 16.11.2023 в 10:10
DrMini Дата: Четверг, 16.11.2023, 10:16 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Спасибо Николай
Давно надо было так спросить. А то 4 дня подряд задаю "не тот вопрос".
:)
 
Ответить
СообщениеСпасибо Николай
Давно надо было так спросить. А то 4 дня подряд задаю "не тот вопрос".
:)

Автор - DrMini
Дата добавления - 16.11.2023 в 10:16
NikitaDvorets Дата: Четверг, 16.11.2023, 10:17 | Сообщение № 4
Группа: Авторы
Ранг: Ветеран
Сообщений: 557
Репутация: 126 ±
Замечаний: 0% ±

Excel 2019
Добрый день.
Вариант: пользовательская функция.
К сообщению приложен файл: vybor_po_dvum_kriterijam_16_11.xlsm (20.2 Kb)
 
Ответить
СообщениеДобрый день.
Вариант: пользовательская функция.

Автор - NikitaDvorets
Дата добавления - 16.11.2023 в 10:17
Serge_007 Дата: Четверг, 16.11.2023, 10:23 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
4 дня подряд задаю "не тот вопрос"
Правильно будет дать ссылку на тему с "не тем" вопросом, что бы две темы были связаны: Доплата в короткий (предпраздничный) рабочий день


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
4 дня подряд задаю "не тот вопрос"
Правильно будет дать ссылку на тему с "не тем" вопросом, что бы две темы были связаны: Доплата в короткий (предпраздничный) рабочий день

Автор - Serge_007
Дата добавления - 16.11.2023 в 10:23
DrMini Дата: Четверг, 16.11.2023, 10:30 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Правильно будет дать ссылку на тему с "не тем" вопросом

Только, что проверил. Всё работает.


Сообщение отредактировал DrMini - Четверг, 16.11.2023, 10:31
 
Ответить
Сообщение
Правильно будет дать ссылку на тему с "не тем" вопросом

Только, что проверил. Всё работает.

Автор - DrMini
Дата добавления - 16.11.2023 в 10:30
Serge_007 Дата: Четверг, 16.11.2023, 10:51 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
На сайте должен быть порядок
yes


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
На сайте должен быть порядок
yes

Автор - Serge_007
Дата добавления - 16.11.2023 в 10:51
Egyptian Дата: Четверг, 16.11.2023, 21:04 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 514
Репутация: 185 ±
Замечаний: 0% ±

Excel 2013/2016
Eще варианты (немассивные)
Код
=SUMPRODUCT(COUNTIF(AJ$3:AJ$5;B$2:AE$2)*(B3:AE3<>"В")*ISTEXT(B3:AE3))

или так
Код
=COUNT(INDEX(1/(COUNTIF(AJ$3:AJ$5;B$2:AE$2)*(B3:AE3<>"В")*ISTEXT(B3:AE3));))
 
Ответить
СообщениеEще варианты (немассивные)
Код
=SUMPRODUCT(COUNTIF(AJ$3:AJ$5;B$2:AE$2)*(B3:AE3<>"В")*ISTEXT(B3:AE3))

или так
Код
=COUNT(INDEX(1/(COUNTIF(AJ$3:AJ$5;B$2:AE$2)*(B3:AE3<>"В")*ISTEXT(B3:AE3));))

Автор - Egyptian
Дата добавления - 16.11.2023 в 21:04
DrMini Дата: Четверг, 16.11.2023, 21:53 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Спасибо всем. Всё работает.
 
Ответить
СообщениеСпасибо всем. Всё работает.

Автор - DrMini
Дата добавления - 16.11.2023 в 21:53
elovkov Дата: Пятница, 17.11.2023, 07:39 | Сообщение № 10
Группа: Друзья
Ранг: Обитатель
Сообщений: 380
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
А то 4 дня подряд задаю "не тот вопрос"

Вот кстати часто бывает что когда сам себе "правильно" вопрос сформулируешь, то и ответ находится, тоже бывало мучаешься с чем-нибудь, потом подумаешь еще раз что в итоге получить хочешь и бац, озаряет)))


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
А то 4 дня подряд задаю "не тот вопрос"

Вот кстати часто бывает что когда сам себе "правильно" вопрос сформулируешь, то и ответ находится, тоже бывало мучаешься с чем-нибудь, потом подумаешь еще раз что в итоге получить хочешь и бац, озаряет)))

Автор - elovkov
Дата добавления - 17.11.2023 в 07:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт букв в диапазоне по выбранным датам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!