Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Условие для большого количества ячеек - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Условие для большого количества ячеек (Формулы/Formulas)
Условие для большого количества ячеек
ilnur0708 Дата: Суббота, 18.11.2023, 14:43 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!

У меня есть список из тридцати имен. Есть таблица, в которой два столбца и несколько сот строк. В каждой строке в первом столбце указано какое-то имя из моего списка, во втором - какое-то число. В первом столбце таблицы каждое имя может встречаться много раз.

Мне нужно для каждого имени просуммировать все числа, которые стоят рядом с этим именем во втором столбце таблицы.

Например, такая таблица:
Имя1 Число1
Имя1 Число2
Имя2 Число3
Имя1 Число4
Имя2 Число5

Мне нужно получить Число1+Число2+Число4 и Число3+Число5

Подскажите, пожалуйста, как это реализовать с учетом того, что у меня несколько сот строк
 
Ответить
СообщениеДобрый день!

У меня есть список из тридцати имен. Есть таблица, в которой два столбца и несколько сот строк. В каждой строке в первом столбце указано какое-то имя из моего списка, во втором - какое-то число. В первом столбце таблицы каждое имя может встречаться много раз.

Мне нужно для каждого имени просуммировать все числа, которые стоят рядом с этим именем во втором столбце таблицы.

Например, такая таблица:
Имя1 Число1
Имя1 Число2
Имя2 Число3
Имя1 Число4
Имя2 Число5

Мне нужно получить Число1+Число2+Число4 и Число3+Число5

Подскажите, пожалуйста, как это реализовать с учетом того, что у меня несколько сот строк

Автор - ilnur0708
Дата добавления - 18.11.2023 в 14:43
DrMini Дата: Суббота, 18.11.2023, 15:40 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1645
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте.
Без вашего примера можно так:
Код
=СУММЕСЛИ($A$1:$A$1000;D1;$B$1:$B$1000)

или так:
Код
=СУММПРОИЗВ(($A$1:$A$1000=D1)*$B$1:$B$1000)

[p.s.]тут диапазон до 1000. Просто поменяйте на нужный.[/p.s.]
К сообщению приложен файл: 20231118.xlsx (9.9 Kb)


Сообщение отредактировал DrMini - Суббота, 18.11.2023, 15:47
 
Ответить
СообщениеЗдравствуйте.
Без вашего примера можно так:
Код
=СУММЕСЛИ($A$1:$A$1000;D1;$B$1:$B$1000)

или так:
Код
=СУММПРОИЗВ(($A$1:$A$1000=D1)*$B$1:$B$1000)

[p.s.]тут диапазон до 1000. Просто поменяйте на нужный.[/p.s.]

Автор - DrMini
Дата добавления - 18.11.2023 в 15:40
ilnur0708 Дата: Суббота, 18.11.2023, 16:08 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

DrMini, спасибо!
 
Ответить
СообщениеDrMini, спасибо!

Автор - ilnur0708
Дата добавления - 18.11.2023 в 16:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Условие для большого количества ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!