Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/динамический список - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
динамический список
aastg2022 Дата: Воскресенье, 19.11.2023, 20:47 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

2021
помогите сохдать список выпадающий динамический. У меня в столбца А список, я его буду добавлять. В столбце В формула ставит единицу если заполнена ячейка в А. В С стоит формула определяющая число строк диапазона. Необходимо в диспечере имен создать имя итр диапазон которого будет определяться по значению С1, тоесть с А1 по А значения С1 и далее стоит выпадающий список в Ф1, где там формула которая определяет список по имени. Тоесть мне необходимо создать этот список всегда обновляющийся
К сообщению приложен файл: 11111.xlsx (9.6 Kb)
 
Ответить
Сообщениепомогите сохдать список выпадающий динамический. У меня в столбца А список, я его буду добавлять. В столбце В формула ставит единицу если заполнена ячейка в А. В С стоит формула определяющая число строк диапазона. Необходимо в диспечере имен создать имя итр диапазон которого будет определяться по значению С1, тоесть с А1 по А значения С1 и далее стоит выпадающий список в Ф1, где там формула которая определяет список по имени. Тоесть мне необходимо создать этот список всегда обновляющийся

Автор - aastg2022
Дата добавления - 19.11.2023 в 20:47
gling Дата: Воскресенье, 19.11.2023, 20:58 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2526
Репутация: 678 ±
Замечаний: 0% ±

2010
Здравствуйте.
Это формула итр в диспетчере имен без использования доп столбцов и доп ячеек.
Код
=Лист1!$A$1:ИНДЕКС(Лист1!$A$1:$A$10000;СЧЁТЗ(Лист1!$A$1:$A$10000))
В проверке данных сразу ссылаемся на имя именованного диапазона без ДВССЫЛ()
К сообщению приложен файл: 5390213.xlsx (9.0 Kb)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
Это формула итр в диспетчере имен без использования доп столбцов и доп ячеек.
Код
=Лист1!$A$1:ИНДЕКС(Лист1!$A$1:$A$10000;СЧЁТЗ(Лист1!$A$1:$A$10000))
В проверке данных сразу ссылаемся на имя именованного диапазона без ДВССЫЛ()

Автор - gling
Дата добавления - 19.11.2023 в 20:58
DrMini Дата: Понедельник, 20.11.2023, 09:46 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1679
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте.
без ДВССЫЛ()

Отложу себе в копилку и предложу с ДВССЫЛ() просто, как вариант.
К сообщению приложен файл: 0815936.xlsx (13.8 Kb)
 
Ответить
СообщениеЗдравствуйте.
без ДВССЫЛ()

Отложу себе в копилку и предложу с ДВССЫЛ() просто, как вариант.

Автор - DrMini
Дата добавления - 20.11.2023 в 09:46
aastg2022 Дата: Понедельник, 20.11.2023, 11:22 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

2021
проблема в том что у меня несколько списков, определяет какой показывать ячейка, в которой меняется назнвание именного диапазона, поэтому и ДВССЫЛ в списке. Как мне его сделать?


Сообщение отредактировал Serge_007 - Понедельник, 20.11.2023, 11:43
 
Ответить
Сообщениепроблема в том что у меня несколько списков, определяет какой показывать ячейка, в которой меняется назнвание именного диапазона, поэтому и ДВССЫЛ в списке. Как мне его сделать?

Автор - aastg2022
Дата добавления - 20.11.2023 в 11:22
aastg2022 Дата: Понедельник, 20.11.2023, 11:29 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

2021
в файле 3 списка, в ячейке I2 выпадающий список выбирать какой именованный диапазон. Вследствии в ячейке F2 должен появляться тот список название которого в I2. И так же при пополнении списков диапазон имени должен расширяться или сужаться
К сообщению приложен файл: 6352038.xlsx (9.7 Kb)
 
Ответить
Сообщениев файле 3 списка, в ячейке I2 выпадающий список выбирать какой именованный диапазон. Вследствии в ячейке F2 должен появляться тот список название которого в I2. И так же при пополнении списков диапазон имени должен расширяться или сужаться

Автор - aastg2022
Дата добавления - 20.11.2023 в 11:29
Nic70y Дата: Понедельник, 20.11.2023, 12:06 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 8801
Репутация: 2295 ±
Замечаний: 0% ±

Excel 2010
Код
=ИНДЕКС(Лист1!$A:$C;2;ПОИСКПОЗ(Лист1!I2;Лист1!$A$1:$C$1;)):ИНДЕКС(Лист1!$A:$C;СЧЁТЗ(ИНДЕКС(Лист1!$A:$C;;ПОИСКПОЗ(Лист1!I2;Лист1!$A$1:$C$1;)));ПОИСКПОЗ(Лист1!I2;Лист1!$A$1:$C$1;))
К сообщению приложен файл: 0635531.xlsx (9.2 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ИНДЕКС(Лист1!$A:$C;2;ПОИСКПОЗ(Лист1!I2;Лист1!$A$1:$C$1;)):ИНДЕКС(Лист1!$A:$C;СЧЁТЗ(ИНДЕКС(Лист1!$A:$C;;ПОИСКПОЗ(Лист1!I2;Лист1!$A$1:$C$1;)));ПОИСКПОЗ(Лист1!I2;Лист1!$A$1:$C$1;))

Автор - Nic70y
Дата добавления - 20.11.2023 в 12:06
aastg2022 Дата: Понедельник, 20.11.2023, 13:51 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

2021
да, спасибо все работает, поставил Ф4 на ячейку указывающую и вообще все супер
 
Ответить
Сообщениеда, спасибо все работает, поставил Ф4 на ячейку указывающую и вообще все супер

Автор - aastg2022
Дата добавления - 20.11.2023 в 13:51
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!