Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как сделать ВПР нескольких значений - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать ВПР нескольких значений (Формулы/Formulas)
Как сделать ВПР нескольких значений
eashmv Дата: Вторник, 21.11.2023, 13:30 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

2310
Есть файл с вопросами по товарам и по одному товару может быть несколько вопросов, соответственно мне нужно сделать что-то наподобие ВПР, чтобы в одной строке был Артикул и все вопросы по нему в разных столбцах.
Основные данные на листе "вопросы", а пример как нужно на листе "Лист5"
К сообщению приложен файл: voprosy_wb.xlsm (254.5 Kb)
 
Ответить
СообщениеЕсть файл с вопросами по товарам и по одному товару может быть несколько вопросов, соответственно мне нужно сделать что-то наподобие ВПР, чтобы в одной строке был Артикул и все вопросы по нему в разных столбцах.
Основные данные на листе "вопросы", а пример как нужно на листе "Лист5"

Автор - eashmv
Дата добавления - 21.11.2023 в 13:30
DrMini Дата: Вторник, 21.11.2023, 14:26 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Посмотрите в файле.
С доп столбцом.
К сообщению приложен файл: 4441614.xlsm (256.2 Kb)


Сообщение отредактировал DrMini - Вторник, 21.11.2023, 14:29
 
Ответить
СообщениеПосмотрите в файле.
С доп столбцом.

Автор - DrMini
Дата добавления - 21.11.2023 в 14:26
bigor Дата: Вторник, 21.11.2023, 15:38 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1015
Репутация: 195 ±
Замечаний: 0% ±

нет
eashmv, в b1 и тянуть вправо
Код
=IFERROR(INDEX(вопросы!$E$2:$E$800;AGGREGATE(15;6;ROW($A$1:$A$799)/(вопросы!$A$2:$A$800=$A1);COLUMN(A1)));"")


Сообщение отредактировал bigor - Вторник, 21.11.2023, 15:44
 
Ответить
Сообщениеeashmv, в b1 и тянуть вправо
Код
=IFERROR(INDEX(вопросы!$E$2:$E$800;AGGREGATE(15;6;ROW($A$1:$A$799)/(вопросы!$A$2:$A$800=$A1);COLUMN(A1)));"")

Автор - bigor
Дата добавления - 21.11.2023 в 15:38
DrMini Дата: Вторник, 21.11.2023, 15:42 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Ну и как вариант без доп столбца:
Код
=ЕСЛИОШИБКА(ИНДЕКС(вопросы!$E$2:$E$800;НАИМЕНЬШИЙ(ЕСЛИ($A1=вопросы!$A$2:$A$800;СТРОКА(вопросы!$A$2:$A$800)-1);СТОЛБЕЦ(A1)));"")
К сообщению приложен файл: 9137682.xlsm (258.1 Kb)
 
Ответить
СообщениеНу и как вариант без доп столбца:
Код
=ЕСЛИОШИБКА(ИНДЕКС(вопросы!$E$2:$E$800;НАИМЕНЬШИЙ(ЕСЛИ($A1=вопросы!$A$2:$A$800;СТРОКА(вопросы!$A$2:$A$800)-1);СТОЛБЕЦ(A1)));"")

Автор - DrMini
Дата добавления - 21.11.2023 в 15:42
eashmv Дата: Вторник, 21.11.2023, 17:54 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

2310
Спасибо! DrMini,
Код
=ЕСЛИОШИБКА(ИНДЕКС(вопросы!$E$2:$E$800;НАИМЕНЬШИЙ(ЕСЛИ($A1=вопросы!$A$2:$A$800;СТРОКА(вопросы!$A$2:$A$800)-1);СТОЛБЕЦ(A1)));"")

данный способ подошел
 
Ответить
СообщениеСпасибо! DrMini,
Код
=ЕСЛИОШИБКА(ИНДЕКС(вопросы!$E$2:$E$800;НАИМЕНЬШИЙ(ЕСЛИ($A1=вопросы!$A$2:$A$800;СТРОКА(вопросы!$A$2:$A$800)-1);СТОЛБЕЦ(A1)));"")

данный способ подошел

Автор - eashmv
Дата добавления - 21.11.2023 в 17:54
Pelena Дата: Среда, 22.11.2023, 09:28 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 19137
Репутация: 4409 ±
Замечаний: ±

Excel 365 & Mac Excel
Для новых версий
Код
=ТРАНСП(ФИЛЬТР(вопросы!$E$1:$E$10000;вопросы!$A$1:$A$10000=A2;""))
К сообщению приложен файл: 8915347.xlsm (304.6 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеДля новых версий
Код
=ТРАНСП(ФИЛЬТР(вопросы!$E$1:$E$10000;вопросы!$A$1:$A$10000=A2;""))

Автор - Pelena
Дата добавления - 22.11.2023 в 09:28
eashmv Дата: Четверг, 30.11.2023, 09:49 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

2310
Подскажите, что делаю не так, вроде все идентично, но почему то вправо не протягиваются результаты
К сообщению приложен файл: voprosyotzyvy_ozon.xlsx (137.0 Kb)
 
Ответить
СообщениеПодскажите, что делаю не так, вроде все идентично, но почему то вправо не протягиваются результаты

Автор - eashmv
Дата добавления - 30.11.2023 в 09:49
Nic70y Дата: Четверг, 30.11.2023, 10:11 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 8649
Репутация: 2207 ±
Замечаний: 0% ±

Excel 2010
вариант - ссылка на сводную
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(СВОД!A:A;СТРОКА());"")
Код
=ЕСЛИ(A1="";"";ПОДСТАВИТЬ(ИНДЕКС(СВОД!$A:$A;ПОИСКПОЗ($A1;СВОД!$A:$A;)+СТОЛБЕЦ(A1));$A2;))
К сообщению приложен файл: 149.xlsm (291.4 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениевариант - ссылка на сводную
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(СВОД!A:A;СТРОКА());"")
Код
=ЕСЛИ(A1="";"";ПОДСТАВИТЬ(ИНДЕКС(СВОД!$A:$A;ПОИСКПОЗ($A1;СВОД!$A:$A;)+СТОЛБЕЦ(A1));$A2;))

Автор - Nic70y
Дата добавления - 30.11.2023 в 10:11
eashmv Дата: Четверг, 30.11.2023, 10:20 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

2310
Nic70y, было предложено решение и оно работало в первом файле, сейчас же делаю во втором и не протягивается :(((
Код
=ЕСЛИОШИБКА(ИНДЕКС(вопросы!$E$2:$E$800;НАИМЕНЬШИЙ(ЕСЛИ($A1=вопросы!$A$2:$A$800;СТРОКА(вопросы!$A$2:$A$800)-1);СТОЛБЕЦ(A1)));"")


Сообщение отредактировал eashmv - Пятница, 01.12.2023, 06:26
 
Ответить
СообщениеNic70y, было предложено решение и оно работало в первом файле, сейчас же делаю во втором и не протягивается :(((
Код
=ЕСЛИОШИБКА(ИНДЕКС(вопросы!$E$2:$E$800;НАИМЕНЬШИЙ(ЕСЛИ($A1=вопросы!$A$2:$A$800;СТРОКА(вопросы!$A$2:$A$800)-1);СТОЛБЕЦ(A1)));"")

Автор - eashmv
Дата добавления - 30.11.2023 в 10:20
eashmv Дата: Четверг, 30.11.2023, 10:23 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

2310
Делаю все так же вроде, значение ищет, но при протягивании вправо пустые ячейки везде
Код
=ЕСЛИОШИБКА(ИНДЕКС(ИСХОДНИК!$D$2:$D$649;НАИМЕНЬШИЙ(ЕСЛИ($A2=ИСХОДНИК!$A$2:$A$649;СТРОКА(ИСХОДНИК!$A$2:$A$649)-1);СТОЛБЕЦ(A2)));"")


Сообщение отредактировал eashmv - Пятница, 01.12.2023, 06:26
 
Ответить
СообщениеДелаю все так же вроде, значение ищет, но при протягивании вправо пустые ячейки везде
Код
=ЕСЛИОШИБКА(ИНДЕКС(ИСХОДНИК!$D$2:$D$649;НАИМЕНЬШИЙ(ЕСЛИ($A2=ИСХОДНИК!$A$2:$A$649;СТРОКА(ИСХОДНИК!$A$2:$A$649)-1);СТОЛБЕЦ(A2)));"")

Автор - eashmv
Дата добавления - 30.11.2023 в 10:23
Nic70y Дата: Четверг, 30.11.2023, 10:35 | Сообщение № 11
Группа: Друзья
Ранг: Экселист
Сообщений: 8649
Репутация: 2207 ±
Замечаний: 0% ±

Excel 2010
eashmv, это формулы массива - они вас плохому научат
[p.s.]формула массива вводиться не энтером, а сочетанием клавиш ctrl+shift+enter[/p.s.]


ЮMoney 41001841029809
 
Ответить
Сообщениеeashmv, это формулы массива - они вас плохому научат
[p.s.]формула массива вводиться не энтером, а сочетанием клавиш ctrl+shift+enter[/p.s.]

Автор - Nic70y
Дата добавления - 30.11.2023 в 10:35
eashmv Дата: Четверг, 30.11.2023, 10:54 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

2310
Nic70y, почему?
 
Ответить
СообщениеNic70y, почему?

Автор - eashmv
Дата добавления - 30.11.2023 в 10:54
Nic70y Дата: Четверг, 30.11.2023, 11:08 | Сообщение № 13
Группа: Друзья
Ранг: Экселист
Сообщений: 8649
Репутация: 2207 ±
Замечаний: 0% ±

Excel 2010
формулы массива очень массивные и сжирают много энергии.
макрос хотите?


ЮMoney 41001841029809
 
Ответить
Сообщениеформулы массива очень массивные и сжирают много энергии.
макрос хотите?

Автор - Nic70y
Дата добавления - 30.11.2023 в 11:08
eashmv Дата: Четверг, 30.11.2023, 11:10 | Сообщение № 14
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

2310
Nic70y, я вроде разобрался с вашим вариантом формулы
 
Ответить
СообщениеNic70y, я вроде разобрался с вашим вариантом формулы

Автор - eashmv
Дата добавления - 30.11.2023 в 11:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать ВПР нескольких значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!