Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/если в ячейке А1 выбрать 1, то посчитать кол-во с листа 1 - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
если в ячейке А1 выбрать 1, то посчитать кол-во с листа 1
Tati_37 Дата: Четверг, 23.11.2023, 22:03 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 40% ±

Excel 2019
Добрый вечер.
Подскажите, пожалуйста, как записать формулу в примере во вложении: если в ячейке А1 выбрать 1, то нужно сосчитать каждую должность из закладки 1, соответственно если в ячейке А1 -2, то сосчитать из закладки 2.
Заранее спасибо.
К сообщению приложен файл: na_forum.xls (29.5 Kb)
 
Ответить
СообщениеДобрый вечер.
Подскажите, пожалуйста, как записать формулу в примере во вложении: если в ячейке А1 выбрать 1, то нужно сосчитать каждую должность из закладки 1, соответственно если в ячейке А1 -2, то сосчитать из закладки 2.
Заранее спасибо.

Автор - Tati_37
Дата добавления - 23.11.2023 в 22:03
Gustav Дата: Четверг, 23.11.2023, 22:47 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2763
Репутация: 1140 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Для C8 формула (и скопировать ниже):
Код
=СЧЁТЕСЛИ(ДВССЫЛ($A$1&"!B:B");B8)


[p.s.]Либо если в названиях листов ожидаются пробелы,[/p.s.]то формула чуть усложнится за счет добавления одиночных кавычек вокруг названия листа:
Код
=СЧЁТЕСЛИ(ДВССЫЛ("'"&$A$1&"'!B:B");B8)


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Пятница, 24.11.2023, 00:33
 
Ответить
СообщениеДля C8 формула (и скопировать ниже):
Код
=СЧЁТЕСЛИ(ДВССЫЛ($A$1&"!B:B");B8)


[p.s.]Либо если в названиях листов ожидаются пробелы,[/p.s.]то формула чуть усложнится за счет добавления одиночных кавычек вокруг названия листа:
Код
=СЧЁТЕСЛИ(ДВССЫЛ("'"&$A$1&"'!B:B");B8)

Автор - Gustav
Дата добавления - 23.11.2023 в 22:47
Tati_37 Дата: Пятница, 24.11.2023, 00:58 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 40% ±

Excel 2019
Gustav, Что-то не получается... Скорректируйте пожалуйста в файле.
К сообщению приложен файл: na_forum_2.xls (33.0 Kb)
 
Ответить
СообщениеGustav, Что-то не получается... Скорректируйте пожалуйста в файле.

Автор - Tati_37
Дата добавления - 24.11.2023 в 00:58
Gustav Дата: Пятница, 24.11.2023, 01:15 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2763
Репутация: 1140 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
В ячейке A1 на ШР второй пробел перед 210 уберите! И вторую формулу возьмите мою, которая в P.S.
К сообщению приложен файл: 8111320.xls (29.0 Kb)


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Пятница, 24.11.2023, 01:29
 
Ответить
СообщениеВ ячейке A1 на ШР второй пробел перед 210 уберите! И вторую формулу возьмите мою, которая в P.S.

Автор - Gustav
Дата добавления - 24.11.2023 в 01:15
Tati_37 Дата: Пятница, 24.11.2023, 01:28 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 40% ±

Excel 2019
Gustav, СПАСИБО!!! При сцепке не заметила лишнего пробела... Все получилось!
 
Ответить
СообщениеGustav, СПАСИБО!!! При сцепке не заметила лишнего пробела... Все получилось!

Автор - Tati_37
Дата добавления - 24.11.2023 в 01:28
bmv98rus Дата: Суббота, 25.11.2023, 10:04 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4111
Репутация: 769 ±
Замечаний: 0% ±

Excel 2013/2016
Если количество листов ограничено, то возможно более правильным, хоть и длинным будет
Код
=COUNTIF(CHOOSE(A$1;'1'!B:B;'2'!B:B);B8)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеЕсли количество листов ограничено, то возможно более правильным, хоть и длинным будет
Код
=COUNTIF(CHOOSE(A$1;'1'!B:B;'2'!B:B);B8)

Автор - bmv98rus
Дата добавления - 25.11.2023 в 10:04
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!