Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/сведения по возрасту и возрастная группа - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сведения по возрасту и возрастная группа (Формулы/Formulas)
сведения по возрасту и возрастная группа
urpsomchs Дата: Пятница, 24.11.2023, 14:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!
Необходим расчет возрастной группы для сдачи нормативов по ФИЗО. Нормативы применяются с учетос возрастных групп ( в прикпленном файле)[/size]
К сообщению приложен файл: vozrastnaja_gruppa.xlsx (11.3 Kb)
 
Ответить
СообщениеДобрый день!
Необходим расчет возрастной группы для сдачи нормативов по ФИЗО. Нормативы применяются с учетос возрастных групп ( в прикпленном файле)[/size]

Автор - urpsomchs
Дата добавления - 24.11.2023 в 14:16
AlexM Дата: Пятница, 24.11.2023, 14:37 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4379
Репутация: 1081 ±
Замечаний: 0% ±

Excel 2003
Формула массива. Ввод Ctrl+Shift+Enter
Код
=ЕСЛИ(E6<18;"-";ВПР(E6;--ЛЕВБ(B8:C14;2);2))
К сообщению приложен файл: vozrastnaja_gruppa1.xlsx (10.8 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Пятница, 24.11.2023, 14:38
 
Ответить
СообщениеФормула массива. Ввод Ctrl+Shift+Enter
Код
=ЕСЛИ(E6<18;"-";ВПР(E6;--ЛЕВБ(B8:C14;2);2))

Автор - AlexM
Дата добавления - 24.11.2023 в 14:37
Gustav Дата: Пятница, 24.11.2023, 14:38 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2652
Репутация: 1114 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Если фразу "от 50 и выше" замените на "50 и выше", т.е. "от " уберете, то для ячейки F6 можно использовать такую формулу:
Код
=ВПР(""&E6+1;$B$8:$C$14;2)

[p.s.]А если не убирать "от ", типа если принципиально так надо,[/p.s.] то тогда такая формула массива (Ctrl+Shift+Enter):
Код
=ВПР(""&E6+1;ПОДСТАВИТЬ($B$8:$C$14;"от ";"");2)

Т.е. за принципы нужно платить дополнительно :)


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Пятница, 24.11.2023, 14:48
 
Ответить
СообщениеЕсли фразу "от 50 и выше" замените на "50 и выше", т.е. "от " уберете, то для ячейки F6 можно использовать такую формулу:
Код
=ВПР(""&E6+1;$B$8:$C$14;2)

[p.s.]А если не убирать "от ", типа если принципиально так надо,[/p.s.] то тогда такая формула массива (Ctrl+Shift+Enter):
Код
=ВПР(""&E6+1;ПОДСТАВИТЬ($B$8:$C$14;"от ";"");2)

Т.е. за принципы нужно платить дополнительно :)

Автор - Gustav
Дата добавления - 24.11.2023 в 14:38
urpsomchs Дата: Пятница, 24.11.2023, 15:09 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

AlexM, благодарю за ответ, но когда начинаю заводить строки и менять положение таблицы в ячейке F встает #H/Д.
 
Ответить
СообщениеAlexM, благодарю за ответ, но когда начинаю заводить строки и менять положение таблицы в ячейке F встает #H/Д.

Автор - urpsomchs
Дата добавления - 24.11.2023 в 15:09
urpsomchs Дата: Пятница, 24.11.2023, 15:12 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Gustav,благодарю за ответ hands нет не принципы и без ОТ НИЧЕГО НЕ ПОМЕНЯТЕСЯ
 
Ответить
СообщениеGustav,благодарю за ответ hands нет не принципы и без ОТ НИЧЕГО НЕ ПОМЕНЯТЕСЯ

Автор - urpsomchs
Дата добавления - 24.11.2023 в 15:12
Gustav Дата: Пятница, 24.11.2023, 15:31 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2652
Репутация: 1114 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
в ячейке F встает #H/Д.

Придайте аргументу B8:C14 в формуле AlexM вид как у меня (с долларами): $B$8:$C$14


МОИ: Ник, Tip box: 41001663842605
 
Ответить
Сообщение
в ячейке F встает #H/Д.

Придайте аргументу B8:C14 в формуле AlexM вид как у меня (с долларами): $B$8:$C$14

Автор - Gustav
Дата добавления - 24.11.2023 в 15:31
AlexM Дата: Пятница, 24.11.2023, 18:22 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4379
Репутация: 1081 ±
Замечаний: 0% ±

Excel 2003
urpsomchs, Еще можно с другой функцией
Код
=ЕСЛИ(E6<18;"-";ПОИСКПОЗ(""&E6+1;$B$8:$B$14))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениеurpsomchs, Еще можно с другой функцией
Код
=ЕСЛИ(E6<18;"-";ПОИСКПОЗ(""&E6+1;$B$8:$B$14))

Автор - AlexM
Дата добавления - 24.11.2023 в 18:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сведения по возрасту и возрастная группа (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!