Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Кол-во и время в одной ячейке - подвести итог - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Кол-во и время в одной ячейке - подвести итог (Формулы/Formulas)
Кол-во и время в одной ячейке - подвести итог
Tati_37 Дата: Суббота, 25.11.2023, 19:48 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 40% ±

Excel 2019
Добрый вечер. Для анализа эффективности сотрудников из программы формируется отчет (во вложении), который в одной ячейке отражает количество звонков за день и время потраченное на эти звонки (например, 3 - 00:02:37). Однако подведение итогов за месяц не считается. Что можно придумать для решения этой задачи?
К сообщению приложен файл: kol_vo_i_vremja.xlsx (11.1 Kb)
 
Ответить
СообщениеДобрый вечер. Для анализа эффективности сотрудников из программы формируется отчет (во вложении), который в одной ячейке отражает количество звонков за день и время потраченное на эти звонки (например, 3 - 00:02:37). Однако подведение итогов за месяц не считается. Что можно придумать для решения этой задачи?

Автор - Tati_37
Дата добавления - 25.11.2023 в 19:48
bmv98rus Дата: Суббота, 25.11.2023, 20:04 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4095
Репутация: 766 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=SUMPRODUCT(--LEFT(SUBSTITUTE(TEXT(B3:W3;";;\0;@");"-";REPT(" ";9));9)) &" - "&TEXT(SUMPRODUCT(--RIGHT(TEXT(B3:W3;";;\0;@");8));"[ч]:мм:сс")

или массивка
Код
=SUM(IFERROR(--LEFT(SUBSTITUTE(B3:W3;"-";REPT(" ";9));9);)) &" - "&TEXT(SUM(IFERROR(--RIGHT(B3:W3;8);));"[ч]:мм:сс")


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Суббота, 25.11.2023, 20:13
 
Ответить
Сообщение
Код
=SUMPRODUCT(--LEFT(SUBSTITUTE(TEXT(B3:W3;";;\0;@");"-";REPT(" ";9));9)) &" - "&TEXT(SUMPRODUCT(--RIGHT(TEXT(B3:W3;";;\0;@");8));"[ч]:мм:сс")

или массивка
Код
=SUM(IFERROR(--LEFT(SUBSTITUTE(B3:W3;"-";REPT(" ";9));9);)) &" - "&TEXT(SUM(IFERROR(--RIGHT(B3:W3;8);));"[ч]:мм:сс")

Автор - bmv98rus
Дата добавления - 25.11.2023 в 20:04
Tati_37 Дата: Суббота, 25.11.2023, 20:20 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 40% ±

Excel 2019
bmv98rus, СПАСИБО. А каким-то образом можно из итогов за месяц определить сколько в среднем за день сотрудник делает звонков и сколько времени на это тратится?
К сообщению приложен файл: srednee_kol_vo_i_vremja.xlsx (16.7 Kb)
 
Ответить
Сообщениеbmv98rus, СПАСИБО. А каким-то образом можно из итогов за месяц определить сколько в среднем за день сотрудник делает звонков и сколько времени на это тратится?

Автор - Tati_37
Дата добавления - 25.11.2023 в 20:20
bigor Дата: Суббота, 25.11.2023, 21:21 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1015
Репутация: 195 ±
Замечаний: 0% ±

нет
Tati_37, звонков
Код
=INT(Y3/COUNTA(B3:W3))
, время разговора
Код
=(Z3/COUNTA(B3:W3))
 
Ответить
СообщениеTati_37, звонков
Код
=INT(Y3/COUNTA(B3:W3))
, время разговора
Код
=(Z3/COUNTA(B3:W3))

Автор - bigor
Дата добавления - 25.11.2023 в 21:21
Gustav Дата: Суббота, 25.11.2023, 23:17 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2649
Репутация: 1114 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Тоже поучаствую. У меня две отдельные итоговые формулы для ячеек Y3 (кол-во) и Z3 (время) соответственно:
Код
=СУММПРОИЗВ(--ЛЕВСИМВ(B3:W3&"0";2))

Код
=СУММПРОИЗВ(--ПРАВСИМВ("0:"&B3:W3;8))

Для ячеек времени (колонка Z) установить формат: [ч]:мм:сс . Формула для кол-ва (колонка Y) имеет ограничение "не более 99 в день", но, вроде, по факту реальность далека от этого предела, а формула при этом довольно компактненькая ))


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Суббота, 25.11.2023, 23:33
 
Ответить
СообщениеТоже поучаствую. У меня две отдельные итоговые формулы для ячеек Y3 (кол-во) и Z3 (время) соответственно:
Код
=СУММПРОИЗВ(--ЛЕВСИМВ(B3:W3&"0";2))

Код
=СУММПРОИЗВ(--ПРАВСИМВ("0:"&B3:W3;8))

Для ячеек времени (колонка Z) установить формат: [ч]:мм:сс . Формула для кол-ва (колонка Y) имеет ограничение "не более 99 в день", но, вроде, по факту реальность далека от этого предела, а формула при этом довольно компактненькая ))

Автор - Gustav
Дата добавления - 25.11.2023 в 23:17
Tati_37 Дата: Воскресенье, 26.11.2023, 09:48 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 40% ±

Excel 2019
Ребята, спасибо большое. Все работает!
 
Ответить
СообщениеРебята, спасибо большое. Все работает!

Автор - Tati_37
Дата добавления - 26.11.2023 в 09:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Кол-во и время в одной ячейке - подвести итог (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!