Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет премии в зависимости от % выполнения (ВПР) - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет премии в зависимости от % выполнения (ВПР) (Формулы/Formulas)
Расчет премии в зависимости от % выполнения (ВПР)
Tati_37 Дата: Понедельник, 27.11.2023, 22:43 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 40% ±

Excel 2019
Доброго времени суток. Необходимо просчитать премию сотрудника в зависимости от выполнении нескольких показателей. Например,
если KPI 1 выполнен на 107 % - то плюс 15 000
- 95,01%-100,00% + 10 000 руб.
- 100,01%-110,00% + 15 000 руб.
- 110,01% и выше + 20 000 руб.
если KPI 2 выполнен на 98 % - то плюс 5 000
- 95,01%-100,00% + 5 000 руб.
- 100,01%-110,00% + 7 000 руб.
- 110,01% и выше + 10 000 руб.

Не понимаю как проставить критерии для ЕСЛИ в диапазоне %. Пример во вложении.
К сообщению приложен файл: premija.xlsx (9.1 Kb)
 
Ответить
СообщениеДоброго времени суток. Необходимо просчитать премию сотрудника в зависимости от выполнении нескольких показателей. Например,
если KPI 1 выполнен на 107 % - то плюс 15 000
- 95,01%-100,00% + 10 000 руб.
- 100,01%-110,00% + 15 000 руб.
- 110,01% и выше + 20 000 руб.
если KPI 2 выполнен на 98 % - то плюс 5 000
- 95,01%-100,00% + 5 000 руб.
- 100,01%-110,00% + 7 000 руб.
- 110,01% и выше + 10 000 руб.

Не понимаю как проставить критерии для ЕСЛИ в диапазоне %. Пример во вложении.

Автор - Tati_37
Дата добавления - 27.11.2023 в 22:43
AlexM Дата: Понедельник, 27.11.2023, 22:54 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4378
Репутация: 1079 ±
Замечаний: 0% ±

Excel 2003
На форум приходят за помощью/советом "Создать формулу"
Интересно бы смотрелось, когда все темы с одним названием.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеНа форум приходят за помощью/советом "Создать формулу"
Интересно бы смотрелось, когда все темы с одним названием.

Автор - AlexM
Дата добавления - 27.11.2023 в 22:54
Tati_37 Дата: Понедельник, 27.11.2023, 23:12 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 40% ±

Excel 2019
AlexM, я новичок, прошу понять и простить. Исправлюсь :(
 
Ответить
СообщениеAlexM, я новичок, прошу понять и простить. Исправлюсь :(

Автор - Tati_37
Дата добавления - 27.11.2023 в 23:12
Gustav Дата: Вторник, 28.11.2023, 02:34 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2649
Репутация: 1114 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Оформите где-то в сторонке табличку интервалов премии из двух колонок примерно такого вида (для KPI 1):
[vba]
Код
0%    0
95,01%    10 000
100,01%    15 000
110,01%    20 000
[/vba]
И ВПРкайте по ней на здоровье. Для KPI 2 - аналогичную табличку. Или добавьте его суммы в ту же табличку третьим столбцом, коль скоро процентные интервалы одни и те же.

Либо зашейти эти данные массивами прямо в формулы, имея в виду, что значение типа 95,01% нужно будет в этом случае превратить в 0,9501:
для KPI 1:
Код
=ВПР(D2;{0;0:0,9501;10000:1,0001;15000:1,1001;20000};2)

для KPI 2:
Код
=ВПР(D3;{0;0:0,9501;5000:1,0001;7000:1,1001;10000};2)


А тему попросите модераторов переименовать хотя бы в "Расчет премии в зависимости от % выполнения (ВПР)".


МОИ: Ник, Tip box: 41001663842605
 
Ответить
СообщениеОформите где-то в сторонке табличку интервалов премии из двух колонок примерно такого вида (для KPI 1):
[vba]
Код
0%    0
95,01%    10 000
100,01%    15 000
110,01%    20 000
[/vba]
И ВПРкайте по ней на здоровье. Для KPI 2 - аналогичную табличку. Или добавьте его суммы в ту же табличку третьим столбцом, коль скоро процентные интервалы одни и те же.

Либо зашейти эти данные массивами прямо в формулы, имея в виду, что значение типа 95,01% нужно будет в этом случае превратить в 0,9501:
для KPI 1:
Код
=ВПР(D2;{0;0:0,9501;10000:1,0001;15000:1,1001;20000};2)

для KPI 2:
Код
=ВПР(D3;{0;0:0,9501;5000:1,0001;7000:1,1001;10000};2)


А тему попросите модераторов переименовать хотя бы в "Расчет премии в зависимости от % выполнения (ВПР)".

Автор - Gustav
Дата добавления - 28.11.2023 в 02:34
jakim Дата: Вторник, 28.11.2023, 09:30 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1195
Репутация: 313 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=IF(A2="KPI 1";LOOKUP(D2;{0,95;1;1,1};{10000;15000;20000});LOOKUP(D2;{0,95;1;1,1};{5000;7000;10000}))
 
Ответить
Сообщение
Формула

Код
=IF(A2="KPI 1";LOOKUP(D2;{0,95;1;1,1};{10000;15000;20000});LOOKUP(D2;{0,95;1;1,1};{5000;7000;10000}))

Автор - jakim
Дата добавления - 28.11.2023 в 09:30
Serge_007 Дата: Вторник, 28.11.2023, 10:34 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 16450
Репутация: 2746 ±
Замечаний: ±

Excel 2016
100,00% + 5 000 руб.
- 100,01
А между 100% и 100,01% значения потеряли?

https://dzen.ru/a/ZPh-At5E7C2OWXas


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
100,00% + 5 000 руб.
- 100,01
А между 100% и 100,01% значения потеряли?

https://dzen.ru/a/ZPh-At5E7C2OWXas

Автор - Serge_007
Дата добавления - 28.11.2023 в 10:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет премии в зависимости от % выполнения (ВПР) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!