Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нарушается формула при удалении строк - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Нарушается формула при удалении строк
zavikzavik Дата: Среда, 06.12.2023, 09:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

365
доброго дня.
есть книга и 2 листа в ней.
на первом листе пользователи вносят данные, на втором я собираю итоги. Вот по этой формуле:
Код
=СУММЕСЛИМН(Лист1!$A$2:$G$1000;Лист1!$G$2:$G$1000;"3";Лист1!$D$2:$D$1000;16)

Но часто удаляют или добавляют в первый лист строки, соответственно рушатся мои формулы. Т.е. после нескольких удалений превращается в примерно такое:
Код
=СУММЕСЛИМН(Лист1!$A$2:$G$958;Лист1!$G$2:$G$958;"3";Лист1!$D$2:$D$958;16)

вроде и форумы похожие перечитал, всё равно не пойму как избавиться от этой проблемы.


zavik
 
Ответить
Сообщениедоброго дня.
есть книга и 2 листа в ней.
на первом листе пользователи вносят данные, на втором я собираю итоги. Вот по этой формуле:
Код
=СУММЕСЛИМН(Лист1!$A$2:$G$1000;Лист1!$G$2:$G$1000;"3";Лист1!$D$2:$D$1000;16)

Но часто удаляют или добавляют в первый лист строки, соответственно рушатся мои формулы. Т.е. после нескольких удалений превращается в примерно такое:
Код
=СУММЕСЛИМН(Лист1!$A$2:$G$958;Лист1!$G$2:$G$958;"3";Лист1!$D$2:$D$958;16)

вроде и форумы похожие перечитал, всё равно не пойму как избавиться от этой проблемы.

Автор - zavikzavik
Дата добавления - 06.12.2023 в 09:06
bigor Дата: Среда, 06.12.2023, 09:42 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1133
Репутация: 212 ±
Замечаний: 0% ±

нет
zavikzavik, фиксируем нижнюю границу
Код
=СУММЕСЛИМН(Лист1!$A$2:индекс(Лист1!$A$2:$a$1500;1000);Лист1!$G$2:индекс(Лист1!$g$2:$g$1500;1000);"3";Лист1!$D$2:индекс(Лист1!$d$2:$d$1500;1000);16)
 
Ответить
Сообщениеzavikzavik, фиксируем нижнюю границу
Код
=СУММЕСЛИМН(Лист1!$A$2:индекс(Лист1!$A$2:$a$1500;1000);Лист1!$G$2:индекс(Лист1!$g$2:$g$1500;1000);"3";Лист1!$D$2:индекс(Лист1!$d$2:$d$1500;1000);16)

Автор - bigor
Дата добавления - 06.12.2023 в 09:42
DrMini Дата: Среда, 06.12.2023, 10:03 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1722
Репутация: 235 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
А если так:
Код
=СУММЕСЛИМН(Лист1!A:A;Лист1!D:D;3;Лист1!G:G;16)
 
Ответить
СообщениеА если так:
Код
=СУММЕСЛИМН(Лист1!A:A;Лист1!D:D;3;Лист1!G:G;16)

Автор - DrMini
Дата добавления - 06.12.2023 в 10:03
zavikzavik Дата: Среда, 06.12.2023, 10:24 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

365
что-то как то сильно просто :)))
сейчас проверю :)


zavik
 
Ответить
Сообщениечто-то как то сильно просто :)))
сейчас проверю :)

Автор - zavikzavik
Дата добавления - 06.12.2023 в 10:24
zavikzavik Дата: Среда, 06.12.2023, 10:29 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

365
да, спасибо, работает !!! и то и то вроде работает.
я пробовал с "индекс" - не получилось, но хоть в правильном направлении думал :)
ещё раз всем спасибо!!!


zavik
 
Ответить
Сообщениеда, спасибо, работает !!! и то и то вроде работает.
я пробовал с "индекс" - не получилось, но хоть в правильном направлении думал :)
ещё раз всем спасибо!!!

Автор - zavikzavik
Дата добавления - 06.12.2023 в 10:29
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!