Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Удаление списанных серийных номеров - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Удаление списанных серийных номеров
DAUR Дата: Понедельник, 11.12.2023, 21:08 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Всем привет

Помогите пожалуйста с формулой
Имеется 3 группы столбцов - Поступление, Ремонт, Списание
Все группы идентичны и состоят из даты и серийных номеров
В группу Поступление вносят дату поступления и серийный номер
В группу Ремонт аналогично но эти серийные номера могут уйти и вернутся
В группе Списание серийные номера не возвращаются
В остатке необходима формула которая бы показывала только те серийные номера которые имеются на сегодняшний день
То есть формула сравнивает столбцы и оставляет только те которые не встречаются в группе Ремонт или Списание
Если в группе Ремонт появится номер то формула убирает серийный номер если дата поступления ранее даты отправки на ремонт - затем данный номер может вновь вернуться в группу поступления.
Номера в группе Списание удаляются безвозвратно

За ранее благодарю
К сообщению приложен файл: udalenie_nomerov.xlsx (9.5 Kb)
 
Ответить
СообщениеВсем привет

Помогите пожалуйста с формулой
Имеется 3 группы столбцов - Поступление, Ремонт, Списание
Все группы идентичны и состоят из даты и серийных номеров
В группу Поступление вносят дату поступления и серийный номер
В группу Ремонт аналогично но эти серийные номера могут уйти и вернутся
В группе Списание серийные номера не возвращаются
В остатке необходима формула которая бы показывала только те серийные номера которые имеются на сегодняшний день
То есть формула сравнивает столбцы и оставляет только те которые не встречаются в группе Ремонт или Списание
Если в группе Ремонт появится номер то формула убирает серийный номер если дата поступления ранее даты отправки на ремонт - затем данный номер может вновь вернуться в группу поступления.
Номера в группе Списание удаляются безвозвратно

За ранее благодарю

Автор - DAUR
Дата добавления - 11.12.2023 в 21:08
AlexM Дата: Понедельник, 11.12.2023, 23:26 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4514
Репутация: 1129 ±
Замечаний: 0% ±

Excel 2003
Тяжелая формула получилась
Код
=ИНДЕКС(A$1:A$11;НАИМЕНЬШИЙ(ЕСЛИ(НЕ(МУМНОЖ(ЕЧИСЛО(ПОИСК($B$3:$B$11;ТРАНСП($D$3:$D$11&" "&$F$3:$F$11)))*СТРОКА(A$3:A$11);СТРОКА(A$3:A$11)^0));СТРОКА(A$3:A$11));СТРОКА(A1)))

Формула массива
К сообщению приложен файл: udalenie_nomerov_1.xlsx (9.3 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеТяжелая формула получилась
Код
=ИНДЕКС(A$1:A$11;НАИМЕНЬШИЙ(ЕСЛИ(НЕ(МУМНОЖ(ЕЧИСЛО(ПОИСК($B$3:$B$11;ТРАНСП($D$3:$D$11&" "&$F$3:$F$11)))*СТРОКА(A$3:A$11);СТРОКА(A$3:A$11)^0));СТРОКА(A$3:A$11));СТРОКА(A1)))

Формула массива

Автор - AlexM
Дата добавления - 11.12.2023 в 23:26
AlexM Дата: Вторник, 12.12.2023, 09:07 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4514
Репутация: 1129 ±
Замечаний: 0% ±

Excel 2003
Немного короче
Код
=ИНДЕКС(A$1:A$11;НАИМЕНЬШИЙ(ЕСЛИ(МУМНОЖ(-ЕЧИСЛО(ПОИСК($B$3:$B$11;ТРАНСП($D$3:$D$11&" "&$F$3:$F$11)));СТРОКА(A$3:A$11)^0);0=1;СТРОКА(A$3:A$11));СТРОКА(A1)))
К сообщению приложен файл: udalenie_nomerov_2.xlsx (9.4 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеНемного короче
Код
=ИНДЕКС(A$1:A$11;НАИМЕНЬШИЙ(ЕСЛИ(МУМНОЖ(-ЕЧИСЛО(ПОИСК($B$3:$B$11;ТРАНСП($D$3:$D$11&" "&$F$3:$F$11)));СТРОКА(A$3:A$11)^0);0=1;СТРОКА(A$3:A$11));СТРОКА(A1)))

Автор - AlexM
Дата добавления - 12.12.2023 в 09:07
msi2102 Дата: Вторник, 12.12.2023, 09:26 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 414
Репутация: 129 ±
Замечаний: 0% ±

Excel 2007
Добавим немного экзотики
[vba]
Код
=ФИЛЬТР.XML("<t><s>"&ПОДСТАВИТЬ(ОБЪЕДИНИТЬ(";";1;B3:B11;D3:D11;F3:F11);";";"</s><s>")&"</s></t>";"//s[not(following::*=. or preceding::*=.)]")
[/vba]
К сообщению приложен файл: 6617464.xlsx (10.5 Kb)
 
Ответить
СообщениеДобавим немного экзотики
[vba]
Код
=ФИЛЬТР.XML("<t><s>"&ПОДСТАВИТЬ(ОБЪЕДИНИТЬ(";";1;B3:B11;D3:D11;F3:F11);";";"</s><s>")&"</s></t>";"//s[not(following::*=. or preceding::*=.)]")
[/vba]

Автор - msi2102
Дата добавления - 12.12.2023 в 09:26
DAUR Дата: Вторник, 12.12.2023, 10:23 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Спасибо огромное Сработало - все отлично
 
Ответить
СообщениеСпасибо огромное Сработало - все отлично

Автор - DAUR
Дата добавления - 12.12.2023 в 10:23
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!