Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества пустых ячеек в диапазоне - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Подсчет количества пустых ячеек в диапазоне
Vinc Дата: Четверг, 21.12.2023, 16:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 20% ±

Добрый день всем, у меня такая ситуация, хочу облегчить себе жизнь

Есть у меня таблица, в которой идет список учащихся, даты занятий и их посещаемость (как в обычных журналах). Я отмечаю отсутствующих в определенные дни. Мне, для дальнейшей аналитики, необходимо посчитать количество присутствующих учащихся (то есть пустых ячеек) за первую, вторую и т.д. четверти. Суть проблемы заключается в том, что я не могу сообразить, как указать именно тот диапазон дат, которым мне нужен. Использую данную формулу, но она считает просто все пустые ячейки за весь учебный период, а не только ту четверть, которая мне нужна:
Код
=СЧИТАТЬПУСТОТЫ(ЕСЛИ(D2:CD2<=B19;D3:CD15))
в ячейке B19 дата последнего дня первой четверти
в этих ячейках D2:CD2 даты занятий
здесь D3:CD15 ячейки, в которых отмечаю присутствующих/отсутствующих, если учащийся есть, то ячейка пустая, если нет, то ставится "н"

Заранее всем спасибо!


Сообщение отредактировал Serge_007 - Пятница, 22.12.2023, 09:34
 
Ответить
СообщениеДобрый день всем, у меня такая ситуация, хочу облегчить себе жизнь

Есть у меня таблица, в которой идет список учащихся, даты занятий и их посещаемость (как в обычных журналах). Я отмечаю отсутствующих в определенные дни. Мне, для дальнейшей аналитики, необходимо посчитать количество присутствующих учащихся (то есть пустых ячеек) за первую, вторую и т.д. четверти. Суть проблемы заключается в том, что я не могу сообразить, как указать именно тот диапазон дат, которым мне нужен. Использую данную формулу, но она считает просто все пустые ячейки за весь учебный период, а не только ту четверть, которая мне нужна:
Код
=СЧИТАТЬПУСТОТЫ(ЕСЛИ(D2:CD2<=B19;D3:CD15))
в ячейке B19 дата последнего дня первой четверти
в этих ячейках D2:CD2 даты занятий
здесь D3:CD15 ячейки, в которых отмечаю присутствующих/отсутствующих, если учащийся есть, то ячейка пустая, если нет, то ставится "н"

Заранее всем спасибо!

Автор - Vinc
Дата добавления - 21.12.2023 в 16:12
bigor Дата: Четверг, 21.12.2023, 16:49 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1133
Репутация: 212 ±
Замечаний: 0% ±

нет
Vinc, вы конечно все подробно описали, но файл пример все-равно не помешал бы
 
Ответить
СообщениеVinc, вы конечно все подробно описали, но файл пример все-равно не помешал бы

Автор - bigor
Дата добавления - 21.12.2023 в 16:49
Gustav Дата: Четверг, 21.12.2023, 16:52 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2763
Репутация: 1140 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Как-то так можно попробовать:
Код
=СЧИТАТЬПУСТОТЫ( СМЕЩ(D3:CD15 ;;;; ПОИСКПОЗ(B19; D2:CD2;0) ) )

Или так:
Код
=СЧИТАТЬПУСТОТЫ(D3:D15:ИНДЕКС(D3:CD15;0; ПОИСКПОЗ(B19;D2:CD2;0) ))

Или можно еще так - для единообразия первого и второго ИНДЕКСов (в смысле ссылки на один и тот же общий диапазон):
Код
=СЧИТАТЬПУСТОТЫ(ИНДЕКС(D3:CD15;0;1) : ИНДЕКС(D3:CD15;0; ПОИСКПОЗ(B19;D2:CD2;0) ))

Последняя форма особенно интересна для случаев "вырезок" из общего диапазона D3:CD15, начинающихся не с первого столбца (D), например, при подсчетах для второй и последующих четвертей.


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Четверг, 21.12.2023, 19:46
 
Ответить
СообщениеКак-то так можно попробовать:
Код
=СЧИТАТЬПУСТОТЫ( СМЕЩ(D3:CD15 ;;;; ПОИСКПОЗ(B19; D2:CD2;0) ) )

Или так:
Код
=СЧИТАТЬПУСТОТЫ(D3:D15:ИНДЕКС(D3:CD15;0; ПОИСКПОЗ(B19;D2:CD2;0) ))

Или можно еще так - для единообразия первого и второго ИНДЕКСов (в смысле ссылки на один и тот же общий диапазон):
Код
=СЧИТАТЬПУСТОТЫ(ИНДЕКС(D3:CD15;0;1) : ИНДЕКС(D3:CD15;0; ПОИСКПОЗ(B19;D2:CD2;0) ))

Последняя форма особенно интересна для случаев "вырезок" из общего диапазона D3:CD15, начинающихся не с первого столбца (D), например, при подсчетах для второй и последующих четвертей.

Автор - Gustav
Дата добавления - 21.12.2023 в 16:52
AlexM Дата: Четверг, 21.12.2023, 18:14 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4514
Репутация: 1129 ±
Замечаний: 0% ±

Excel 2003
Еще вариант
Код
=СЧЁТЕСЛИ(D3:ИНДЕКС(D3:CD15;;ПОИСКПОЗ(B19;D2:CD2));"")



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЕще вариант
Код
=СЧЁТЕСЛИ(D3:ИНДЕКС(D3:CD15;;ПОИСКПОЗ(B19;D2:CD2));"")

Автор - AlexM
Дата добавления - 21.12.2023 в 18:14
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!