Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет значений в диапазоне дат - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Подсчет значений в диапазоне дат
Snow Дата: Вторник, 26.12.2023, 15:20 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007,2010
Привет, умники)
Помогите пжл формулой. как посчитать значения в диапазоне дат?
Сколько дней в командировке водитель был в РБ и сколько в РФ
К сообщению приложен файл: kniga1.xlsx (9.2 Kb)
 
Ответить
СообщениеПривет, умники)
Помогите пжл формулой. как посчитать значения в диапазоне дат?
Сколько дней в командировке водитель был в РБ и сколько в РФ

Автор - Snow
Дата добавления - 26.12.2023 в 15:20
AlexM Дата: Вторник, 26.12.2023, 16:09 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4517
Репутация: 1129 ±
Замечаний: 0% ±

Excel 2003
Код
=СУММПРОИЗВ(($A2:ИНДЕКС($A2:$A20;ПОИСКПОЗ($F2;$A2:$A20;0))>=$E2)*($A2:ИНДЕКС($A2:$A20;ПОИСКПОЗ($F2;$A2:$A20;0))<=$F2)*($B2:ИНДЕКС($B2:$B20;ПОИСКПОЗ($F2;$A2:$A20;0))=C$1))
К сообщению приложен файл: kniga1_1.xlsx (9.0 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(($A2:ИНДЕКС($A2:$A20;ПОИСКПОЗ($F2;$A2:$A20;0))>=$E2)*($A2:ИНДЕКС($A2:$A20;ПОИСКПОЗ($F2;$A2:$A20;0))<=$F2)*($B2:ИНДЕКС($B2:$B20;ПОИСКПОЗ($F2;$A2:$A20;0))=C$1))

Автор - AlexM
Дата добавления - 26.12.2023 в 16:09
Snow Дата: Вторник, 26.12.2023, 16:23 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007,2010
=СУММПРОИЗВ(($A2:ИНДЕКС($A2:$A20;ПОИСКПОЗ($F2;$A2:$A20;0))>=$E2)*($A2:ИНДЕКС($A2:$A20;ПОИСКПОЗ($F2;$A2:$A20;0))<=$F2)*($B2:ИНДЕКС($B2:$B20;ПОИСКПОЗ($F2;$A2:$A20;0))=C$1))


СПАСИБО

 
Ответить
Сообщение
=СУММПРОИЗВ(($A2:ИНДЕКС($A2:$A20;ПОИСКПОЗ($F2;$A2:$A20;0))>=$E2)*($A2:ИНДЕКС($A2:$A20;ПОИСКПОЗ($F2;$A2:$A20;0))<=$F2)*($B2:ИНДЕКС($B2:$B20;ПОИСКПОЗ($F2;$A2:$A20;0))=C$1))


СПАСИБО


Автор - Snow
Дата добавления - 26.12.2023 в 16:23
Nic70y Дата: Вторник, 26.12.2023, 16:27 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 8872
Репутация: 2315 ±
Замечаний: 0% ±

Excel 2010
Код
=СЧЁТЕСЛИ($B2:ИНДЕКС($B2:$B$20;ПОИСКПОЗ($F2;$A2:$A$20;));C$1)
К сообщению приложен файл: 14_53.xlsx (9.3 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=СЧЁТЕСЛИ($B2:ИНДЕКС($B2:$B$20;ПОИСКПОЗ($F2;$A2:$A$20;));C$1)

Автор - Nic70y
Дата добавления - 26.12.2023 в 16:27
Snow Дата: Вторник, 26.12.2023, 17:19 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007,2010
=СЧЁТЕСЛИ($B2:ИНДЕКС($B2:$B$20;ПОИСКПОЗ($F2;$A2:$A$20;));C$1)

hands спасииибо
 
Ответить
Сообщение
=СЧЁТЕСЛИ($B2:ИНДЕКС($B2:$B$20;ПОИСКПОЗ($F2;$A2:$A$20;));C$1)

hands спасииибо

Автор - Snow
Дата добавления - 26.12.2023 в 17:19
AlexM Дата: Среда, 27.12.2023, 10:53 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4517
Репутация: 1129 ±
Замечаний: 0% ±

Excel 2003
Ужас. Сколько лишнего в моей формуле. 2/3 можно убрать.
Код
=СУММПРОИЗВ(--($B2:ИНДЕКС($B2:$B20;ПОИСКПОЗ($F2;$A2:$A20;))=C$1))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеУжас. Сколько лишнего в моей формуле. 2/3 можно убрать.
Код
=СУММПРОИЗВ(--($B2:ИНДЕКС($B2:$B20;ПОИСКПОЗ($F2;$A2:$A20;))=C$1))

Автор - AlexM
Дата добавления - 27.12.2023 в 10:53
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!