Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/суммирование по критериям таблицы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » суммирование по критериям таблицы (Формулы/Formulas)
суммирование по критериям таблицы
astashovmichail Дата: Среда, 27.12.2023, 09:52 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте. Имею загвоздку в написании формулы суммирования. Искал по архиву сайта по похожим темам, но увы подходящего не нашёл.
необходимо просуммировать по столбцу «i» числа для вычисления суммы по позиции «ПР02.493 [1]» и должно получится 474.
синим цветом в расчёте НЕ учитывать, т.к. например по первой и второй группах выделения (строка 1-12 и 25-28) позиция в столбце «А» ПР02.493 [1] соответствует позиции «РУ-8.00.00.000», и соответственно в столбце «А» ПР02.493 [1] соответствует позиции «ПРСК 172-2.00.00.000» а столбцы В-G (выделены разными цветами) разделены на равные ТРИ группы, и взять данные необходимо только по одному значению из каждой группы (т.е. что выделено жёлтым на фоне синего).
в строках 18-21 берутся все значения т.к. нет груп повторений по позициям в столбце «А» ПР02.493 [1] соответствует позиции «РСК 12-2.00.00.000»
К сообщению приложен файл: vopros1.xlsx (21.6 Kb)
 
Ответить
СообщениеЗдравствуйте. Имею загвоздку в написании формулы суммирования. Искал по архиву сайта по похожим темам, но увы подходящего не нашёл.
необходимо просуммировать по столбцу «i» числа для вычисления суммы по позиции «ПР02.493 [1]» и должно получится 474.
синим цветом в расчёте НЕ учитывать, т.к. например по первой и второй группах выделения (строка 1-12 и 25-28) позиция в столбце «А» ПР02.493 [1] соответствует позиции «РУ-8.00.00.000», и соответственно в столбце «А» ПР02.493 [1] соответствует позиции «ПРСК 172-2.00.00.000» а столбцы В-G (выделены разными цветами) разделены на равные ТРИ группы, и взять данные необходимо только по одному значению из каждой группы (т.е. что выделено жёлтым на фоне синего).
в строках 18-21 берутся все значения т.к. нет груп повторений по позициям в столбце «А» ПР02.493 [1] соответствует позиции «РСК 12-2.00.00.000»

Автор - astashovmichail
Дата добавления - 27.12.2023 в 09:52
Nic70y Дата: Среда, 27.12.2023, 10:38 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8650
Репутация: 2207 ±
Замечаний: 0% ±

Excel 2010
с допами
К сообщению приложен файл: 235.xlsx (22.6 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениес допами

Автор - Nic70y
Дата добавления - 27.12.2023 в 10:38
alexa1965 Дата: Среда, 27.12.2023, 10:52 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 341
Репутация: 55 ±
Замечаний: 0% ±

2003> 2019 >2016
Просто формула без допов
Код
=СУММЕСЛИМН(I1:I28;A1:A28;"ПР02.493 [1]";H1:H28;"РУ-8.00.00.000";C1:C28;"АМ 600Т")+СУММЕСЛИМН(I1:I28;A1:A28;"ПР02.493 [1]";H1:H28;"РСК 12-2.00.00.000")+СУММЕСЛИМН(I1:I28;A1:A28;"ПР02.493 [1]";H1:H28;"ПРСК 172-2.00.00.000";C1:C28;"АМ 600Т")


Главное не быть балабастиком
 
Ответить
СообщениеПросто формула без допов
Код
=СУММЕСЛИМН(I1:I28;A1:A28;"ПР02.493 [1]";H1:H28;"РУ-8.00.00.000";C1:C28;"АМ 600Т")+СУММЕСЛИМН(I1:I28;A1:A28;"ПР02.493 [1]";H1:H28;"РСК 12-2.00.00.000")+СУММЕСЛИМН(I1:I28;A1:A28;"ПР02.493 [1]";H1:H28;"ПРСК 172-2.00.00.000";C1:C28;"АМ 600Т")

Автор - alexa1965
Дата добавления - 27.12.2023 в 10:52
astashovmichail Дата: Среда, 27.12.2023, 11:32 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, спасибо. отлично считает, но если не только одну позицию ПР02.493 [1] надо посчитать, а сводную , а их может сотни быть. в данной таблице

ПР02.493 [1] - 474 - посчитали
ПР02.516
РУ-8.01.45.407
РСК 12.02.01.621
РСК 12.02.01.411 [1]
РСК 12.02.01.611
а остальные вручную изменять переменную позицию из перечня, но если их сотни :(
 
Ответить
СообщениеNic70y, спасибо. отлично считает, но если не только одну позицию ПР02.493 [1] надо посчитать, а сводную , а их может сотни быть. в данной таблице

ПР02.493 [1] - 474 - посчитали
ПР02.516
РУ-8.01.45.407
РСК 12.02.01.621
РСК 12.02.01.411 [1]
РСК 12.02.01.611
а остальные вручную изменять переменную позицию из перечня, но если их сотни :(

Автор - astashovmichail
Дата добавления - 27.12.2023 в 11:32
Nic70y Дата: Среда, 27.12.2023, 12:05 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 8650
Репутация: 2207 ±
Замечаний: 0% ±

Excel 2010
astashovmichail, так?
К сообщению приложен файл: 235_2.xlsx (21.7 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеastashovmichail, так?

Автор - Nic70y
Дата добавления - 27.12.2023 в 12:05
astashovmichail Дата: Среда, 27.12.2023, 12:19 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Nic70y,огромное СПАСИБО!!!!
 
Ответить
СообщениеNic70y,огромное СПАСИБО!!!!

Автор - astashovmichail
Дата добавления - 27.12.2023 в 12:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » суммирование по критериям таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!