Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества из дух столбцов - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Подсчет количества из дух столбцов
LAS_old Дата: Понедельник, 01.01.2024, 10:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Office 2016
Доброго всем. Подскажите какой формулой решить небольшую проблему. Есть два столбца. Тип авто и номерной знак. Рядом есть столбцы в котором хочу сделать выборку и подсчет. Делаю формулой COUNTIF. Но если в первом столбце к примеру из 5 легковых автомобилей оно мне может высчитать, то к примеру с грузовыми, в столбце у одного автомобиля нет номерного знака (будем условно считать что автомобиля как бы нет). Нужно что бы формула просчитала как несществующую одну клетку и по факту было бы 4 грузовика. Но если в пустую клетку вписать номер, оно пересчитало на нужное количесто - 5 грузовиков.
К сообщению приложен файл: 123456.xlsx (9.7 Kb)
 
Ответить
СообщениеДоброго всем. Подскажите какой формулой решить небольшую проблему. Есть два столбца. Тип авто и номерной знак. Рядом есть столбцы в котором хочу сделать выборку и подсчет. Делаю формулой COUNTIF. Но если в первом столбце к примеру из 5 легковых автомобилей оно мне может высчитать, то к примеру с грузовыми, в столбце у одного автомобиля нет номерного знака (будем условно считать что автомобиля как бы нет). Нужно что бы формула просчитала как несществующую одну клетку и по факту было бы 4 грузовика. Но если в пустую клетку вписать номер, оно пересчитало на нужное количесто - 5 грузовиков.

Автор - LAS_old
Дата добавления - 01.01.2024 в 10:27
jakim Дата: Понедельник, 01.01.2024, 11:15 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1205
Репутация: 313 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=SUMPRODUCT(--($C3:$C12=J1)*($D3:$D12<>""))
 
Ответить
Сообщение
Формула

Код
=SUMPRODUCT(--($C3:$C12=J1)*($D3:$D12<>""))

Автор - jakim
Дата добавления - 01.01.2024 в 11:15
LAS_old Дата: Понедельник, 01.01.2024, 12:05 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Office 2016
Пишет результат 0
 
Ответить
СообщениеПишет результат 0

Автор - LAS_old
Дата добавления - 01.01.2024 в 12:05
jakim Дата: Понедельник, 01.01.2024, 12:29 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1205
Репутация: 313 ±
Замечаний: 0% ±

Excel 2010
Уберите объединение ячеек в первой строке и формула будет работать.
К сообщению приложен файл: 123456_1.xlsx (9.6 Kb)
 
Ответить
Сообщение
Уберите объединение ячеек в первой строке и формула будет работать.

Автор - jakim
Дата добавления - 01.01.2024 в 12:29
LAS_old Дата: Понедельник, 01.01.2024, 12:35 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Office 2016
Понял, спасибо
 
Ответить
СообщениеПонял, спасибо

Автор - LAS_old
Дата добавления - 01.01.2024 в 12:35
i691198 Дата: Понедельник, 01.01.2024, 12:55 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 237
Репутация: 88 ±
Замечаний: 0% ±

Добрый день. С Новым годом Вас. Вдогонку пара формул для ячейки M3
Код
=СЧЁТЕСЛИМН(C3:C12;L1;D3:D12;"<>")

Или массивная
Код
=СУММ((C3:C12=L1)*(D3:D12<>""))
 
Ответить
СообщениеДобрый день. С Новым годом Вас. Вдогонку пара формул для ячейки M3
Код
=СЧЁТЕСЛИМН(C3:C12;L1;D3:D12;"<>")

Или массивная
Код
=СУММ((C3:C12=L1)*(D3:D12<>""))

Автор - i691198
Дата добавления - 01.01.2024 в 12:55
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!