Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование исключая совпадения - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование исключая совпадения (Формулы/Formulas)
Суммирование исключая совпадения
astashovmichail Дата: Среда, 10.01.2024, 16:26 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Добрый всем вечер. Столкнулся с проблемой нахождения суммы при наличии совпадений, которые необходимо игнорировать.
При отсутствии совпадений формула работает, а при наличии совпадений уже выдаёт результат который неприемлем: =СУММЕСЛИМН($F$9:$F$28;$B$9:$B$28;$I$14;$E$9:$E$28;J1;$A$9:$A$28;$H$14)
если в столбце «F» одинаковые значения (в нашем случае =1) при этом в столбце «В» соответствующие строки также одинаковы,а значения в столбце «А» соответствуют заданной ячейке поиска (в нашем случае КДН 04.472 и 40544 и 40543), результат должен быть = 1 (в нашем случае «1» или другому значению которое там будет стоять). Но так как в столбце «F» ещё присутствуют данные по поиску принадлежности к машине КДН-2 и соответствуют заданной ячейке поиска (в нашем случае КДН 04.472 и 40544 и 40543) выделено жёлтым, и там так же повторяются значения ( =7), то итоговой результат должен равняться 1+7=8, т.е. из первой группы результат =1, из второго совпадения =7, итого всего 8
К сообщению приложен файл: vopross.xlsx (20.9 Kb)
 
Ответить
СообщениеДобрый всем вечер. Столкнулся с проблемой нахождения суммы при наличии совпадений, которые необходимо игнорировать.
При отсутствии совпадений формула работает, а при наличии совпадений уже выдаёт результат который неприемлем: =СУММЕСЛИМН($F$9:$F$28;$B$9:$B$28;$I$14;$E$9:$E$28;J1;$A$9:$A$28;$H$14)
если в столбце «F» одинаковые значения (в нашем случае =1) при этом в столбце «В» соответствующие строки также одинаковы,а значения в столбце «А» соответствуют заданной ячейке поиска (в нашем случае КДН 04.472 и 40544 и 40543), результат должен быть = 1 (в нашем случае «1» или другому значению которое там будет стоять). Но так как в столбце «F» ещё присутствуют данные по поиску принадлежности к машине КДН-2 и соответствуют заданной ячейке поиска (в нашем случае КДН 04.472 и 40544 и 40543) выделено жёлтым, и там так же повторяются значения ( =7), то итоговой результат должен равняться 1+7=8, т.е. из первой группы результат =1, из второго совпадения =7, итого всего 8

Автор - astashovmichail
Дата добавления - 10.01.2024 в 16:26
AlexM Дата: Среда, 10.01.2024, 20:38 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4378
Репутация: 1079 ±
Замечаний: 0% ±

Excel 2003
Код
=СУММ(ИНДЕКС(ЕСЛИ(ЧАСТОТА(($B$8:$B$28&$E$8:$E$28=$I2&J$1)*($F$8:$F$28);--$F$8:$F$28);$F$8:$F$28;"");))
К сообщению приложен файл: vopross_1.xlsx (20.9 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=СУММ(ИНДЕКС(ЕСЛИ(ЧАСТОТА(($B$8:$B$28&$E$8:$E$28=$I2&J$1)*($F$8:$F$28);--$F$8:$F$28);$F$8:$F$28;"");))

Автор - AlexM
Дата добавления - 10.01.2024 в 20:38
astashovmichail Дата: Четверг, 11.01.2024, 08:56 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

AlexM, спасибо
 
Ответить
СообщениеAlexM, спасибо

Автор - astashovmichail
Дата добавления - 11.01.2024 в 08:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование исключая совпадения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!