Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск совпадений в 2х столбцах и вставка данных из соседнего - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Поиск совпадений в 2х столбцах и вставка данных из соседнего
piar61ru Дата: Четверг, 18.01.2024, 15:34 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

excel 2021
Всем привет. Задача такая, если значение в столбце F совпадает со значением в столбце D, то вставляем соответствующее значение из столбца G в столбец E.
К сообщению приложен файл: vneshnie_bitye.xlsx (276.8 Kb)
 
Ответить
СообщениеВсем привет. Задача такая, если значение в столбце F совпадает со значением в столбце D, то вставляем соответствующее значение из столбца G в столбец E.

Автор - piar61ru
Дата добавления - 18.01.2024 в 15:34
elovkov Дата: Четверг, 18.01.2024, 15:36 | Сообщение № 2
Группа: Друзья
Ранг: Обитатель
Сообщений: 383
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Ну как бы в Е2:
Код
=ЕСЛИ(F2=D2;G2;"")


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеНу как бы в Е2:
Код
=ЕСЛИ(F2=D2;G2;"")

Автор - elovkov
Дата добавления - 18.01.2024 в 15:36
piar61ru Дата: Четверг, 18.01.2024, 15:46 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

excel 2021
Ну как бы в Е2:


Строки в столбцах D могут повторяться и в F стоят не по порядку. Нужно что-то типа если в D2-D3000 есть совпадение с F с одним из его значений, то тогда выводим в E данные из G
 
Ответить
Сообщение
Ну как бы в Е2:


Строки в столбцах D могут повторяться и в F стоят не по порядку. Нужно что-то типа если в D2-D3000 есть совпадение с F с одним из его значений, то тогда выводим в E данные из G

Автор - piar61ru
Дата добавления - 18.01.2024 в 15:46
Nic70y Дата: Четверг, 18.01.2024, 15:49 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 8827
Репутация: 2300 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИОШИБКА(ВПР(D2;F:G;2;);"")


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ВПР(D2;F:G;2;);"")

Автор - Nic70y
Дата добавления - 18.01.2024 в 15:49
piar61ru Дата: Четверг, 18.01.2024, 16:08 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

excel 2021
=ЕСЛИОШИБКА(ВПР(D2;F:G;2;);"")

Супер, работает.
Вот у меня получился столбец E с данными.
А еще можете подсказать?
В столбце C есть дубли и в столбце E есть дубли. НО, дубли из C могут ссылаться на уникальные значения в E, и также уникальные значения в С могут ссылаться на дубли в E. Как тут быть? Нужно оставить все уникальные значения пары С и Е.


Сообщение отредактировал piar61ru - Четверг, 18.01.2024, 16:09
 
Ответить
Сообщение
=ЕСЛИОШИБКА(ВПР(D2;F:G;2;);"")

Супер, работает.
Вот у меня получился столбец E с данными.
А еще можете подсказать?
В столбце C есть дубли и в столбце E есть дубли. НО, дубли из C могут ссылаться на уникальные значения в E, и также уникальные значения в С могут ссылаться на дубли в E. Как тут быть? Нужно оставить все уникальные значения пары С и Е.

Автор - piar61ru
Дата добавления - 18.01.2024 в 16:08
Nic70y Дата: Четверг, 18.01.2024, 16:17 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 8827
Репутация: 2300 ±
Замечаний: 0% ±

Excel 2010
piar61ru, не совсем Вас понял, точнее совсем не понял.
можете в файле вручную показать что должно получиться?


ЮMoney 41001841029809
 
Ответить
Сообщениеpiar61ru, не совсем Вас понял, точнее совсем не понял.
можете в файле вручную показать что должно получиться?

Автор - Nic70y
Дата добавления - 18.01.2024 в 16:17
piar61ru Дата: Четверг, 18.01.2024, 16:31 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

excel 2021
на скрине столбец А имеет одинаковые значения, они ссылаются на разные значения в столбце С. Может быть наоборот, разные значения в А ссылаться на одинаковые в С. Я удаляю или выделяю в столбце С дубли, а вместе с ними удаляются уникальные значения в А. а мне нужно их оставить. Наверное, если в А и С одновременно одинаковые значения, тогда удаляем. вот точно.
К сообщению приложен файл: 0515235.png (153.1 Kb)
 
Ответить
Сообщениена скрине столбец А имеет одинаковые значения, они ссылаются на разные значения в столбце С. Может быть наоборот, разные значения в А ссылаться на одинаковые в С. Я удаляю или выделяю в столбце С дубли, а вместе с ними удаляются уникальные значения в А. а мне нужно их оставить. Наверное, если в А и С одновременно одинаковые значения, тогда удаляем. вот точно.

Автор - piar61ru
Дата добавления - 18.01.2024 в 16:31
Nic70y Дата: Четверг, 18.01.2024, 16:42 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 8827
Репутация: 2300 ±
Замечаний: 0% ±

Excel 2010
а если выделить A-B-C одновременно и удалить дубликаты?


ЮMoney 41001841029809
 
Ответить
Сообщениеа если выделить A-B-C одновременно и удалить дубликаты?

Автор - Nic70y
Дата добавления - 18.01.2024 в 16:42
piar61ru Дата: Четверг, 18.01.2024, 17:30 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

excel 2021
а если выделить A-B-C одновременно и удалить дубликаты?

Пока не пойму. Сложно оценить результат
 
Ответить
Сообщение
а если выделить A-B-C одновременно и удалить дубликаты?

Пока не пойму. Сложно оценить результат

Автор - piar61ru
Дата добавления - 18.01.2024 в 17:30
piar61ru Дата: Четверг, 18.01.2024, 17:33 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

excel 2021
а если выделить A-B-C одновременно и удалить дубликаты?

Пока не пойму. Сложно оценить результат


Не получается так, строки сдвигаются, соответствие строк пропадает.
 
Ответить
Сообщение
а если выделить A-B-C одновременно и удалить дубликаты?

Пока не пойму. Сложно оценить результат


Не получается так, строки сдвигаются, соответствие строк пропадает.

Автор - piar61ru
Дата добавления - 18.01.2024 в 17:33
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!