Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Создать свой формат ячейки с кадастровым номером - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создать свой формат ячейки с кадастровым номером (Формулы/Formulas)
Создать свой формат ячейки с кадастровым номером
fintepluha Дата: Четверг, 18.01.2024, 17:17 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

последний
Здравствуйте! Извините, нужно чтобы при вводе в ячейку цифр например 11123456788 отображалось как 24:11:1234567:88.

24: - должно быть всегда и без его ввода вручную
далее после : идут всегда 2 цифры (ни больше ни меньше), в примере :11
далее после :11 всегда должно быть 7 цифр (ни больше ни меньше), в примере :1234567
ну и после последнего : может быть любое количество цифр, в пример :88

И если возможно, как сделать, так чтобы при формировании в ячейке кадастрового номера например 24:11:1234567:88 в соседней ячейке появлялось определенные слова в зависимости от той цифры, которая идет после 24: (из примера это 11). И раз там 11 то в соседней будет написано - Емельяновский, а если будет 01 то в соседней будет слово - Абанский и так далее?

Спасибо!
 
Ответить
СообщениеЗдравствуйте! Извините, нужно чтобы при вводе в ячейку цифр например 11123456788 отображалось как 24:11:1234567:88.

24: - должно быть всегда и без его ввода вручную
далее после : идут всегда 2 цифры (ни больше ни меньше), в примере :11
далее после :11 всегда должно быть 7 цифр (ни больше ни меньше), в примере :1234567
ну и после последнего : может быть любое количество цифр, в пример :88

И если возможно, как сделать, так чтобы при формировании в ячейке кадастрового номера например 24:11:1234567:88 в соседней ячейке появлялось определенные слова в зависимости от той цифры, которая идет после 24: (из примера это 11). И раз там 11 то в соседней будет написано - Емельяновский, а если будет 01 то в соседней будет слово - Абанский и так далее?

Спасибо!

Автор - fintepluha
Дата добавления - 18.01.2024 в 17:17
AlexM Дата: Четверг, 18.01.2024, 18:48 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4379
Репутация: 1081 ±
Замечаний: 0% ±

Excel 2003
Формат ячейки
24\:00\:0000000\:00



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Четверг, 18.01.2024, 18:49
 
Ответить
СообщениеФормат ячейки
24\:00\:0000000\:00

Автор - AlexM
Дата добавления - 18.01.2024 в 18:48
DrMini Дата: Четверг, 18.01.2024, 20:27 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте fintepluha,
если возможно, как сделать, так чтобы при формировании в ячейке кадастрового номера например 24:11:1234567:88 в соседней ячейке появлялось определенные слова в зависимости от той цифры

Посмотрите. Вдруг подойдёт:
Код
=ВПР(ЦЕЛОЕ(ЛЕВСИМВ(ТЕКСТ(A1;"00000000000");2));$F$1:$G$15;2;ЛОЖЬ)
К сообщению приложен файл: kadastr.xlsx (9.7 Kb)
 
Ответить
СообщениеЗдравствуйте fintepluha,
если возможно, как сделать, так чтобы при формировании в ячейке кадастрового номера например 24:11:1234567:88 в соседней ячейке появлялось определенные слова в зависимости от той цифры

Посмотрите. Вдруг подойдёт:
Код
=ВПР(ЦЕЛОЕ(ЛЕВСИМВ(ТЕКСТ(A1;"00000000000");2));$F$1:$G$15;2;ЛОЖЬ)

Автор - DrMini
Дата добавления - 18.01.2024 в 20:27
AlexM Дата: Четверг, 18.01.2024, 20:34 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4379
Репутация: 1081 ±
Замечаний: 0% ±

Excel 2003
DrMini, так покороче
Код
=ВПР(ОТБР(A1/10^9);$F$1:$G$15;2;)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеDrMini, так покороче
Код
=ВПР(ОТБР(A1/10^9);$F$1:$G$15;2;)

Автор - AlexM
Дата добавления - 18.01.2024 в 20:34
DrMini Дата: Пятница, 19.01.2024, 05:33 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
так покороче

Не могу с этим не согласится. Но с моим уровнем знаний Excel только романы писать.
:)
 
Ответить
Сообщение
так покороче

Не могу с этим не согласится. Но с моим уровнем знаний Excel только романы писать.
:)

Автор - DrMini
Дата добавления - 19.01.2024 в 05:33
AlexM Дата: Пятница, 19.01.2024, 09:51 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4379
Репутация: 1081 ±
Замечаний: 0% ±

Excel 2003
Не скромничайте. У вас хороший уровень. :)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеНе скромничайте. У вас хороший уровень. :)

Автор - AlexM
Дата добавления - 19.01.2024 в 09:51
fintepluha Дата: Пятница, 19.01.2024, 15:39 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

последний
Формат ячейки
24\:00\:0000000\:00


Спасибо! Вот только после последнего двоеточия не всегда могут быть только 2 знака, если писать больше 2х знаков в этой форме, то все уезжает влево и соответственно номер искажается
 
Ответить
Сообщение
Формат ячейки
24\:00\:0000000\:00


Спасибо! Вот только после последнего двоеточия не всегда могут быть только 2 знака, если писать больше 2х знаков в этой форме, то все уезжает влево и соответственно номер искажается

Автор - fintepluha
Дата добавления - 19.01.2024 в 15:39
fintepluha Дата: Пятница, 19.01.2024, 15:41 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

последний
Посмотрите. Вдруг подойдёт:


Спасибо! Выглядит на то, что нужно.
 
Ответить
Сообщение
Посмотрите. Вдруг подойдёт:


Спасибо! Выглядит на то, что нужно.

Автор - fintepluha
Дата добавления - 19.01.2024 в 15:41
AlexM Дата: Пятница, 19.01.2024, 16:08 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4379
Репутация: 1081 ±
Замечаний: 0% ±

Excel 2003
[>99999999999]24\:00\:0000000\:000;24\:00\:0000000\:00
Код
=ВПР(--ЛЕВБ(A1;2);$F$1:$G$15;2;)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Пятница, 19.01.2024, 16:15
 
Ответить
Сообщение[>99999999999]24\:00\:0000000\:000;24\:00\:0000000\:00
Код
=ВПР(--ЛЕВБ(A1;2);$F$1:$G$15;2;)

Автор - AlexM
Дата добавления - 19.01.2024 в 16:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создать свой формат ячейки с кадастровым номером (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!