Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Упростить формулу - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Упростить формулу
Chelovekov Дата: Суббота, 20.01.2024, 03:19 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 310
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Здравствуйте, Уважаемые Форумчане. Прошу, Вас, помочь решить проблему, нужно упростить следующую формулу, так как условий может быть много, и формула становиться очень длинной.

Код
=ЕСЛИ(B2=1;Имена[1Имя];ЕСЛИ(B2=2;Имена[2Имя];ЕСЛИ(B2=3;Имена[3Имя];"")))


Пример прилагаю.
К сообщению приложен файл: 0098851.xlsx (11.5 Kb)
 
Ответить
СообщениеЗдравствуйте, Уважаемые Форумчане. Прошу, Вас, помочь решить проблему, нужно упростить следующую формулу, так как условий может быть много, и формула становиться очень длинной.

Код
=ЕСЛИ(B2=1;Имена[1Имя];ЕСЛИ(B2=2;Имена[2Имя];ЕСЛИ(B2=3;Имена[3Имя];"")))


Пример прилагаю.

Автор - Chelovekov
Дата добавления - 20.01.2024 в 03:19
DrMini Дата: Суббота, 20.01.2024, 06:37 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1679
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте Chelovekov,
Как вариант:
Код
=ИНДЕКС(Имена[#Все];2;B2)

что-то функция переводчика тупит:
[vba]
Код
=ИНДЕКС(Имена[#Все];2;B2)
[/vba]
К сообщению приложен файл: 9984625.xlsx (11.6 Kb)


Сообщение отредактировал DrMini - Суббота, 20.01.2024, 06:40
 
Ответить
СообщениеЗдравствуйте Chelovekov,
Как вариант:
Код
=ИНДЕКС(Имена[#Все];2;B2)

что-то функция переводчика тупит:
[vba]
Код
=ИНДЕКС(Имена[#Все];2;B2)
[/vba]

Автор - DrMini
Дата добавления - 20.01.2024 в 06:37
Chelovekov Дата: Суббота, 20.01.2024, 06:57 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 310
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Извеняюсь, но немного не корректно составил пример. Поэтому данное решение не подходит.
Пример изменил.
К сообщению приложен файл: 1559642.xlsx (11.8 Kb)
 
Ответить
СообщениеИзвеняюсь, но немного не корректно составил пример. Поэтому данное решение не подходит.
Пример изменил.

Автор - Chelovekov
Дата добавления - 20.01.2024 в 06:57
DrMini Дата: Суббота, 20.01.2024, 07:09 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1679
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Пример изменил.

Может тогда так:
Код
=ГПР(B2&"*";Имена[#Все];2;ЛОЖЬ)

опять... %)
[vba]
Код
=ГПР(B2&"*";Имена[#Все];2;ЛОЖЬ)
[/vba]


Сообщение отредактировал DrMini - Суббота, 20.01.2024, 07:10
 
Ответить
Сообщение
Пример изменил.

Может тогда так:
Код
=ГПР(B2&"*";Имена[#Все];2;ЛОЖЬ)

опять... %)
[vba]
Код
=ГПР(B2&"*";Имена[#Все];2;ЛОЖЬ)
[/vba]

Автор - DrMini
Дата добавления - 20.01.2024 в 07:09
Chelovekov Дата: Суббота, 20.01.2024, 07:19 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 310
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Спасибо hands
 
Ответить
СообщениеСпасибо hands

Автор - Chelovekov
Дата добавления - 20.01.2024 в 07:19
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!