Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка данных в формулу из ячейки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Подстановка данных в формулу из ячейки
Chelovekov Дата: Суббота, 20.01.2024, 08:55 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 313
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Здравствуйте, Уважаемые Форумчане. Прошу, Вас, помочь решить проблему, если в ячейки А1 стоит 5, будет такая формула

Код
=ЕСЛИ($A$1=5;ЕСЛИ((Результат[5М.П1]>=$Q$3)*(Результат[5М.П1]<=$Q$3);"1";"")


Если значение меняется на 10 будет такая формула

Код
=ЕСЛИ($A$1=10;ЕСЛИ((Результат[10М.П1]>=$Q$3)*(Результат[10М.П1]<=$Q$3);"1";"")


Нужно что бы в формуле автоматически менялись параметры 5 - 5М, 10 - 10М, 15 - 15М и так далее .

Заранее благодарен.


Сообщение отредактировал Chelovekov - Суббота, 20.01.2024, 08:58
 
Ответить
СообщениеЗдравствуйте, Уважаемые Форумчане. Прошу, Вас, помочь решить проблему, если в ячейки А1 стоит 5, будет такая формула

Код
=ЕСЛИ($A$1=5;ЕСЛИ((Результат[5М.П1]>=$Q$3)*(Результат[5М.П1]<=$Q$3);"1";"")


Если значение меняется на 10 будет такая формула

Код
=ЕСЛИ($A$1=10;ЕСЛИ((Результат[10М.П1]>=$Q$3)*(Результат[10М.П1]<=$Q$3);"1";"")


Нужно что бы в формуле автоматически менялись параметры 5 - 5М, 10 - 10М, 15 - 15М и так далее .

Заранее благодарен.

Автор - Chelovekov
Дата добавления - 20.01.2024 в 08:55
gling Дата: Суббота, 20.01.2024, 09:50 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2527
Репутация: 679 ±
Замечаний: 0% ±

2010
Здравствуйте.
А у вас эти формулы работают? Что такое Результат[5М.П1], это именованная ячейка? А лучше Было-бы если вы файл с примером приложили.
если в ячейки А1 стоит 5, будет такая формула
это и пропишите в формуле, ЕСЛИ(А1=5; формул1; формула2)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
А у вас эти формулы работают? Что такое Результат[5М.П1], это именованная ячейка? А лучше Было-бы если вы файл с примером приложили.
если в ячейки А1 стоит 5, будет такая формула
это и пропишите в формуле, ЕСЛИ(А1=5; формул1; формула2)

Автор - gling
Дата добавления - 20.01.2024 в 09:50
Pelena Дата: Суббота, 20.01.2024, 10:27 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 19235
Репутация: 4433 ±
Замечаний: ±

Excel 365 & Mac Excel
файл с примером приложили
присоединяюсь

без файла
Код
=ЕСЛИ((ДВССЫЛ("Результат["&$A$1&"М.П1]")>=$Q$3)*(ДВССЫЛ("Результат["&$A$1&"М.П1]")<=$Q$3);"1";"")

или
Код
=(ДВССЫЛ("Результат["&$A$1&"М.П1]")>=$Q$3)*(ДВССЫЛ("Результат["&$A$1&"М.П1]")<=$Q$3)
и форматом скрыть нули


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщение
файл с примером приложили
присоединяюсь

без файла
Код
=ЕСЛИ((ДВССЫЛ("Результат["&$A$1&"М.П1]")>=$Q$3)*(ДВССЫЛ("Результат["&$A$1&"М.П1]")<=$Q$3);"1";"")

или
Код
=(ДВССЫЛ("Результат["&$A$1&"М.П1]")>=$Q$3)*(ДВССЫЛ("Результат["&$A$1&"М.П1]")<=$Q$3)
и форматом скрыть нули

Автор - Pelena
Дата добавления - 20.01.2024 в 10:27
Chelovekov Дата: Суббота, 20.01.2024, 12:18 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 313
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Всем спасибо, все работает. hands Извените, но пример был громозкий.
 
Ответить
СообщениеВсем спасибо, все работает. hands Извените, но пример был громозкий.

Автор - Chelovekov
Дата добавления - 20.01.2024 в 12:18
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!