Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/% выполнения плана за день сделать положительным - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
% выполнения плана за день сделать положительным
Tati_37 Дата: Понедельник, 22.01.2024, 23:06 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 40% ±

Excel 2019
Добрый день. У сотрудника есть план на месяц, нужно поставить план на день, исходя из факта и оставшихся рабочих дней. Если сотрудник уже план месяца выполнил, то план на день получается отрицательным (ячейки Е) и соответственно % выполнения ежедневного плана тоже с минусом. Подскажите пожалуйста можно ли как-то это исправить (например план на день сделать "0", а % - положительным значением)?
К сообщению приложен файл: forum_plan_na_den.xlsx (12.8 Kb)
 
Ответить
СообщениеДобрый день. У сотрудника есть план на месяц, нужно поставить план на день, исходя из факта и оставшихся рабочих дней. Если сотрудник уже план месяца выполнил, то план на день получается отрицательным (ячейки Е) и соответственно % выполнения ежедневного плана тоже с минусом. Подскажите пожалуйста можно ли как-то это исправить (например план на день сделать "0", а % - положительным значением)?

Автор - Tati_37
Дата добавления - 22.01.2024 в 23:06
Gustav Дата: Вторник, 23.01.2024, 00:42 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2763
Репутация: 1140 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Я бы сделал такую формулу:
[vba]
Код
=ЕСЛИ( (месПлан - месФакт)/остДней < месПлан/всегоДней; месПлан/всегоДней; (месПлан - месФакт)/остДней )
[/vba]
Т.е. для ячейки E5 так:
Код
=ЕСЛИ((B5-C5)/$B$3 < B5/$B$2; B5/$B$2; (B5-C5)/$B$3)

Т.е. принцип такой: план на день в любой день не может быть меньше среднемесячного плана на день, рассчитанного в начале месяца (как месПлан/всегоДней).

Либо можно принять какое-нибудь "бонусное понижение" плана. Простейший напрашивающийся коэффициент - 0,5, т.е. половина от среднемесячного плана на день. В этом случае сотрудник (склад, регион), уже выполнивший план в середине месяца, получает на оставшиеся дни месяца "щадящий режим" с "половинным" дневным планом:
Код
=ЕСЛИ((B5-C5)/$B$3 < 0,5*B5/$B$2; 0,5*B5/$B$2; (B5-C5)/$B$3)


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Вторник, 23.01.2024, 00:58
 
Ответить
СообщениеЯ бы сделал такую формулу:
[vba]
Код
=ЕСЛИ( (месПлан - месФакт)/остДней < месПлан/всегоДней; месПлан/всегоДней; (месПлан - месФакт)/остДней )
[/vba]
Т.е. для ячейки E5 так:
Код
=ЕСЛИ((B5-C5)/$B$3 < B5/$B$2; B5/$B$2; (B5-C5)/$B$3)

Т.е. принцип такой: план на день в любой день не может быть меньше среднемесячного плана на день, рассчитанного в начале месяца (как месПлан/всегоДней).

Либо можно принять какое-нибудь "бонусное понижение" плана. Простейший напрашивающийся коэффициент - 0,5, т.е. половина от среднемесячного плана на день. В этом случае сотрудник (склад, регион), уже выполнивший план в середине месяца, получает на оставшиеся дни месяца "щадящий режим" с "половинным" дневным планом:
Код
=ЕСЛИ((B5-C5)/$B$3 < 0,5*B5/$B$2; 0,5*B5/$B$2; (B5-C5)/$B$3)

Автор - Gustav
Дата добавления - 23.01.2024 в 00:42
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!