Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Усечь конец по количеству знаков по формуле - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Усечь конец по количеству знаков по формуле
kaiyrkz0 Дата: Вторник, 23.01.2024, 18:36 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 39
Репутация: 0 ±
Замечаний: 0% ±

2007
Усечь конец по количеству знаков по формуле
К сообщению приложен файл: list_microsoft_excel.xlsx (8.2 Kb)
 
Ответить
СообщениеУсечь конец по количеству знаков по формуле

Автор - kaiyrkz0
Дата добавления - 23.01.2024 в 18:36
i691198 Дата: Вторник, 23.01.2024, 18:53 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 237
Репутация: 88 ±
Замечаний: 0% ±

Добрый вечер. Формула такая.
Код
=ПСТР(A2;1;ДЛСТР(A2)-3)
 
Ответить
СообщениеДобрый вечер. Формула такая.
Код
=ПСТР(A2;1;ДЛСТР(A2)-3)

Автор - i691198
Дата добавления - 23.01.2024 в 18:53
AlexM Дата: Вторник, 23.01.2024, 19:04 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4515
Репутация: 1129 ±
Замечаний: 0% ±

Excel 2003
Код
=ЛЕВБ(A2;ДЛСТР(A2)-3)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=ЛЕВБ(A2;ДЛСТР(A2)-3)

Автор - AlexM
Дата добавления - 23.01.2024 в 19:04
DrMini Дата: Среда, 24.01.2024, 05:03 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1734
Репутация: 236 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте kaiyrkz0,
ещё вариант:
Код
=ЗАМЕНИТЬ(A2;ДЛСТР(A2)-2;3;"")

и на случай если букв будет меньше 3-х то можно обернуть формулу функцией
=ЕСЛИОШИБКА
например вот так:
Код
=ЕСЛИОШИБКА(ЗАМЕНИТЬ(A2;ДЛСТР(A2)-2;3;"");"")
 
Ответить
СообщениеЗдравствуйте kaiyrkz0,
ещё вариант:
Код
=ЗАМЕНИТЬ(A2;ДЛСТР(A2)-2;3;"")

и на случай если букв будет меньше 3-х то можно обернуть формулу функцией
=ЕСЛИОШИБКА
например вот так:
Код
=ЕСЛИОШИБКА(ЗАМЕНИТЬ(A2;ДЛСТР(A2)-2;3;"");"")

Автор - DrMini
Дата добавления - 24.01.2024 в 05:03
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!