Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Копирования значений в строки с одинаковыми значениями - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Копирования значений в строки с одинаковыми значениями
Tracksimus Дата: Воскресенье, 28.01.2024, 00:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте,

Есть задача скопировать значения с ячеек с похожими названиями друг напротив друга,
названия отличаются только цифровым значением т.е. например скопировать цены на позицию
"AF 252 PAM 71B5" во все ячейки "AF 252 1/4.80 PAM 71B5", где будет меняться только числовое значение "1/4.80" и т.д.

Во вложении файл, в котором цветом выделил пример того, что хочу в итоге получить.
Задача очень простая, но хочется ее как-то автоматизировать.
К сообщению приложен файл: Order.xlsx (37.7 Kb)
 
Ответить
СообщениеЗдравствуйте,

Есть задача скопировать значения с ячеек с похожими названиями друг напротив друга,
названия отличаются только цифровым значением т.е. например скопировать цены на позицию
"AF 252 PAM 71B5" во все ячейки "AF 252 1/4.80 PAM 71B5", где будет меняться только числовое значение "1/4.80" и т.д.

Во вложении файл, в котором цветом выделил пример того, что хочу в итоге получить.
Задача очень простая, но хочется ее как-то автоматизировать.

Автор - Tracksimus
Дата добавления - 28.01.2024 в 00:02
DrMini Дата: Воскресенье, 28.01.2024, 06:10 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1732
Репутация: 236 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Как вариант до 860-ой строки
Код
=ВПР(ЛЕВСИМВ(B2;6)&ПРАВСИМВ(B2;ДЛСТР(B2)-ПОИСК("PAM";B2)+2);$G$2:$H$100;2;)
К сообщению приложен файл: 6130709.xlsx (44.7 Kb)
 
Ответить
СообщениеКак вариант до 860-ой строки
Код
=ВПР(ЛЕВСИМВ(B2;6)&ПРАВСИМВ(B2;ДЛСТР(B2)-ПОИСК("PAM";B2)+2);$G$2:$H$100;2;)

Автор - DrMini
Дата добавления - 28.01.2024 в 06:10
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!