Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нумерация строк по нескольким условиям. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нумерация строк по нескольким условиям. (Формулы/Formulas)
Нумерация строк по нескольким условиям.
FoxD69 Дата: Воскресенье, 28.01.2024, 11:16 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Доброго времени суток всем!
Прошу помощи у форума.
Необходимо решить задачу присвоения уникального номера (столбец F) совокупности операциям по однотипным инструментам, когда сумма (купля - продажа) по ним становится равной 0. Таблица по операциям ведется в хронологическом порядке, где присутствуют разные инструменты. Сделал столбец Е, где подсчитываю количество остатка по инструментам после каждой операции (чтобы не обращаться к списку с самой первой строки). Блок-схему и более подробное описание прилагаю в файле.
К сообщению приложен файл: 240128.xlsm (19.7 Kb)
 
Ответить
СообщениеДоброго времени суток всем!
Прошу помощи у форума.
Необходимо решить задачу присвоения уникального номера (столбец F) совокупности операциям по однотипным инструментам, когда сумма (купля - продажа) по ним становится равной 0. Таблица по операциям ведется в хронологическом порядке, где присутствуют разные инструменты. Сделал столбец Е, где подсчитываю количество остатка по инструментам после каждой операции (чтобы не обращаться к списку с самой первой строки). Блок-схему и более подробное описание прилагаю в файле.

Автор - FoxD69
Дата добавления - 28.01.2024 в 11:16
Pelena Дата: Воскресенье, 28.01.2024, 14:53 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 19137
Репутация: 4409 ±
Замечаний: ±

Excel 365 & Mac Excel
Здравствуйте.
В первую ячейку 1, начиная со второй
Код
=ЕСЛИ(СУММЕСЛИ($A$2:A2;A3;$D$2:D2);ПРОСМОТР(A3;$A$2:A2;$F$2:F2);МАКС($F$2:F2)+1)
К сообщению приложен файл: 6577349.xlsm (19.8 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
В первую ячейку 1, начиная со второй
Код
=ЕСЛИ(СУММЕСЛИ($A$2:A2;A3;$D$2:D2);ПРОСМОТР(A3;$A$2:A2;$F$2:F2);МАКС($F$2:F2)+1)

Автор - Pelena
Дата добавления - 28.01.2024 в 14:53
FoxD69 Дата: Воскресенье, 28.01.2024, 18:55 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Большое спасибо!!! Сильно выручили!!!
 
Ответить
СообщениеБольшое спасибо!!! Сильно выручили!!!

Автор - FoxD69
Дата добавления - 28.01.2024 в 18:55
FoxD69 Дата: Понедельник, 29.01.2024, 19:27 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Прошу прощения. Не подскажите, я правильно понял, что данное решение подходит только для отсортированных списков? Просто подставил другие наименования и формула слетела.
К сообщению приложен файл: primer1.xlsm (26.7 Kb)
 
Ответить
СообщениеПрошу прощения. Не подскажите, я правильно понял, что данное решение подходит только для отсортированных списков? Просто подставил другие наименования и формула слетела.

Автор - FoxD69
Дата добавления - 29.01.2024 в 19:27
Pelena Дата: Вторник, 30.01.2024, 00:32 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 19137
Репутация: 4409 ±
Замечаний: ±

Excel 365 & Mac Excel
Так не будет зависеть от сортировки
Код
=ЕСЛИ(СУММЕСЛИ($A$2:A2;A3;$D$2:D2);ПРОСМОТР(;-1/(A3=$A$2:A2);$F$2:F2);МАКС($F$2:F2)+1)

только результат не сошелся с вашим образцом
К сообщению приложен файл: 9735676.xlsm (27.4 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеТак не будет зависеть от сортировки
Код
=ЕСЛИ(СУММЕСЛИ($A$2:A2;A3;$D$2:D2);ПРОСМОТР(;-1/(A3=$A$2:A2);$F$2:F2);МАКС($F$2:F2)+1)

только результат не сошелся с вашим образцом

Автор - Pelena
Дата добавления - 30.01.2024 в 00:32
FoxD69 Дата: Вторник, 30.01.2024, 08:44 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Еще раз огромное спасибо за ответ!!! Более углубленный тест буду делать сегодня днем. Но на первый взгляд - подставил, все работает. Очень благодарю за помощь!!!
 
Ответить
СообщениеЕще раз огромное спасибо за ответ!!! Более углубленный тест буду делать сегодня днем. Но на первый взгляд - подставил, все работает. Очень благодарю за помощь!!!

Автор - FoxD69
Дата добавления - 30.01.2024 в 08:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нумерация строк по нескольким условиям. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!