Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР по 2 условиям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
ВПР по 2 условиям
brn60033110 Дата: Понедельник, 29.01.2024, 09:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Добрый день. Помогите пожалуйста разобраться с поиском решения.
Есть два массива данных к одному из них нужно вприть столбец со значением ,усложняется задача тем что в этих массивах есть повторяющиеся значения и по сути нужно впр по 2 условиям ,создавать дополнительные столбцы не хочется так как данных порядка 100000.
Буду рад вашему совету
К сообщению приложен файл: 29012024.xlsx (11.5 Kb)
 
Ответить
СообщениеДобрый день. Помогите пожалуйста разобраться с поиском решения.
Есть два массива данных к одному из них нужно вприть столбец со значением ,усложняется задача тем что в этих массивах есть повторяющиеся значения и по сути нужно впр по 2 условиям ,создавать дополнительные столбцы не хочется так как данных порядка 100000.
Буду рад вашему совету

Автор - brn60033110
Дата добавления - 29.01.2024 в 09:46
Nic70y Дата: Понедельник, 29.01.2024, 09:52 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8873
Репутация: 2315 ±
Замечаний: 0% ±

Excel 2010
вдруг правильно
Код
=СУММЕСЛИМН('От Сюда'!C:C;'От Сюда'!A:A;B3;'От Сюда'!B:B;F3)


ЮMoney 41001841029809
 
Ответить
Сообщениевдруг правильно
Код
=СУММЕСЛИМН('От Сюда'!C:C;'От Сюда'!A:A;B3;'От Сюда'!B:B;F3)

Автор - Nic70y
Дата добавления - 29.01.2024 в 09:52
brn60033110 Дата: Понедельник, 29.01.2024, 09:55 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Спасибо Nic70y.
Ты меня очень выручил, все работает.
 
Ответить
СообщениеСпасибо Nic70y.
Ты меня очень выручил, все работает.

Автор - brn60033110
Дата добавления - 29.01.2024 в 09:55
alexa1965 Дата: Понедельник, 29.01.2024, 10:02 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 347
Репутация: 56 ±
Замечаний: 0% ±

2003> 2019 >2016
Как вариант
Код
=СУММПРОИЗВ(('От Сюда'!A$3:A$29=Сюда!B3)*('От Сюда'!B$3:B$29=Сюда!F3)*('От Сюда'!C$3:C$29))


Главное не быть балабастиком
 
Ответить
СообщениеКак вариант
Код
=СУММПРОИЗВ(('От Сюда'!A$3:A$29=Сюда!B3)*('От Сюда'!B$3:B$29=Сюда!F3)*('От Сюда'!C$3:C$29))

Автор - alexa1965
Дата добавления - 29.01.2024 в 10:02
AlexM Дата: Понедельник, 29.01.2024, 11:00 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4517
Репутация: 1129 ±
Замечаний: 0% ±

Excel 2003
нужно вприть столбец со значением

Можно и ВПРить
Код
=ВПР(B3&"|"&F3;ЕСЛИ({1;0};ИНДЕКС('От Сюда'!A$3:A$35&"|"&'От Сюда'!B$3:B$35;);'От Сюда'!C$3:C$35);2;)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
нужно вприть столбец со значением

Можно и ВПРить
Код
=ВПР(B3&"|"&F3;ЕСЛИ({1;0};ИНДЕКС('От Сюда'!A$3:A$35&"|"&'От Сюда'!B$3:B$35;);'От Сюда'!C$3:C$35);2;)

Автор - AlexM
Дата добавления - 29.01.2024 в 11:00
brn60033110 Дата: Понедельник, 29.01.2024, 11:11 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

AlexM, Тоже работает. Спасибо огромное. Буду пробовать
 
Ответить
СообщениеAlexM, Тоже работает. Спасибо огромное. Буду пробовать

Автор - brn60033110
Дата добавления - 29.01.2024 в 11:11
jakim Дата: Понедельник, 29.01.2024, 18:58 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1208
Репутация: 314 ±
Замечаний: 0% ±

Excel 2010
Power Query

[vba]
Код
let
    Source = Excel.CurrentWorkbook(){[Name="Table1"]}[Content],
    #"Changed Type" = Table.TransformColumnTypes(Source,{{"Регион", type text}, {"Магазин", Int64.Type}, {"Отдел", Int64.Type}, {"Подотдел", Int64.Type}, {"Тип", Int64.Type}, {"Артикул", Int64.Type}, {"Наименование", type text}, {"Статус", type text}, {"ТОП", Int64.Type}, {"Гамма", type text}, {"Логистический ТОП", type text}, {"Теор. сток", Int64.Type}, {"Best", type any}, {"Срок поставки м агазтн", Int64.Type}, {"Задержка поставки", Int64.Type}, {"СДП", type number}, {"СДП Н-1", type any}, {"СДП Н-2", type any}, {"Прогресс СДП", type any}, {"Бастион", Int64.Type}}),
    #"Merged Queries" = Table.NestedJoin(#"Changed Type", {"Магазин", "Артикул"}, Table2, {"Магазин", "Арт"}, "Table2", JoinKind.LeftOuter),
    #"Expanded Table2" = Table.ExpandTableColumn(#"Merged Queries", "Table2", {"Продажи за неделю"}, {"Table2.Продажи за неделю"}),
    #"Removed Other Columns" = Table.SelectColumns(#"Expanded Table2",{"Table2.Продажи за неделю"}),
    #"Renamed Columns" = Table.RenameColumns(#"Removed Other Columns",{{"Table2.Продажи за неделю", "Продажи за неделю"}})
in
    #"Renamed Columns"
[/vba]
К сообщению приложен файл: 6713450.xlsx (22.9 Kb)
 
Ответить
Сообщение
Power Query

[vba]
Код
let
    Source = Excel.CurrentWorkbook(){[Name="Table1"]}[Content],
    #"Changed Type" = Table.TransformColumnTypes(Source,{{"Регион", type text}, {"Магазин", Int64.Type}, {"Отдел", Int64.Type}, {"Подотдел", Int64.Type}, {"Тип", Int64.Type}, {"Артикул", Int64.Type}, {"Наименование", type text}, {"Статус", type text}, {"ТОП", Int64.Type}, {"Гамма", type text}, {"Логистический ТОП", type text}, {"Теор. сток", Int64.Type}, {"Best", type any}, {"Срок поставки м агазтн", Int64.Type}, {"Задержка поставки", Int64.Type}, {"СДП", type number}, {"СДП Н-1", type any}, {"СДП Н-2", type any}, {"Прогресс СДП", type any}, {"Бастион", Int64.Type}}),
    #"Merged Queries" = Table.NestedJoin(#"Changed Type", {"Магазин", "Артикул"}, Table2, {"Магазин", "Арт"}, "Table2", JoinKind.LeftOuter),
    #"Expanded Table2" = Table.ExpandTableColumn(#"Merged Queries", "Table2", {"Продажи за неделю"}, {"Table2.Продажи за неделю"}),
    #"Removed Other Columns" = Table.SelectColumns(#"Expanded Table2",{"Table2.Продажи за неделю"}),
    #"Renamed Columns" = Table.RenameColumns(#"Removed Other Columns",{{"Table2.Продажи за неделю", "Продажи за неделю"}})
in
    #"Renamed Columns"
[/vba]

Автор - jakim
Дата добавления - 29.01.2024 в 18:58
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!