Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заливка ячейки по множеству условий - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Заливка ячейки по множеству условий
Skylptor Дата: Вторник, 30.01.2024, 07:20 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

2016
Добрый день, прошу помощи. Есть реестр работников куда вносятся данные по обученностям, документам, которые необходимы. Если не требуется обучение или документа ставят тире "-". Хотелось бы чтобы ФИО заливалось красным если просрочено или не заполнено.
К сообщению приложен файл: proba.xlsx (355.0 Kb)


Скульптор
 
Ответить
СообщениеДобрый день, прошу помощи. Есть реестр работников куда вносятся данные по обученностям, документам, которые необходимы. Если не требуется обучение или документа ставят тире "-". Хотелось бы чтобы ФИО заливалось красным если просрочено или не заполнено.

Автор - Skylptor
Дата добавления - 30.01.2024 в 07:20
elovkov Дата: Вторник, 30.01.2024, 08:30 | Сообщение № 2
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Как вариант, служебный столбец с ближайшей датой переаттестации
Код
=МИН(диапазон ячеек с датами)

И условное форматирование "использовать формулу"
Код
="ссылка на служебный столбец"<СЕГОДНЯ()

или, допустим чтобы за 7 дней предупреждало желтым
Код
="ссылка на служебный столбец"-7<СЕГОДНЯ()
К сообщению приложен файл: 3274194.xlsx (354.6 Kb)


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеКак вариант, служебный столбец с ближайшей датой переаттестации
Код
=МИН(диапазон ячеек с датами)

И условное форматирование "использовать формулу"
Код
="ссылка на служебный столбец"<СЕГОДНЯ()

или, допустим чтобы за 7 дней предупреждало желтым
Код
="ссылка на служебный столбец"-7<СЕГОДНЯ()

Автор - elovkov
Дата добавления - 30.01.2024 в 08:30
Skylptor Дата: Вторник, 30.01.2024, 09:26 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

2016
elovkov, К моему сожалению там намного больше столбцов, их надо тоже учитывать. И не везде может стоять дата. Может быть "-", "допуск". Надо как минимум учитывать диапазон столбцов J:AJ. Если бы были одни даты все бы было очень просто.


Скульптор

Сообщение отредактировал Skylptor - Вторник, 30.01.2024, 09:27
 
Ответить
Сообщениеelovkov, К моему сожалению там намного больше столбцов, их надо тоже учитывать. И не везде может стоять дата. Может быть "-", "допуск". Надо как минимум учитывать диапазон столбцов J:AJ. Если бы были одни даты все бы было очень просто.

Автор - Skylptor
Дата добавления - 30.01.2024 в 09:26
elovkov Дата: Вторник, 30.01.2024, 09:58 | Сообщение № 4
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
У Вас в диапазоне AC-AJ много пустых ячеек , только в 3й строке все заполнено
Если я правильно понял, пустая ячейка - это плохо, тогда можно в служебном столбце выбрать или минимальную дату, или если есть пустые ячейки вывести сегодняшнюю, и тогда красить по тем же условиям. но диапазон этот придется заполнять, хотя бы прочерками
Для столбца:
Код
=ЕСЛИ(ЕСЛИ(СУММ(--ЕПУСТО(J3:AJ3));1;0);СЕГОДНЯ();МИН(J3:AJ3))

массивная - вводится ктрл+шифт+энтер
[p.s.]я там файл позаполнял разными датами для пробы[/p.s.]
К сообщению приложен файл: 6650641.xlsx (354.8 Kb)


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица

Сообщение отредактировал elovkov - Вторник, 30.01.2024, 10:00
 
Ответить
СообщениеУ Вас в диапазоне AC-AJ много пустых ячеек , только в 3й строке все заполнено
Если я правильно понял, пустая ячейка - это плохо, тогда можно в служебном столбце выбрать или минимальную дату, или если есть пустые ячейки вывести сегодняшнюю, и тогда красить по тем же условиям. но диапазон этот придется заполнять, хотя бы прочерками
Для столбца:
Код
=ЕСЛИ(ЕСЛИ(СУММ(--ЕПУСТО(J3:AJ3));1;0);СЕГОДНЯ();МИН(J3:AJ3))

массивная - вводится ктрл+шифт+энтер
[p.s.]я там файл позаполнял разными датами для пробы[/p.s.]

Автор - elovkov
Дата добавления - 30.01.2024 в 09:58
Skylptor Дата: Вторник, 30.01.2024, 10:30 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

2016
elovkov, Спасибо огромное, сейчас буду пробовать на исходнике.


Скульптор
 
Ответить
Сообщениеelovkov, Спасибо огромное, сейчас буду пробовать на исходнике.

Автор - Skylptor
Дата добавления - 30.01.2024 в 10:30
elovkov Дата: Вторник, 30.01.2024, 10:53 | Сообщение № 6
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Skylptor, что-то я с ЕСЛИ перемудрил))) Можно покороче))
Код
=ЕСЛИ(СУММ(--ЕПУСТО(J3:AJ3));СЕГОДНЯ();МИН(J3:AJ3))

но тоже массивный ввод


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеSkylptor, что-то я с ЕСЛИ перемудрил))) Можно покороче))
Код
=ЕСЛИ(СУММ(--ЕПУСТО(J3:AJ3));СЕГОДНЯ();МИН(J3:AJ3))

но тоже массивный ввод

Автор - elovkov
Дата добавления - 30.01.2024 в 10:53
Serge_007 Дата: Вторник, 30.01.2024, 12:16 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
массивный ввод
Вариант без него:
Код
=ВЫБОР(1+(СУММПРОИЗВ(0+(J3:AJ3=""))>0);МИН(J3:AJ3);СЕГОДНЯ())


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
массивный ввод
Вариант без него:
Код
=ВЫБОР(1+(СУММПРОИЗВ(0+(J3:AJ3=""))>0);МИН(J3:AJ3);СЕГОДНЯ())

Автор - Serge_007
Дата добавления - 30.01.2024 в 12:16
AlexM Дата: Вторник, 30.01.2024, 13:43 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4513
Репутация: 1128 ±
Замечаний: 0% ±

Excel 2003
Еще немассивные
Код
=ЕСЛИ(СЧЁТЗ(J3:AJ3)<27;СЕГОДНЯ();МИН(J3:AJ3))
и
Код
=ЕСЛИ(СЧЁТЕСЛИ(J3:AJ3;"");СЕГОДНЯ();МИН(J3:AJ3))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЕще немассивные
Код
=ЕСЛИ(СЧЁТЗ(J3:AJ3)<27;СЕГОДНЯ();МИН(J3:AJ3))
и
Код
=ЕСЛИ(СЧЁТЕСЛИ(J3:AJ3;"");СЕГОДНЯ();МИН(J3:AJ3))

Автор - AlexM
Дата добавления - 30.01.2024 в 13:43
elovkov Дата: Вторник, 30.01.2024, 13:52 | Сообщение № 9
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Мда, как говорится - будь проще и люди к тебе потянутся)


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеМда, как говорится - будь проще и люди к тебе потянутся)

Автор - elovkov
Дата добавления - 30.01.2024 в 13:52
Skylptor Дата: Вторник, 30.01.2024, 14:16 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

2016
Всем огромное спасибо, буду пробовать разные варианты. Восхищен вашей отзывчивостью.


Скульптор
 
Ответить
СообщениеВсем огромное спасибо, буду пробовать разные варианты. Восхищен вашей отзывчивостью.

Автор - Skylptor
Дата добавления - 30.01.2024 в 14:16
elovkov Дата: Вторник, 30.01.2024, 14:58 | Сообщение № 11
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Еще в коллекцию до кучи)))
Код
=ЕСЛИ(СЧИТАТЬПУСТОТЫ(J3:AJ3);СЕГОДНЯ();МИН(J3:AJ3))

Принцип везде тот же, можно и допстобец не делать, сразу какую-то из формул в УФ прописать


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеЕще в коллекцию до кучи)))
Код
=ЕСЛИ(СЧИТАТЬПУСТОТЫ(J3:AJ3);СЕГОДНЯ();МИН(J3:AJ3))

Принцип везде тот же, можно и допстобец не делать, сразу какую-то из формул в УФ прописать

Автор - elovkov
Дата добавления - 30.01.2024 в 14:58
Skylptor Дата: Среда, 31.01.2024, 11:37 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

2016
elovkov, Еще раз спасибо. Тему можно закрывать


Скульптор
 
Ответить
Сообщениеelovkov, Еще раз спасибо. Тему можно закрывать

Автор - Skylptor
Дата добавления - 31.01.2024 в 11:37
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!