Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск строк со скрытием пустых столбцов - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск строк со скрытием пустых столбцов (Формулы/Formulas)
Поиск строк со скрытием пустых столбцов
Repz20105 Дата: Вторник, 30.01.2024, 09:34 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2019
Здравствуйте, коллеги. Можно ли как-то сделать так, чтоб условно при вводе в ячейку Лист2 А1 значения "Ст1кп" выводилась строка из таблицы Листа 3, но при отсутствии значения в столбце она бы просто скрывалась, чтоб лишнее место не занимало, и как это вообще сделать не прописывая в каждую ячейку функцию ВПР. Пример как это выглядеть должно я укажу в листе 4. Заранее огромное спасибо !
К сообщению приложен файл: materialy_kopija.xlsx (381.7 Kb)
 
Ответить
СообщениеЗдравствуйте, коллеги. Можно ли как-то сделать так, чтоб условно при вводе в ячейку Лист2 А1 значения "Ст1кп" выводилась строка из таблицы Листа 3, но при отсутствии значения в столбце она бы просто скрывалась, чтоб лишнее место не занимало, и как это вообще сделать не прописывая в каждую ячейку функцию ВПР. Пример как это выглядеть должно я укажу в листе 4. Заранее огромное спасибо !

Автор - Repz20105
Дата добавления - 30.01.2024 в 09:34
Nic70y Дата: Вторник, 30.01.2024, 09:48 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8650
Репутация: 2207 ±
Замечаний: 0% ±

Excel 2010
вариант - формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист3!$A:$AA;ПОИСКПОЗ($A1;Лист3!$A:$A;);НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС(Лист3!$D:$AA;ПОИСКПОЗ($A1;Лист3!$A:$A;);)<>"";СТОЛБЕЦ(Лист3!$D:$AA));СТОЛБЕЦ(A1)));"")
К сообщению приложен файл: 15.xlsx (397.9 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениевариант - формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист3!$A:$AA;ПОИСКПОЗ($A1;Лист3!$A:$A;);НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС(Лист3!$D:$AA;ПОИСКПОЗ($A1;Лист3!$A:$A;);)<>"";СТОЛБЕЦ(Лист3!$D:$AA));СТОЛБЕЦ(A1)));"")

Автор - Nic70y
Дата добавления - 30.01.2024 в 09:48
Repz20105 Дата: Вторник, 30.01.2024, 09:54 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2019
Nic70y, Невероятно, спасибо огромное !!!
 
Ответить
СообщениеNic70y, Невероятно, спасибо огромное !!!

Автор - Repz20105
Дата добавления - 30.01.2024 в 09:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск строк со скрытием пустых столбцов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!