Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Количество номерор от 0 до 3 равно1 - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество номерор от 0 до 3 равно1 (Формулы/Formulas)
Количество номерор от 0 до 3 равно1
zanasih84 Дата: Среда, 31.01.2024, 19:54 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте! Не хватает знаний, помогите пожалуйста создать формулу. Если в диапазоне B2:D2, количество номеров от 0 до 3 (включительно), ровно 1, то в ячейке G2 значение "ДА". Если номеров от 0 до 3 больше 1го, или номеров от 0 до 3 нет, или в диапазоне B2:D2 сразу есть и 1 и 2, то в ячейке G2 значение "НЕТ". То есть в диапазоне ячеек B2:D2 должно быть только одно число или 0 или 1 или 2 или 3, тогда "ДА"
К сообщению приложен файл: poligon.xlsm (10.7 Kb)
 
Ответить
СообщениеЗдравствуйте! Не хватает знаний, помогите пожалуйста создать формулу. Если в диапазоне B2:D2, количество номеров от 0 до 3 (включительно), ровно 1, то в ячейке G2 значение "ДА". Если номеров от 0 до 3 больше 1го, или номеров от 0 до 3 нет, или в диапазоне B2:D2 сразу есть и 1 и 2, то в ячейке G2 значение "НЕТ". То есть в диапазоне ячеек B2:D2 должно быть только одно число или 0 или 1 или 2 или 3, тогда "ДА"

Автор - zanasih84
Дата добавления - 31.01.2024 в 19:54
bmv98rus Дата: Среда, 31.01.2024, 20:33 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4095
Репутация: 766 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=COUNTIF(B2:D2;"<3")=1

Если нужно только целые и больше 0 то сложнее чуток


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=COUNTIF(B2:D2;"<3")=1

Если нужно только целые и больше 0 то сложнее чуток

Автор - bmv98rus
Дата добавления - 31.01.2024 в 20:33
i691198 Дата: Среда, 31.01.2024, 20:42 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 196
Репутация: 82 ±
Замечаний: 0% ±

Может быть так?
Код
=ЕСЛИ((СЧЁТЕСЛИ(B2:D2;">=0")-СЧЁТЕСЛИ(B2:D2;">3"))=1;"Да";"Нет")

Если числа целые и положительные, можно проще.
Код
=ЕСЛИ(СЧЁТЕСЛИ(B2:D2;">3")=2;"Да";"Нет")


Сообщение отредактировал i691198 - Среда, 31.01.2024, 20:49
 
Ответить
СообщениеМожет быть так?
Код
=ЕСЛИ((СЧЁТЕСЛИ(B2:D2;">=0")-СЧЁТЕСЛИ(B2:D2;">3"))=1;"Да";"Нет")

Если числа целые и положительные, можно проще.
Код
=ЕСЛИ(СЧЁТЕСЛИ(B2:D2;">3")=2;"Да";"Нет")

Автор - i691198
Дата добавления - 31.01.2024 в 20:42
zanasih84 Дата: Четверг, 01.02.2024, 20:41 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Спасибо огромное! =ЕСЛИ((СЧЁТЕСЛИ(B2:D2;">=0")-СЧЁТЕСЛИ(B2:D2;">3"))=1;"Да";"Нет") это то, что нужно.
 
Ответить
СообщениеСпасибо огромное! =ЕСЛИ((СЧЁТЕСЛИ(B2:D2;">=0")-СЧЁТЕСЛИ(B2:D2;">3"))=1;"Да";"Нет") это то, что нужно.

Автор - zanasih84
Дата добавления - 01.02.2024 в 20:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество номерор от 0 до 3 равно1 (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!