Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сбор значений по двум и более условиям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Сбор значений по двум и более условиям
MVA018 Дата: Четверг, 01.02.2024, 14:32 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2016
Всем здравия желаю. Прошу помочь с формулой.
Есть таблица(штатное расписание), где по столбцам как обычно указан должность, разряд, зарплата, ФИО.
Проблема вот в чем: Перечень должностей всего 16. А количество работников около 1000. Зарплата зависит от разряда работника.
Нужно сделать так, чтобы при смене названия должности и номера разряда зарплата считывалась автоматически (с боковой таблицы, ну или с другого документа).
На примере первых двух строк я собрал формулу с помощью функции ЕСЛИ с несколькими условиями. Но и тут я могу только сменой номера разряда правильно считывать зарплату. Не больше.
То, что я нахимичил не удовлетворяет моим требованиям. Т.е. во-первых, нельзя плюсиком формулу применить к последующим ячейкам.
Во-вторых ни как не смог в функциях интегрировать ВПР с названиями должности. Чтобы можно было менять название должности и разряд.
Что применимо в этом случае?
Очень прошу, помогите.
К сообщению приложен файл: zarplata.xlsx (21.3 Kb)
 
Ответить
СообщениеВсем здравия желаю. Прошу помочь с формулой.
Есть таблица(штатное расписание), где по столбцам как обычно указан должность, разряд, зарплата, ФИО.
Проблема вот в чем: Перечень должностей всего 16. А количество работников около 1000. Зарплата зависит от разряда работника.
Нужно сделать так, чтобы при смене названия должности и номера разряда зарплата считывалась автоматически (с боковой таблицы, ну или с другого документа).
На примере первых двух строк я собрал формулу с помощью функции ЕСЛИ с несколькими условиями. Но и тут я могу только сменой номера разряда правильно считывать зарплату. Не больше.
То, что я нахимичил не удовлетворяет моим требованиям. Т.е. во-первых, нельзя плюсиком формулу применить к последующим ячейкам.
Во-вторых ни как не смог в функциях интегрировать ВПР с названиями должности. Чтобы можно было менять название должности и разряд.
Что применимо в этом случае?
Очень прошу, помогите.

Автор - MVA018
Дата добавления - 01.02.2024 в 14:32
elovkov Дата: Четверг, 01.02.2024, 14:39 | Сообщение № 2
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Добрый день
Код
=ВПР(A3;$G$1:$K$15;ПОИСКПОЗ(B3&"-Разряд";$G$1:$K$1;0);0)

Только вот у Главбуха разряд 4, а в штатном максимум 3
К сообщению приложен файл: 4132827.xlsx (21.5 Kb)


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица

Сообщение отредактировал elovkov - Четверг, 01.02.2024, 14:43
 
Ответить
СообщениеДобрый день
Код
=ВПР(A3;$G$1:$K$15;ПОИСКПОЗ(B3&"-Разряд";$G$1:$K$1;0);0)

Только вот у Главбуха разряд 4, а в штатном максимум 3

Автор - elovkov
Дата добавления - 01.02.2024 в 14:39
DrMini Дата: Четверг, 01.02.2024, 15:22 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1722
Репутация: 235 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Прошу помочь с формулой

Как вариант:
Код
=СУММПРОИЗВ(($I$1:$L$1=B3&"-Разряд")*($G$2:$G$15=A3)*$I$2:$L$15)
К сообщению приложен файл: 9617301.xlsx (22.7 Kb)
 
Ответить
Сообщение
Прошу помочь с формулой

Как вариант:
Код
=СУММПРОИЗВ(($I$1:$L$1=B3&"-Разряд")*($G$2:$G$15=A3)*$I$2:$L$15)

Автор - DrMini
Дата добавления - 01.02.2024 в 15:22
Nic70y Дата: Четверг, 01.02.2024, 15:28 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 8821
Репутация: 2298 ±
Замечаний: 0% ±

Excel 2010
Код
=ВПР(A3;G$1:K$15;B3+2;)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ВПР(A3;G$1:K$15;B3+2;)

Автор - Nic70y
Дата добавления - 01.02.2024 в 15:28
elovkov Дата: Четверг, 01.02.2024, 15:31 | Сообщение № 5
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Код
B3+2

ЧЁРТ!!! Это красиво!!!


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
Код
B3+2

ЧЁРТ!!! Это красиво!!!

Автор - elovkov
Дата добавления - 01.02.2024 в 15:31
DrMini Дата: Четверг, 01.02.2024, 15:38 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1722
Репутация: 235 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Это красиво!!!

Не могу с этим не согласиться.
Никогда бы, даже в голову не пришло.
 
Ответить
Сообщение
Это красиво!!!

Не могу с этим не согласиться.
Никогда бы, даже в голову не пришло.

Автор - DrMini
Дата добавления - 01.02.2024 в 15:38
MVA018 Дата: Четверг, 01.02.2024, 17:01 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2016
Ребята, вы все красавцы. Спасибо большое.
 
Ответить
СообщениеРебята, вы все красавцы. Спасибо большое.

Автор - MVA018
Дата добавления - 01.02.2024 в 17:01
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!