Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/как посчитать сумму недель в столбце с датами - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как посчитать сумму недель в столбце с датами (Формулы/Formulas)
как посчитать сумму недель в столбце с датами
maksvl007 Дата: Четверг, 01.02.2024, 15:42 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте. Помогите посчитать сумму недель в заданном столбце. Посчитать месяц получилось . Файл приложил.
К сообщению приложен файл: kol_vo_nedel.xlsx (10.5 Kb)
 
Ответить
СообщениеЗдравствуйте. Помогите посчитать сумму недель в заданном столбце. Посчитать месяц получилось . Файл приложил.

Автор - maksvl007
Дата добавления - 01.02.2024 в 15:42
elovkov Дата: Четверг, 01.02.2024, 16:21 | Сообщение № 2
Группа: Друзья
Ранг: Обитатель
Сообщений: 364
Репутация: 50 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте, Вашей же формулой, но с допстолбцом с использованием НОМНЕДЕЛИ
Код
=СУММПРОИЗВ(--(($B$2:$B$6=$F3)*(ГОД(Дата)=ГОД($G$2))>0))

И, кстати, при использовании СУММПРОИЗВ массивный ввод необязателен
К сообщению приложен файл: 9980680.xlsx (11.2 Kb)


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица

Сообщение отредактировал elovkov - Четверг, 01.02.2024, 16:53
 
Ответить
СообщениеЗдравствуйте, Вашей же формулой, но с допстолбцом с использованием НОМНЕДЕЛИ
Код
=СУММПРОИЗВ(--(($B$2:$B$6=$F3)*(ГОД(Дата)=ГОД($G$2))>0))

И, кстати, при использовании СУММПРОИЗВ массивный ввод необязателен

Автор - elovkov
Дата добавления - 01.02.2024 в 16:21
gling Дата: Четверг, 01.02.2024, 17:57 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2506
Репутация: 668 ±
Замечаний: 0% ±

2010
Здравствуйте.
Зачем >0 и --? Умножение дает число. Если есть такие функции, можно так.
Код
=СУММПРОИЗВ((МЕСЯЦ(Дата)=$E9)*(ГОД(Дата)=ГОД(F$8)))
Код
=СУММПРОИЗВ((НОМНЕДЕЛИ.ISO(Дата)=$E3)*(ГОД(Дата)=ГОД(F$8)))
К сообщению приложен файл: 6014390.xlsx (10.2 Kb)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
Зачем >0 и --? Умножение дает число. Если есть такие функции, можно так.
Код
=СУММПРОИЗВ((МЕСЯЦ(Дата)=$E9)*(ГОД(Дата)=ГОД(F$8)))
Код
=СУММПРОИЗВ((НОМНЕДЕЛИ.ISO(Дата)=$E3)*(ГОД(Дата)=ГОД(F$8)))

Автор - gling
Дата добавления - 01.02.2024 в 17:57
maksvl007 Дата: Понедельник, 05.02.2024, 07:42 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

elovkov, gling Спасибо. Тема закрыта
 
Ответить
Сообщениеelovkov, gling Спасибо. Тема закрыта

Автор - maksvl007
Дата добавления - 05.02.2024 в 07:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как посчитать сумму недель в столбце с датами (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!