Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение строк из нескольких ячеек. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Сравнение строк из нескольких ячеек.
ni4esse Дата: Пятница, 02.02.2024, 15:07 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Уважаемые форумчане, может кто подскажет способ сравнения строк не из одной ячейки, а из нескольких. Мне нужно сравнить строку из нескольких ячеек (т.е. массив) и всем совпадением присвоить имя. Формула =ЕСЛИ($B$2:$F$2=B2:F2;"01";"") сравнивает каждую ячейку и выдает в конечном итоге 01 столько раз, сколько ячеек я сравниваю. а мне нужно 01 получить 1 раз. Пример приложил.
К сообщению приложен файл: 7131337.xlsx (8.9 Kb)
 
Ответить
СообщениеУважаемые форумчане, может кто подскажет способ сравнения строк не из одной ячейки, а из нескольких. Мне нужно сравнить строку из нескольких ячеек (т.е. массив) и всем совпадением присвоить имя. Формула =ЕСЛИ($B$2:$F$2=B2:F2;"01";"") сравнивает каждую ячейку и выдает в конечном итоге 01 столько раз, сколько ячеек я сравниваю. а мне нужно 01 получить 1 раз. Пример приложил.

Автор - ni4esse
Дата добавления - 02.02.2024 в 15:07
gling Дата: Пятница, 02.02.2024, 15:42 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2531
Репутация: 680 ±
Замечаний: 0% ±

2010
А так не подойдет? Посчиталось 4 ячейки с 01, но выдало только 1 раз.
Код
=ЕСЛИ(СЧЁТЕСЛИ(A2:F12;$F$2);"01";"")
А показали бы, где и какой результат хотите получить, было бы понятнее.
Еще вариант
Код
=ЕСЛИОШИБКА(ВПР(СЦЕПИТЬ(--ЕТЕКСТ(A2);--ЕТЕКСТ(B2);--ЕТЕКСТ(C2);--ЕТЕКСТ(D2);--ЕТЕКСТ(E2));{"10101";"01":"01110";"02":"01011";"03"};2;);"Нет типа")


ЯД-41001506838083

Сообщение отредактировал gling - Пятница, 02.02.2024, 17:39
 
Ответить
СообщениеА так не подойдет? Посчиталось 4 ячейки с 01, но выдало только 1 раз.
Код
=ЕСЛИ(СЧЁТЕСЛИ(A2:F12;$F$2);"01";"")
А показали бы, где и какой результат хотите получить, было бы понятнее.
Еще вариант
Код
=ЕСЛИОШИБКА(ВПР(СЦЕПИТЬ(--ЕТЕКСТ(A2);--ЕТЕКСТ(B2);--ЕТЕКСТ(C2);--ЕТЕКСТ(D2);--ЕТЕКСТ(E2));{"10101";"01":"01110";"02":"01011";"03"};2;);"Нет типа")

Автор - gling
Дата добавления - 02.02.2024 в 15:42
elovkov Дата: Пятница, 02.02.2024, 15:42 | Сообщение № 3
Группа: Друзья
Ранг: Обитатель
Сообщений: 394
Репутация: 53 ±
Замечаний: 0% ±

Excel 2013
Не знаю как типы по колонкам разнести, но строки можно сравнивать таким вот монстром
Код
=ЕСЛИ(A3&1&B3&1&C3&1&D3&1&E3=A$22&1&B$22&1&C$22&1&D$22&1&E$22;"01";
ЕСЛИ(A3&1&B3&1&C3&1&D3&1&E3=A$23&1&B$23&1&C$23&1&D$23&1&E$23;"02";
ЕСЛИ(A3&1&B3&1&C3&1&D3&1&E3=A$24&1&B$24&1&C$24&1&D$24&1&E$24;"03";"")))

Но для этого шаблон нужен, у меня он в строках 22-24
Вопрос не решил, но может направление подскажу
К сообщению приложен файл: 3381651.xlsx (10.4 Kb)


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица

Сообщение отредактировал elovkov - Пятница, 02.02.2024, 15:43
 
Ответить
СообщениеНе знаю как типы по колонкам разнести, но строки можно сравнивать таким вот монстром
Код
=ЕСЛИ(A3&1&B3&1&C3&1&D3&1&E3=A$22&1&B$22&1&C$22&1&D$22&1&E$22;"01";
ЕСЛИ(A3&1&B3&1&C3&1&D3&1&E3=A$23&1&B$23&1&C$23&1&D$23&1&E$23;"02";
ЕСЛИ(A3&1&B3&1&C3&1&D3&1&E3=A$24&1&B$24&1&C$24&1&D$24&1&E$24;"03";"")))

Но для этого шаблон нужен, у меня он в строках 22-24
Вопрос не решил, но может направление подскажу

Автор - elovkov
Дата добавления - 02.02.2024 в 15:42
ni4esse Дата: Пятница, 02.02.2024, 17:19 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

А показали бы, где и какой результат хотите получить, было бы понятнее.

так вроде пример желаемого результата выложил.
 
Ответить
Сообщение
А показали бы, где и какой результат хотите получить, было бы понятнее.

так вроде пример желаемого результата выложил.

Автор - ni4esse
Дата добавления - 02.02.2024 в 17:19
ni4esse Дата: Пятница, 02.02.2024, 17:22 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Вопрос не решил, но может направление подскажу
Спасибо. Пока решил примерно тем же способом только через Объединить и Если.
 
Ответить
Сообщение
Вопрос не решил, но может направление подскажу
Спасибо. Пока решил примерно тем же способом только через Объединить и Если.

Автор - ni4esse
Дата добавления - 02.02.2024 в 17:22
gling Дата: Пятница, 02.02.2024, 18:10 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2531
Репутация: 680 ±
Замечаний: 0% ±

2010
Может кому пригодятся формулы в файле.
К сообщению приложен файл: 2088273.xlsx (11.8 Kb)


ЯД-41001506838083
 
Ответить
СообщениеМожет кому пригодятся формулы в файле.

Автор - gling
Дата добавления - 02.02.2024 в 18:10
elovkov Дата: Суббота, 03.02.2024, 10:27 | Сообщение № 7
Группа: Друзья
Ранг: Обитатель
Сообщений: 394
Репутация: 53 ±
Замечаний: 0% ±

Excel 2013
только через Объединить

ну у меня ОБЪЕДИНИТЬ нету, 13й офис, эта штука с 16го только, полезная конечно функция


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
только через Объединить

ну у меня ОБЪЕДИНИТЬ нету, 13й офис, эта штука с 16го только, полезная конечно функция

Автор - elovkov
Дата добавления - 03.02.2024 в 10:27
AlexM Дата: Суббота, 03.02.2024, 13:36 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4517
Репутация: 1129 ±
Замечаний: 0% ±

Excel 2003
Для конкретного примера можно так.
Т.е оценивать только столбец D и E
К сообщению приложен файл: 7131337_1.xlsx (8.9 Kb) · 7131337_2.xlsx (8.8 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Суббота, 03.02.2024, 13:46
 
Ответить
СообщениеДля конкретного примера можно так.
Т.е оценивать только столбец D и E

Автор - AlexM
Дата добавления - 03.02.2024 в 13:36
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!