Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР, относительный путь - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
ВПР, относительный путь
Guard Дата: Понедельник, 05.02.2024, 17:19 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте. Подскажите пожалуйста как в Excel указать относительный путь к другой книге в другой папке?
Структура:
Folder1
--file1.xlsx
--Folder2
----file2.xlsx

Раньше пользовался Libreoffice, там работало
Код
=ВПР(A2;'./Folder2/file2.xlsx'#$Лист_1.B:E;4;0)

Как только не пробовал и что только не гуглил для excel, мне почему то кажется что он не умеет в "относительный путь"...

Если положить файлы в одну папку, то будет работать
Код
=ВПР(A2;'[file2.xlsx]Лист_1'!B:E;4;0)

Если указать полный путь, то будет работать
Код
=ВПР(A2;'W:\folder\folder\folder\folder2\[file2.xlsx]Лист_1'!$B:$E;4;0)

Но т.к. папки регулярно меняются, на каждый день своя папка, неизменным остаются только названия файлов, хочется что бы из блокнота ctrl+c - ctrl+v - протянул и получил результат.
 
Ответить
СообщениеЗдравствуйте. Подскажите пожалуйста как в Excel указать относительный путь к другой книге в другой папке?
Структура:
Folder1
--file1.xlsx
--Folder2
----file2.xlsx

Раньше пользовался Libreoffice, там работало
Код
=ВПР(A2;'./Folder2/file2.xlsx'#$Лист_1.B:E;4;0)

Как только не пробовал и что только не гуглил для excel, мне почему то кажется что он не умеет в "относительный путь"...

Если положить файлы в одну папку, то будет работать
Код
=ВПР(A2;'[file2.xlsx]Лист_1'!B:E;4;0)

Если указать полный путь, то будет работать
Код
=ВПР(A2;'W:\folder\folder\folder\folder2\[file2.xlsx]Лист_1'!$B:$E;4;0)

Но т.к. папки регулярно меняются, на каждый день своя папка, неизменным остаются только названия файлов, хочется что бы из блокнота ctrl+c - ctrl+v - протянул и получил результат.

Автор - Guard
Дата добавления - 05.02.2024 в 17:19
Pelena Дата: Понедельник, 05.02.2024, 19:57 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 19235
Репутация: 4433 ±
Замечаний: ±

Excel 365 & Mac Excel
Здравствуйте.
Функция
Код
=ЯЧЕЙКА("filename";A1)

вернет полный путь к файлу. С помощью ПСТР() можно вытянуть постоянную часть и к ней прицепить имя файла


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Функция
Код
=ЯЧЕЙКА("filename";A1)

вернет полный путь к файлу. С помощью ПСТР() можно вытянуть постоянную часть и к ней прицепить имя файла

Автор - Pelena
Дата добавления - 05.02.2024 в 19:57
Guard Дата: Вторник, 06.02.2024, 12:45 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте.
Функция

=ЯЧЕЙКА("filename";A1)

вернет полный путь к файлу. С помощью ПСТР() можно вытянуть постоянную часть и к ней прицепить имя файла


Может быть есть более простой способ? Чего то я не могу сообразить как это должно работать=))
Ну или может подробнее можете подсказать?
 
Ответить
Сообщение
Здравствуйте.
Функция

=ЯЧЕЙКА("filename";A1)

вернет полный путь к файлу. С помощью ПСТР() можно вытянуть постоянную часть и к ней прицепить имя файла


Может быть есть более простой способ? Чего то я не могу сообразить как это должно работать=))
Ну или может подробнее можете подсказать?

Автор - Guard
Дата добавления - 06.02.2024 в 12:45
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!