Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Дописать формулу под дополнительные условия - Страница 2 - Мир MS Excel

Старая форма входа
  • Страница 2 из 2
  • «
  • 1
  • 2
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Дописать формулу под дополнительные условия (Формулы/Formulas)
Дописать формулу под дополнительные условия
homeavt Дата: Среда, 28.02.2024, 10:54 | Сообщение № 21
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 20% ±

2016
_Boroda_, когда вводим слово нет, считает только одну формулу из таблицы на листе2!, так как формула находит последнее значение «нет», но не переходит на следующую строку таблицы на листе 2! В 14 посте есть пояснение картинками
К сообщению приложен файл: umnaja_tablica_2.xlsx (30.0 Kb)
 
Ответить
Сообщение_Boroda_, когда вводим слово нет, считает только одну формулу из таблицы на листе2!, так как формула находит последнее значение «нет», но не переходит на следующую строку таблицы на листе 2! В 14 посте есть пояснение картинками

Автор - homeavt
Дата добавления - 28.02.2024 в 10:54
Nic70y Дата: Среда, 28.02.2024, 11:03 | Сообщение № 22
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
homeavt, "мутный" формат времени у Вас,
но уже макрос заточен под него,
я заменил формулу в C2:AY2, если не нравиться - верните свою.
на втором листе
Код
=ЕСЛИОШИБКА(ЕСЛИ(--ПСТР(-МАКС(ЕСЛИ(B2+G$23>ЕСЛИ(Лист1!C$3:AY$3="Нет";Лист1!C$4:AY$4);Лист1!C$4:AY$4));2;15)>B2;МАКС(ЕСЛИ(B2+G$23>ЕСЛИ(Лист1!C$3:AY$3="Нет";Лист1!C$4:AY$4);Лист1!C$4:AY$4));B2+G$23);B2+G$23)
вдруг правильно
К сообщению приложен файл: 14.xlsx (27.5 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеhomeavt, "мутный" формат времени у Вас,
но уже макрос заточен под него,
я заменил формулу в C2:AY2, если не нравиться - верните свою.
на втором листе
Код
=ЕСЛИОШИБКА(ЕСЛИ(--ПСТР(-МАКС(ЕСЛИ(B2+G$23>ЕСЛИ(Лист1!C$3:AY$3="Нет";Лист1!C$4:AY$4);Лист1!C$4:AY$4));2;15)>B2;МАКС(ЕСЛИ(B2+G$23>ЕСЛИ(Лист1!C$3:AY$3="Нет";Лист1!C$4:AY$4);Лист1!C$4:AY$4));B2+G$23);B2+G$23)
вдруг правильно

Автор - Nic70y
Дата добавления - 28.02.2024 в 11:03
homeavt Дата: Среда, 28.02.2024, 12:44 | Сообщение № 23
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 20% ±

2016
Nic70y, hands ты красавчик, просто лучший
 
Ответить
СообщениеNic70y, hands ты красавчик, просто лучший

Автор - homeavt
Дата добавления - 28.02.2024 в 12:44
homeavt Дата: Среда, 28.02.2024, 12:45 | Сообщение № 24
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 20% ±

2016
Nic70y, огромное тебе спасибо hands hands hands hands hands тему можно закрывать задача решена
 
Ответить
СообщениеNic70y, огромное тебе спасибо hands hands hands hands hands тему можно закрывать задача решена

Автор - homeavt
Дата добавления - 28.02.2024 в 12:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Дописать формулу под дополнительные условия (Формулы/Formulas)
  • Страница 2 из 2
  • «
  • 1
  • 2
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!