Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как преобразовать 01.янв в 01.01 - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как преобразовать 01.янв в 01.01 (Формулы/Formulas)
Как преобразовать 01.янв в 01.01
Arion Дата: Среда, 07.02.2024, 15:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

office 2019
Есть файл в котором проставили пункты 1.1 1.2 и тд
Эксель их преобразил в даты 01.янв 01.фев и тд
в ячейках соответственно стоит 01.01.2023, 01.02.2023 и тд
если преобразовать через формат ячейки получится обычное число типа 42356
Как сделать так, чтобы преобразилось обратно в 1.1 1.2 и тд?
 
Ответить
СообщениеЕсть файл в котором проставили пункты 1.1 1.2 и тд
Эксель их преобразил в даты 01.янв 01.фев и тд
в ячейках соответственно стоит 01.01.2023, 01.02.2023 и тд
если преобразовать через формат ячейки получится обычное число типа 42356
Как сделать так, чтобы преобразилось обратно в 1.1 1.2 и тд?

Автор - Arion
Дата добавления - 07.02.2024 в 15:46
AlexM Дата: Среда, 07.02.2024, 15:51 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4380
Репутация: 1081 ±
Замечаний: 0% ±

Excel 2003
нужен файл пример



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениенужен файл пример

Автор - AlexM
Дата добавления - 07.02.2024 в 15:51
elovkov Дата: Среда, 07.02.2024, 16:14 | Сообщение № 3
Группа: Друзья
Ранг: Обитатель
Сообщений: 364
Репутация: 50 ±
Замечаний: 0% ±

Excel 2013
В принципе известная проблема, когда нумеруешь подстроки)
Тоже вечно перекидывает на даты, прямо не перевести обратно, стирать, задавать формат "текстовый" и забивать сначала
Можно поизвращаться допстолбцом и формулой типа:
Код
=ТЕКСТ(A1;"Д")&"."&ТЕКСТ(A1;"М")

Это с учетом, что в А1 стоит, допустим 1.1, который автоматом переключился на 01.янв
Но Эксель может и по-другому начать переводить, например 1.13 он переведет как янв.13, и тогда формулу менять надо
В общем проще перебить
Но если тут дадут какое-то решение, будет интересно


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеВ принципе известная проблема, когда нумеруешь подстроки)
Тоже вечно перекидывает на даты, прямо не перевести обратно, стирать, задавать формат "текстовый" и забивать сначала
Можно поизвращаться допстолбцом и формулой типа:
Код
=ТЕКСТ(A1;"Д")&"."&ТЕКСТ(A1;"М")

Это с учетом, что в А1 стоит, допустим 1.1, который автоматом переключился на 01.янв
Но Эксель может и по-другому начать переводить, например 1.13 он переведет как янв.13, и тогда формулу менять надо
В общем проще перебить
Но если тут дадут какое-то решение, будет интересно

Автор - elovkov
Дата добавления - 07.02.2024 в 16:14
AlexM Дата: Среда, 07.02.2024, 16:17 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4380
Репутация: 1081 ±
Замечаний: 0% ±

Excel 2003
elovkov, 1.24 или 33.1 как?
аналог вашей формулы
Код
=ТЕКСТ(B1;"Д.М")



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 07.02.2024, 16:18
 
Ответить
Сообщениеelovkov, 1.24 или 33.1 как?
аналог вашей формулы
Код
=ТЕКСТ(B1;"Д.М")

Автор - AlexM
Дата добавления - 07.02.2024 в 16:17
elovkov Дата: Среда, 07.02.2024, 16:24 | Сообщение № 5
Группа: Друзья
Ранг: Обитатель
Сообщений: 364
Репутация: 50 ±
Замечаний: 0% ±

Excel 2013
AlexM, ну вот потому и проще переписать, какие-то числа переведутся по-одноу, какие-то по-другому, а какие-то останутся номерами
аналог

Ну да, перемудрил))) Это я люблю)

А это я и писал, что уже по-другому переведется и формулу менять надо будет на "М.Г"


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица

Сообщение отредактировал elovkov - Среда, 07.02.2024, 16:26
 
Ответить
СообщениеAlexM, ну вот потому и проще переписать, какие-то числа переведутся по-одноу, какие-то по-другому, а какие-то останутся номерами
аналог

Ну да, перемудрил))) Это я люблю)

А это я и писал, что уже по-другому переведется и формулу менять надо будет на "М.Г"

Автор - elovkov
Дата добавления - 07.02.2024 в 16:24
Nic70y Дата: Среда, 07.02.2024, 16:32 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 8650
Репутация: 2207 ±
Замечаний: 0% ±

Excel 2010
формулу менять надо
Код
=ТЕКСТ(A1;ЕСЛИ(ГОД(A1)=ГОД(СЕГОДНЯ());"Д.М";"М.Г"))
это если в этом году накосячили


ЮMoney 41001841029809
 
Ответить
Сообщение
формулу менять надо
Код
=ТЕКСТ(A1;ЕСЛИ(ГОД(A1)=ГОД(СЕГОДНЯ());"Д.М";"М.Г"))
это если в этом году накосячили

Автор - Nic70y
Дата добавления - 07.02.2024 в 16:32
elovkov Дата: Среда, 07.02.2024, 16:41 | Сообщение № 7
Группа: Друзья
Ранг: Обитатель
Сообщений: 364
Репутация: 50 ±
Замечаний: 0% ±

Excel 2013
Nic70y, не выходит, 1.24 меняет на янв.24, а формула его на 1.1 соответственно перекидывает)
Вот так тогда
Код
=ТЕКСТ(A1;ЕСЛИ(ЯЧЕЙКА("формат";A1)="D2";"Д.М";"М.Г"))


И еще "допилил", чтобы на 33.1 тоже работало, оно же текстом остается
Код
=ЕСЛИ(ЕЧИСЛО(A2);ТЕКСТ(A2;ЕСЛИ(ЯЧЕЙКА("формат";A2)="D2";"Д.М";"М.Г"));A2)

набросал для наглядности файлик)))
К сообщению приложен файл: peredaty.xlsx (10.2 Kb)


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица

Сообщение отредактировал elovkov - Среда, 07.02.2024, 16:55
 
Ответить
СообщениеNic70y, не выходит, 1.24 меняет на янв.24, а формула его на 1.1 соответственно перекидывает)
Вот так тогда
Код
=ТЕКСТ(A1;ЕСЛИ(ЯЧЕЙКА("формат";A1)="D2";"Д.М";"М.Г"))


И еще "допилил", чтобы на 33.1 тоже работало, оно же текстом остается
Код
=ЕСЛИ(ЕЧИСЛО(A2);ТЕКСТ(A2;ЕСЛИ(ЯЧЕЙКА("формат";A2)="D2";"Д.М";"М.Г"));A2)

набросал для наглядности файлик)))

Автор - elovkov
Дата добавления - 07.02.2024 в 16:41
Nic70y Дата: Среда, 07.02.2024, 17:00 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 8650
Репутация: 2207 ±
Замечаний: 0% ±

Excel 2010
не выходит
ну да и не выйдет, если формат ячейки ДД.ММ.ГГГ


ЮMoney 41001841029809
 
Ответить
Сообщение
не выходит
ну да и не выйдет, если формат ячейки ДД.ММ.ГГГ

Автор - Nic70y
Дата добавления - 07.02.2024 в 17:00
elovkov Дата: Среда, 07.02.2024, 17:04 | Сообщение № 9
Группа: Друзья
Ранг: Обитатель
Сообщений: 364
Репутация: 50 ±
Замечаний: 0% ±

Excel 2013
Nic70y, ну та речь как раз о том, что эксель сам переводит вводимое 1.24 в формат МММ.ГГ, а 1.1 в ДД.ММ ну и так далее и тому подобное


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеNic70y, ну та речь как раз о том, что эксель сам переводит вводимое 1.24 в формат МММ.ГГ, а 1.1 в ДД.ММ ну и так далее и тому подобное

Автор - elovkov
Дата добавления - 07.02.2024 в 17:04
Nic70y Дата: Среда, 07.02.2024, 17:16 | Сообщение № 10
Группа: Друзья
Ранг: Экселист
Сообщений: 8650
Репутация: 2207 ±
Замечаний: 0% ±

Excel 2010
elovkov, да, действительно
Эксель их преобразил в даты 01.янв 01.фев и тд
не прочитал, а был бы
файл пример


ЮMoney 41001841029809
 
Ответить
Сообщениеelovkov, да, действительно
Эксель их преобразил в даты 01.янв 01.фев и тд
не прочитал, а был бы
файл пример

Автор - Nic70y
Дата добавления - 07.02.2024 в 17:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как преобразовать 01.янв в 01.01 (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!