Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция Поиск - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция Поиск (Формулы/Formulas)
Функция Поиск
Chelovekov Дата: Понедельник, 12.02.2024, 11:30 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 303
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Здравствуйте, Уважаемые Форумчане. Прошу, Вас, помочь решить проблему, формула с функцией Поиск, не корректно, заботает с числами. Неправильно определяет номер строки. Если число, которое нужно найти, пишется до десятых. В данном примере это число 3,7.

Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ( ЕСЛИ(ЕОШИБКА(ПОИСК(C3;$A$2:$A$6));"";СТРОКА($A$2:$A$6)); 1);"")


Пример прилагаю.
Заранее благодарен.
К сообщению приложен файл: 3758161.xlsx (9.6 Kb)


Сообщение отредактировал Chelovekov - Понедельник, 12.02.2024, 11:42
 
Ответить
СообщениеЗдравствуйте, Уважаемые Форумчане. Прошу, Вас, помочь решить проблему, формула с функцией Поиск, не корректно, заботает с числами. Неправильно определяет номер строки. Если число, которое нужно найти, пишется до десятых. В данном примере это число 3,7.

Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ( ЕСЛИ(ЕОШИБКА(ПОИСК(C3;$A$2:$A$6));"";СТРОКА($A$2:$A$6)); 1);"")


Пример прилагаю.
Заранее благодарен.

Автор - Chelovekov
Дата добавления - 12.02.2024 в 11:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция Поиск (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!