Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/СУММПРОИЗВ не считает по условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
СУММПРОИЗВ не считает по условию
olya2084 Дата: Понедельник, 12.02.2024, 11:34 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: -2 ±
Замечаний: 20% ±

Здравствуйте! Помогите, пожалуйста, отредактировать формулу в файле "Акты понедельно" для столбцов "Принято решений": вроде бы все условия учтены, но корректно не считает, а именно: если в файле "Задание на просмотр видеонаблюдения" удалить решение из столбца "O", то в файле "Акты понедельно" количество принятых решений не обнуляется, например, по неделе №2.
К сообщению приложен файл: zadanie_na_prosmotr_videonablj.xlsm (199.5 Kb) · akty_ponedelno.xlsx (35.1 Kb)
 
Ответить
СообщениеЗдравствуйте! Помогите, пожалуйста, отредактировать формулу в файле "Акты понедельно" для столбцов "Принято решений": вроде бы все условия учтены, но корректно не считает, а именно: если в файле "Задание на просмотр видеонаблюдения" удалить решение из столбца "O", то в файле "Акты понедельно" количество принятых решений не обнуляется, например, по неделе №2.

Автор - olya2084
Дата добавления - 12.02.2024 в 11:34
Nic70y Дата: Понедельник, 12.02.2024, 11:50 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8827
Репутация: 2300 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММПРОИЗВ(([zadanie_na_prosmotr_videonablj.xlsm]Задание!$N$2:$N$2000=B7)*([zadanie_na_prosmotr_videonablj.xlsm]Задание!$B$2:$B$2000=$E$2)*([zadanie_na_prosmotr_videonablj.xlsm]Задание!$O$2:$O$2000>""))
так х=у>"" нельзя


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(([zadanie_na_prosmotr_videonablj.xlsm]Задание!$N$2:$N$2000=B7)*([zadanie_na_prosmotr_videonablj.xlsm]Задание!$B$2:$B$2000=$E$2)*([zadanie_na_prosmotr_videonablj.xlsm]Задание!$O$2:$O$2000>""))
так х=у>"" нельзя

Автор - Nic70y
Дата добавления - 12.02.2024 в 11:50
bigor Дата: Понедельник, 12.02.2024, 11:52 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1136
Репутация: 215 ±
Замечаний: 0% ±

нет
У вас последнее условие коряво прописано, оно всегда истину дает. Лень анализировать, что вы хотели там прописать, опишите сами
 
Ответить
СообщениеУ вас последнее условие коряво прописано, оно всегда истину дает. Лень анализировать, что вы хотели там прописать, опишите сами

Автор - bigor
Дата добавления - 12.02.2024 в 11:52
olya2084 Дата: Четверг, 15.02.2024, 23:41 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: -2 ±
Замечаний: 20% ±

Добрый вечер! Формулу исправила. Только теперь проблема другая: почему при изменении данных в исходном файле- формула не пересчитывает количество ? Я уже перенесла таблицу "Акты понедельно" в файл "Задание на просмотр видеонаблюдения", чтобы исключить ошибку, если функция "СУММПРОИЗВ" не пересчитывает при закрытых файлах. Но опять такая же ерунда даже если и исходные данные, и результирующая таблица находятся в одной книге... Кто-то знает, как это можно решить?
К сообщению приложен файл: 2870769.xlsm (231.8 Kb)


Сообщение отредактировал olya2084 - Четверг, 15.02.2024, 23:44
 
Ответить
СообщениеДобрый вечер! Формулу исправила. Только теперь проблема другая: почему при изменении данных в исходном файле- формула не пересчитывает количество ? Я уже перенесла таблицу "Акты понедельно" в файл "Задание на просмотр видеонаблюдения", чтобы исключить ошибку, если функция "СУММПРОИЗВ" не пересчитывает при закрытых файлах. Но опять такая же ерунда даже если и исходные данные, и результирующая таблица находятся в одной книге... Кто-то знает, как это можно решить?

Автор - olya2084
Дата добавления - 15.02.2024 в 23:41
gling Дата: Пятница, 16.02.2024, 00:32 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2527
Репутация: 679 ±
Замечаний: 0% ±

2010
У вас в файле-примере формулы не ссылаются на соседний лист Задание, они ссылаются на первоначальный исходник \\sb-file\share\Нарушения трудового распорядка в компании\2024\ЯНВАРЬ\Отчеты\[Задание на просмотр видеонаблюдения.xlsm], так что изменения на соседнем листе не к чему не приведут.


ЯД-41001506838083

Сообщение отредактировал gling - Пятница, 16.02.2024, 00:33
 
Ответить
СообщениеУ вас в файле-примере формулы не ссылаются на соседний лист Задание, они ссылаются на первоначальный исходник \\sb-file\share\Нарушения трудового распорядка в компании\2024\ЯНВАРЬ\Отчеты\[Задание на просмотр видеонаблюдения.xlsm], так что изменения на соседнем листе не к чему не приведут.

Автор - gling
Дата добавления - 16.02.2024 в 00:32
olya2084 Дата: Пятница, 16.02.2024, 00:54 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: -2 ±
Замечаний: 20% ±

gling, благодарю за подсказку!
 
Ответить
Сообщениеgling, благодарю за подсказку!

Автор - olya2084
Дата добавления - 16.02.2024 в 00:54
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!