Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет стоимости услуг - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет стоимости услуг (Формулы/Formulas)
Расчет стоимости услуг
nazarovss Дата: Пятница, 16.02.2024, 17:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день.
Имеются данные в виде списка на листе1
СтолбецА СтолбецВ

Скидка 10% Услуга1
Скидка 20% Услуга1
Наличный расчет Услуга3
Скидка 10% Услуга2
Наличный расчет Услуга2
Скидка 5% Услуга3

Отдельно на листе2 есть перечень со стоимостью (в рублях) и коэффициентами

СтолбецА СтолбецВ
Услуга1 1500
Услуга2 2000
Услуга3 1000
Наличный расчет 1
Скидка 5% 0,95
Скидка 10% 0,9
Скидка 20% 0,8

Необходимо посчитать стоимость услуг на листе1 с учетом данных стоимости и скидок листа2.
Формат вывода данных не важен, главное результат.

Предпочтительный инструмент - формулы, макросами не умею пользоваться.
Если это невозможно сделать формулами, то тогда макросы. Заранее благодарю!
К сообщению приложен файл: raschet_stoimosti_uslug.xls (27.0 Kb)
 
Ответить
СообщениеДобрый день.
Имеются данные в виде списка на листе1
СтолбецА СтолбецВ

Скидка 10% Услуга1
Скидка 20% Услуга1
Наличный расчет Услуга3
Скидка 10% Услуга2
Наличный расчет Услуга2
Скидка 5% Услуга3

Отдельно на листе2 есть перечень со стоимостью (в рублях) и коэффициентами

СтолбецА СтолбецВ
Услуга1 1500
Услуга2 2000
Услуга3 1000
Наличный расчет 1
Скидка 5% 0,95
Скидка 10% 0,9
Скидка 20% 0,8

Необходимо посчитать стоимость услуг на листе1 с учетом данных стоимости и скидок листа2.
Формат вывода данных не важен, главное результат.

Предпочтительный инструмент - формулы, макросами не умею пользоваться.
Если это невозможно сделать формулами, то тогда макросы. Заранее благодарю!

Автор - nazarovss
Дата добавления - 16.02.2024 в 17:06
Светлый Дата: Пятница, 16.02.2024, 19:18 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1829
Репутация: 510 ±
Замечаний: 0% ±

Excel 2013, 2016
Как понял:
Код
=ИНДЕКС(Лист2!$B:$B;ПОИСКПОЗ(A1;Лист2!$A:$A;))*ИНДЕКС(Лист2!$B:$B;ПОИСКПОЗ(B1;Лист2!$A:$A;))
*Или так:
Код
=ВПР(A1;Лист2!$A$4:$B$7;2;)*ВПР(B1;Лист2!$A$1:$B$3;2;)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 16.02.2024, 19:23
 
Ответить
СообщениеКак понял:
Код
=ИНДЕКС(Лист2!$B:$B;ПОИСКПОЗ(A1;Лист2!$A:$A;))*ИНДЕКС(Лист2!$B:$B;ПОИСКПОЗ(B1;Лист2!$A:$A;))
*Или так:
Код
=ВПР(A1;Лист2!$A$4:$B$7;2;)*ВПР(B1;Лист2!$A$1:$B$3;2;)

Автор - Светлый
Дата добавления - 16.02.2024 в 19:18
nazarovss Дата: Пятница, 16.02.2024, 20:56 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Светлый, Благодарю! Оба варианта рабочие, спасибо!
 
Ответить
СообщениеСветлый, Благодарю! Оба варианта рабочие, спасибо!

Автор - nazarovss
Дата добавления - 16.02.2024 в 20:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет стоимости услуг (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!