Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выставление сегодняшней даты и времени в ячейке - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Выставление сегодняшней даты и времени в ячейке
franky2118 Дата: Понедельник, 19.02.2024, 09:57 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Добрый день! Подскажите, пожалуйста, как автоматически заполнять ячейку сегодняшней датой, пробелом, настоящим временем при заполнении другой ячейки? Дата и время в таком формате (пример): 15.02.2024 15:26.
Знаю такую формулу: =ЕСЛИ(H12<>"";СЕГОДНЯ();"") — но здесь время всегда выставляется 0:00
 
Ответить
СообщениеДобрый день! Подскажите, пожалуйста, как автоматически заполнять ячейку сегодняшней датой, пробелом, настоящим временем при заполнении другой ячейки? Дата и время в таком формате (пример): 15.02.2024 15:26.
Знаю такую формулу: =ЕСЛИ(H12<>"";СЕГОДНЯ();"") — но здесь время всегда выставляется 0:00

Автор - franky2118
Дата добавления - 19.02.2024 в 09:57
Nic70y Дата: Понедельник, 19.02.2024, 10:01 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8856
Репутация: 2308 ±
Замечаний: 0% ±

Excel 2010
Код
=ТДАТА()


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ТДАТА()

Автор - Nic70y
Дата добавления - 19.02.2024 в 10:01
DrMini Дата: Понедельник, 19.02.2024, 10:23 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1754
Репутация: 243 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте franky2118,
Код
=ЕСЛИ(H12=" ";ТДАТА();"")

формат ячейки (например такой):
Код
ДД.ММ.ГГГГ ч:мм
 
Ответить
СообщениеЗдравствуйте franky2118,
Код
=ЕСЛИ(H12=" ";ТДАТА();"")

формат ячейки (например такой):
Код
ДД.ММ.ГГГГ ч:мм

Автор - DrMini
Дата добавления - 19.02.2024 в 10:23
franky2118 Дата: Понедельник, 19.02.2024, 10:29 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

DrMini, Nic70y, при такой формуле время меняется на настоящее при обновлении Ексель, нужна статичное время
 
Ответить
СообщениеDrMini, Nic70y, при такой формуле время меняется на настоящее при обновлении Ексель, нужна статичное время

Автор - franky2118
Дата добавления - 19.02.2024 в 10:29
DrMini Дата: Понедельник, 19.02.2024, 10:31 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1754
Репутация: 243 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
нужна статичное время

Тогда только VBA.
 
Ответить
Сообщение
нужна статичное время

Тогда только VBA.

Автор - DrMini
Дата добавления - 19.02.2024 в 10:31
DrMini Дата: Понедельник, 19.02.2024, 13:47 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1754
Репутация: 243 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
В макросах ничего не понимаю. Подсмотрел в интернете.
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    For Each cell In Target
       If Not Intersect(cell, Range("H1:A20")) Is Nothing Then
            With Range("I" & cell.Row)
               .Value = Now
               .EntireColumn.AutoFit
            End With
       End If
    Next cell
End Sub
[/vba]
Вводите в диапазон H1:H20 любое изменение ячейки и рядом дата.
К сообщению приложен файл: tdata.xlsm (14.7 Kb)
 
Ответить
СообщениеВ макросах ничего не понимаю. Подсмотрел в интернете.
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    For Each cell In Target
       If Not Intersect(cell, Range("H1:A20")) Is Nothing Then
            With Range("I" & cell.Row)
               .Value = Now
               .EntireColumn.AutoFit
            End With
       End If
    Next cell
End Sub
[/vba]
Вводите в диапазон H1:H20 любое изменение ячейки и рядом дата.

Автор - DrMini
Дата добавления - 19.02.2024 в 13:47
_Boroda_ Дата: Понедельник, 19.02.2024, 16:36 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16675
Репутация: 6481 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Только AutoFit для столбца I (если он вообще нужен, не проще ли заранее или потом ручками выставить нужную ширину столбца) лучше вынести на после цикла For Each. Чтобы он один раз делался. Иначе, при большом количестве изменяемых ячеек, может подвиснуть


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТолько AutoFit для столбца I (если он вообще нужен, не проще ли заранее или потом ручками выставить нужную ширину столбца) лучше вынести на после цикла For Each. Чтобы он один раз делался. Иначе, при большом количестве изменяемых ячеек, может подвиснуть

Автор - _Boroda_
Дата добавления - 19.02.2024 в 16:36
DrMini Дата: Понедельник, 19.02.2024, 18:34 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1754
Репутация: 243 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
может подвиснуть

Я же сразу отметил, что в VBA не понимаю даже "со словарём".
[p.s.]_Александр_, очень рад Вас видеть здесь. Очень давно Вас не было.[/p.s.]
 
Ответить
Сообщение
может подвиснуть

Я же сразу отметил, что в VBA не понимаю даже "со словарём".
[p.s.]_Александр_, очень рад Вас видеть здесь. Очень давно Вас не было.[/p.s.]

Автор - DrMini
Дата добавления - 19.02.2024 в 18:34
Nic70y Дата: Вторник, 20.02.2024, 08:01 | Сообщение № 9
Группа: Друзья
Ранг: Экселист
Сообщений: 8856
Репутация: 2308 ±
Замечаний: 0% ±

Excel 2010
=ЕСЛИ(H
исходя из этого, т.е. данные вносятся в столбец H, вариант:
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("h:h")) Is Nothing Then
        On Error Resume Next
        For Each u In Columns("h").SpecialCells(xlCellTypeConstants, 23)
            If u.Offset(, 1).Value = "" Then u.Offset(, 1).Value = Now
        Next
    End If
End Sub
[/vba]
апдэйт
или наоборот
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("h:h")) Is Nothing Then
        a = Cells(Rows.Count, "h").End(xlUp).Row
        For Each u In Range("i1:i" & a + 1).SpecialCells(xlCellTypeBlanks)
            If u.Offset(, -1).Value <> "" Then u.Value = Now
        Next
    End If
End Sub
[/vba]
К сообщению приложен файл: 418.xlsm (14.5 Kb) · 419.xlsm (14.4 Kb)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Вторник, 20.02.2024, 08:28
 
Ответить
Сообщение
=ЕСЛИ(H
исходя из этого, т.е. данные вносятся в столбец H, вариант:
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("h:h")) Is Nothing Then
        On Error Resume Next
        For Each u In Columns("h").SpecialCells(xlCellTypeConstants, 23)
            If u.Offset(, 1).Value = "" Then u.Offset(, 1).Value = Now
        Next
    End If
End Sub
[/vba]
апдэйт
или наоборот
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("h:h")) Is Nothing Then
        a = Cells(Rows.Count, "h").End(xlUp).Row
        For Each u In Range("i1:i" & a + 1).SpecialCells(xlCellTypeBlanks)
            If u.Offset(, -1).Value <> "" Then u.Value = Now
        Next
    End If
End Sub
[/vba]

Автор - Nic70y
Дата добавления - 20.02.2024 в 08:01
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!