Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Номера договоров из текста - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Номера договоров из текста (Формулы/Formulas)
Номера договоров из текста
ArmilDinat Дата: Вторник, 20.02.2024, 08:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 40% ±

2016
Здравствуйте, подскажите пожалуйста есть ли способ решения такой проблемы, нужно из текста вытащить номер договора, список большой, в тексте может быть 1 и более № договоров, начинаются они на № или после № идет пробел, также может встречаться словосочетание ЕЭТП или +ЕЭТП которое тоже нужно перенести. Возможны варианты формулой или VBA
Спасибо
К сообщению приложен файл: 4606474.png (141.8 Kb) · 9894374.png (112.3 Kb)
 
Ответить
СообщениеЗдравствуйте, подскажите пожалуйста есть ли способ решения такой проблемы, нужно из текста вытащить номер договора, список большой, в тексте может быть 1 и более № договоров, начинаются они на № или после № идет пробел, также может встречаться словосочетание ЕЭТП или +ЕЭТП которое тоже нужно перенести. Возможны варианты формулой или VBA
Спасибо

Автор - ArmilDinat
Дата добавления - 20.02.2024 в 08:23
Nic70y Дата: Вторник, 20.02.2024, 08:29 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
ArmilDinat, нужен файл-Excel


ЮMoney 41001841029809
 
Ответить
СообщениеArmilDinat, нужен файл-Excel

Автор - Nic70y
Дата добавления - 20.02.2024 в 08:29
ArmilDinat Дата: Вторник, 20.02.2024, 08:40 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 40% ±

2016
Прикладываю файл
К сообщению приложен файл: 5277276.xlsx (11.7 Kb)
 
Ответить
СообщениеПрикладываю файл

Автор - ArmilDinat
Дата добавления - 20.02.2024 в 08:40
Nic70y Дата: Вторник, 20.02.2024, 08:53 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
ArmilDinat, текста, кроме п/п не нашел
Код
=ЕСЛИОШИБКА(ПОДСТАВИТЬ(ПСТР($B2;ПОИСК("@";ПОДСТАВИТЬ($B2;"№";"@";СТОЛБЕЦ(A2)));ПОИСК("@";ПОДСТАВИТЬ($B2&"@";"№";"@";СТОЛБЕЦ(B2)))-ПОИСК("@";ПОДСТАВИТЬ($B2;"№";"@";СТОЛБЕЦ(A2))));"п/п";);"")
К сообщению приложен файл: 400.xlsx (14.4 Kb)


ЮMoney 41001841029809
 
Ответить
СообщениеArmilDinat, текста, кроме п/п не нашел
Код
=ЕСЛИОШИБКА(ПОДСТАВИТЬ(ПСТР($B2;ПОИСК("@";ПОДСТАВИТЬ($B2;"№";"@";СТОЛБЕЦ(A2)));ПОИСК("@";ПОДСТАВИТЬ($B2&"@";"№";"@";СТОЛБЕЦ(B2)))-ПОИСК("@";ПОДСТАВИТЬ($B2;"№";"@";СТОЛБЕЦ(A2))));"п/п";);"")

Автор - Nic70y
Дата добавления - 20.02.2024 в 08:53
ArmilDinat Дата: Вторник, 20.02.2024, 09:01 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 40% ±

2016
Спасибо, но именно проблема в том, что нужны именно номера договоров и ЕЭТП если встречается, без дат и в одной ячейке если их много чтобы было в итоге.
Типа
№7698
№8758707
№34
№6976089
 
Ответить
СообщениеСпасибо, но именно проблема в том, что нужны именно номера договоров и ЕЭТП если встречается, без дат и в одной ячейке если их много чтобы было в итоге.
Типа
№7698
№8758707
№34
№6976089

Автор - ArmilDinat
Дата добавления - 20.02.2024 в 09:01
Nic70y Дата: Вторник, 20.02.2024, 09:37 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
апдэцт 11:31
доработал, файл перезалил
[vba]
Код
Function u_7(u As Range)
    a = InStr(u, "№")
    aa = InStr(u, "ЕЭТП")
    If a > 0 Or aa > 0 Then
        ba = Replace(u, "№", "")
        b = Replace(ba, "ЕЭТП", "ЭТП")
        l = Len(u)
        c = l - Len(b)
        ia = Replace(u, "№ ", "№#")
        ib = Replace(ia, "+ ЕЭТП +", "№1111111")
        ic = Replace(ib, "ЕЭТП +", "№22222")
        ie = Replace(ic, "+ ЕЭТП", "№33333")
        i = Replace(ie, "ЕЭТП", "№444") & " "
        For d = 1 To c
            e = InStr(i, "№")
            f = Mid(i, e, l + 1)
            g = InStr(f, " ")
            h = Left(f, g - 1)
            If d = 1 Then
                v = ""
            Else
                v = Chr(10)
            End If
            u_7 = u_7 & v & h
            i = Mid(i, e + 1, l + 1)
        Next
        p = Replace(u_7, "#", "")
        q = Replace(p, "№1111111", "+ ЕЭТП +")
        r = Replace(q, "№22222", "ЕЭТП +")
        s = Replace(r, "№33333", "+ ЕЭТП")
        t = Replace(s, "№444", "ЕЭТП")
        u_7 = Trim(t)
    Else
        u_7 = ""
    End If
End Function
[/vba]
К сообщению приложен файл: 96.xlsm (23.6 Kb)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Вторник, 20.02.2024, 11:32
 
Ответить
Сообщениеапдэцт 11:31
доработал, файл перезалил
[vba]
Код
Function u_7(u As Range)
    a = InStr(u, "№")
    aa = InStr(u, "ЕЭТП")
    If a > 0 Or aa > 0 Then
        ba = Replace(u, "№", "")
        b = Replace(ba, "ЕЭТП", "ЭТП")
        l = Len(u)
        c = l - Len(b)
        ia = Replace(u, "№ ", "№#")
        ib = Replace(ia, "+ ЕЭТП +", "№1111111")
        ic = Replace(ib, "ЕЭТП +", "№22222")
        ie = Replace(ic, "+ ЕЭТП", "№33333")
        i = Replace(ie, "ЕЭТП", "№444") & " "
        For d = 1 To c
            e = InStr(i, "№")
            f = Mid(i, e, l + 1)
            g = InStr(f, " ")
            h = Left(f, g - 1)
            If d = 1 Then
                v = ""
            Else
                v = Chr(10)
            End If
            u_7 = u_7 & v & h
            i = Mid(i, e + 1, l + 1)
        Next
        p = Replace(u_7, "#", "")
        q = Replace(p, "№1111111", "+ ЕЭТП +")
        r = Replace(q, "№22222", "ЕЭТП +")
        s = Replace(r, "№33333", "+ ЕЭТП")
        t = Replace(s, "№444", "ЕЭТП")
        u_7 = Trim(t)
    Else
        u_7 = ""
    End If
End Function
[/vba]

Автор - Nic70y
Дата добавления - 20.02.2024 в 09:37
ArmilDinat Дата: Вторник, 20.02.2024, 12:52 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 40% ±

2016
Спасибо вам огромное, работает, вы очень облегчили работу
 
Ответить
СообщениеСпасибо вам огромное, работает, вы очень облегчили работу

Автор - ArmilDinat
Дата добавления - 20.02.2024 в 12:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Номера договоров из текста (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!