Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сложение в диапазоне по нескольким условиям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложение в диапазоне по нескольким условиям (Формулы/Formulas)
Сложение в диапазоне по нескольким условиям
supercelt Дата: Среда, 21.02.2024, 11:31 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Помогите пожалуйста с формулой. Файл приложил.
Надо в AA просуммировать диапазон строки только дробные числа. В AB надо просуммировать только целые числа, соотв. все где 12.
К сообщению приложен файл: test.xlsx (8.2 Kb)
 
Ответить
СообщениеДобрый день! Помогите пожалуйста с формулой. Файл приложил.
Надо в AA просуммировать диапазон строки только дробные числа. В AB надо просуммировать только целые числа, соотв. все где 12.

Автор - supercelt
Дата добавления - 21.02.2024 в 11:31
Nic70y Дата: Среда, 21.02.2024, 11:36 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
формулы массива
Код
=СУММ(ЕСЛИ(ЕСЛИОШИБКА(ЦЕЛОЕ(A1:Z1);)<>A1:Z1;A1:Z1))
Код
=СУММ(ЕСЛИ(ЕСЛИОШИБКА(ЦЕЛОЕ(A1:Z1);)=A1:Z1;A1:Z1))
К сообщению приложен файл: 15.xlsx (8.5 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеформулы массива
Код
=СУММ(ЕСЛИ(ЕСЛИОШИБКА(ЦЕЛОЕ(A1:Z1);)<>A1:Z1;A1:Z1))
Код
=СУММ(ЕСЛИ(ЕСЛИОШИБКА(ЦЕЛОЕ(A1:Z1);)=A1:Z1;A1:Z1))

Автор - Nic70y
Дата добавления - 21.02.2024 в 11:36
supercelt Дата: Среда, 21.02.2024, 11:42 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Большое спасибо!
 
Ответить
СообщениеБольшое спасибо!

Автор - supercelt
Дата добавления - 21.02.2024 в 11:42
bigor Дата: Среда, 21.02.2024, 11:47 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1100
Репутация: 210 ±
Замечаний: 0% ±

нет
supercelt, для 12 просто
Код
=SUMIF(A1:Z1;12)
, для дробных
Код
=SUM(IF(ISNUMBER(MOD(A1:Z1;1)/MOD(A1:Z1;1));A1:Z1);0)
масивная
 
Ответить
Сообщениеsupercelt, для 12 просто
Код
=SUMIF(A1:Z1;12)
, для дробных
Код
=SUM(IF(ISNUMBER(MOD(A1:Z1;1)/MOD(A1:Z1;1));A1:Z1);0)
масивная

Автор - bigor
Дата добавления - 21.02.2024 в 11:47
_Boroda_ Дата: Среда, 21.02.2024, 12:56 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16675
Репутация: 6481 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В АВ1
для 12 просто
Код
=СУММЕСЛИ(A1:Z1;12)

В АА1
Код
=СУММ(A1:Z1)-AB1


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВ АВ1
для 12 просто
Код
=СУММЕСЛИ(A1:Z1;12)

В АА1
Код
=СУММ(A1:Z1)-AB1

Автор - _Boroda_
Дата добавления - 21.02.2024 в 12:56
supercelt Дата: Среда, 21.02.2024, 13:10 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, можете пожалуйста пояснить синтаксис

Код
=СУММ(A1:Z1)-AB1


Как работает и что значит -AB1
 
Ответить
Сообщение_Boroda_, можете пожалуйста пояснить синтаксис

Код
=СУММ(A1:Z1)-AB1


Как работает и что значит -AB1

Автор - supercelt
Дата добавления - 21.02.2024 в 13:10
_Boroda_ Дата: Среда, 21.02.2024, 13:22 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16675
Репутация: 6481 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В ячейке АВ1 суммируем только 12. В ячейке АА1 суммируем вообще всё и вычитаем то, что посчитали в ячейке АВ1


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВ ячейке АВ1 суммируем только 12. В ячейке АА1 суммируем вообще всё и вычитаем то, что посчитали в ячейке АВ1

Автор - _Boroda_
Дата добавления - 21.02.2024 в 13:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложение в диапазоне по нескольким условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!