Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск количества заказов по дате и названию товара - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск количества заказов по дате и названию товара (Формулы/Formulas)
Поиск количества заказов по дате и названию товара
Магистриус Дата: Понедельник, 26.02.2024, 13:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2016
Здравствуйте. Нужна помощь с созданием формулы, для поиска количества заказанных товаров, по дате и названию товара. Пробовал различные формулы (ЕСЛИ, СЧЁТЕСЛИ, СЧЁТЕСЛИМН и т.д.), не выходит. Пример того что требуется, во вложении. С возможностью менять название товара и добавления его.
К сообщению приложен файл: primer_formul.xlsx (9.4 Kb)
 
Ответить
СообщениеЗдравствуйте. Нужна помощь с созданием формулы, для поиска количества заказанных товаров, по дате и названию товара. Пробовал различные формулы (ЕСЛИ, СЧЁТЕСЛИ, СЧЁТЕСЛИМН и т.д.), не выходит. Пример того что требуется, во вложении. С возможностью менять название товара и добавления его.

Автор - Магистриус
Дата добавления - 26.02.2024 в 13:49
bigor Дата: Понедельник, 26.02.2024, 14:04 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1100
Репутация: 210 ±
Замечаний: 0% ±

нет
Магистриус,
Код
=SUMPRODUCT((INT($A$2:$A$12)=$F2)*($B$2:$B$12=G$1)*($C$2:$C$12))
только приведите таблицу в порядок
 
Ответить
СообщениеМагистриус,
Код
=SUMPRODUCT((INT($A$2:$A$12)=$F2)*($B$2:$B$12=G$1)*($C$2:$C$12))
только приведите таблицу в порядок

Автор - bigor
Дата добавления - 26.02.2024 в 14:04
Магистриус Дата: Понедельник, 26.02.2024, 14:19 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2016
Нули выдает, мне нужно, что бы еще учитывалась время. Потому что переноситься из отчета, в свою таблицу информация. Это возможно?
 
Ответить
СообщениеНули выдает, мне нужно, что бы еще учитывалась время. Потому что переноситься из отчета, в свою таблицу информация. Это возможно?

Автор - Магистриус
Дата добавления - 26.02.2024 в 14:19
bigor Дата: Понедельник, 26.02.2024, 14:24 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1100
Репутация: 210 ±
Замечаний: 0% ±

нет
Цитата Магистриус, 26.02.2024 в 14:19, в сообщении № 3 ()
Нули выдает
там, где данные нормальные - считает , возможно в excel, нужно вводить как массивную формулу ctrl+shift+enter
А где время учитывать?
К сообщению приложен файл: 8620892.png (66.5 Kb)
 
Ответить
Сообщение
Цитата Магистриус, 26.02.2024 в 14:19, в сообщении № 3 ()
Нули выдает
там, где данные нормальные - считает , возможно в excel, нужно вводить как массивную формулу ctrl+shift+enter
А где время учитывать?

Автор - bigor
Дата добавления - 26.02.2024 в 14:24
NikitaDvorets Дата: Понедельник, 26.02.2024, 15:48 | Сообщение № 5
Группа: Авторы
Ранг: Ветеран
Сообщений: 557
Репутация: 126 ±
Замечаний: 0% ±

Excel 2019
Магистриус, добрый день.
Вариант с пользовательскими функциями.
К сообщению приложен файл: primer_formul_2024.xlsm (17.3 Kb)
 
Ответить
СообщениеМагистриус, добрый день.
Вариант с пользовательскими функциями.

Автор - NikitaDvorets
Дата добавления - 26.02.2024 в 15:48
Магистриус Дата: Понедельник, 26.02.2024, 16:25 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2016
Благодарю, вопрос решен. Можно закрыть тему!
 
Ответить
СообщениеБлагодарю, вопрос решен. Можно закрыть тему!

Автор - Магистриус
Дата добавления - 26.02.2024 в 16:25
Nic70y Дата: Понедельник, 26.02.2024, 16:29 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММЕСЛИМН($C$2:$C$12;$B$2:$B$12;G$1;$A$2:$A$12;">"&$F2;$A$2:$A$12;"<"&$F2+1)
К сообщению приложен файл: 153.xlsx (9.5 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=СУММЕСЛИМН($C$2:$C$12;$B$2:$B$12;G$1;$A$2:$A$12;">"&$F2;$A$2:$A$12;"<"&$F2+1)

Автор - Nic70y
Дата добавления - 26.02.2024 в 16:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск количества заказов по дате и названию товара (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!